Previous 1 29 30 31 32 33 Next 628 Replies Latest reply: Sep 6, 2014 11:42 PM by sbock Go to original post
  • Bakerchief Level 1 (0 points)

    Not sure it's a wise move yet. Some ML users appear to be experiencing similar problems with TM.

  • pdugg Level 1 (0 points)

    Well I tried everything I could think of and Spotlight still doesn't work. Since I'm a Spotlight addict and want my backups to be fast and complete via Time Machine, I rolled back my computer to 10.7.4 using Time Machine and then restored my data.


    On 10.7.4, Spotlight and Time Machine work fine. Spotlight indexing complete in two hours.


    If someone wants steps I took, reply back.

  • Dr.Moe Level 1 (0 points)


    All the workarounds from the forum (fstopping spotlight etc) and trying to fix timemachine  didnt work.


    I noticed that, like many others, that spotlight was indexing forever. Also tried several workaround tips but no one did work for me.

    But another tip from the apple forum worked for me. (MacBookPro 10.7.5)


    Dont try it if you dont have a backup (what irony....) or if you dont know what you are doing.


    1.Delete all folders in /var/folders/*   (they are named randomly like "zredgxfgewrgdgdgdgf")

    2.Reboot Mac.

    3. After that Spotlight reindexed the Harddisk within 1 hour.


    After indexing had finished i retried timemachine backup. It is running at the moment and TM copied 11GB of 17 GB. (I hope it continues to the end at least at this speed).


    Hope this helps someone. If this was posted earlier -> nevermind..

  • newbie 230 Level 1 (0 points)

    Same problem here too, and I'm running 10.7.5; come on apple please get this fixed.

  • hk700 Level 1 (0 points)

    After working for Apple for 13 years,  then selling everythiung Apple for 9 years after that, I knew not do a major update until its been in use for some time.  I've seen so many devastated people who have almost lost a lifetime worth of infos, photos, songs, etc...

    But, I did it !!!  and boy am I sorry.

    My 1 year old MB Air was upgraded to the latest in 10.7 galaxy and the first Time Machine backup read 1,166 days (after 24 hours), almost ready to buy the next Mac !!

    Tried a number of external HDs,  all proved fruitless.  Though I can manage to transport 30GB folders to/from external HDs at the usual fast rate.


    Have you tried turning off Spotlight and then do the time machine backup ?  I was advised this may really work.

    Though not through Preferences, but through the Terminal.

    Check this site:

    I'm going to try it this afternoon.


    Gotta luv em !

  • myOpninions Level 1 (0 points)

    Turning off spotlight through the terminal definitely helped me in 10.7.5


    Of course, its not a permanent fix - but I'd rather have a backup than a search tool for now.

  • Bill & Eva Level 1 (0 points)

    I'm not sure about this. I'm no geek and I wouldn't want to delete anything unless I knew what I was doing. I've tried disabling Spotlight by unticking all the search places in Preferrence. Hope that helps until Apple fix it.

  • Hal Sandick Level 1 (10 points)

    same problem.  spotlight has an estimated finish time in days and time machine backs up at a crawl.



  • jimallaway Level 1 (0 points)

    Thanks Dr Moe, your suggested fix has worked for me too. The only thing I had to do differently was have my time machine drive plugged in when the spotlight reindexing started. Reindexing took about an hour and after that the time machine back up was successfull (4gb in about 17 minutes - not super fast but it had been a while since mylast backup).



  • Dr.Moe Level 1 (0 points)

    Great that it worked for you.

    It worked also for my mac and 2 other macs of people i know.


    For what i found its safe to remove the folders. They probably contain temorary Spotlight files.

    If spotlight disabling and such didnt work for you guys, I really suggest you try this


    1.Delete all folders in /var/folders/*   (they are named randomly like "zn" or something like that.)

    2.Reboot Mac.

    3. Done

  • James Rothschild Level 1 (55 points)

    It has taken days to coerce my 10.7.5 iMac 2010 back to life.


    I tried all the above fixes, downgrades, upgrades, reinstall, on/off's ... with some or seemingly no success.


    This morning my Mac seemed to be far more spritely, and indeed Outlook & Finder searches have returned.


    I interpret this as Spotlight needing far longer than it said (3 to 4 hours) to rebuild, and settle.


    I still have TimeMachine off and am using CCCloner bi-daily to backup.


    My 10.7.5 Mac is quite usable now, I'd say at 80% :-)


    I also installed 10.8.2 onto my MacBook Pro early 2011, it crawled along for a while...

    But now it too is coming up to speed.


    Guess we have to wait a lot longer and let OSX do it's thang :-)


    Still not perfect, needs fixing by Apple, but usuable now.

  • yannig Level 1 (0 points)

    For me (mid 2009 macbookpro), it seems that indexing stopped around 60%, after "7 minutes remaining" displayed, and now, displayed time increases by the minute.

  • yannig Level 1 (0 points)

    But it worked at the second reboot, at least for the system drive.


    Now I try external (USB) drives indexing....................

  • Giles Perring1 Level 1 (0 points)

    10.7.5 is a nightmare is these regards I think. Days and days trying to get my 500GB internal drive [currently holding 280GB] to create a new Time Machine backup on an external drive with 1TB to play with. Everytime I get to 12.83GB of backup, TM started producing statistics that project millions of days to complete the job. Tried sticking the drives into Privacy in Spotlight. That just knackered Spotlight too when I fired it up again. It currently claims it needs 5 days to index my drive. What I can say is that good old Carbon Copy Cloner has done the business as far as it can in appreciably quicker time [about 2 hours]. I'm going to bite the bullet and head back to Snow Leopard. Lion has been nothing but trouble...

  • peterpaulfromvenlo Level 1 (0 points)

    What worked for me:


    Download Houdini and start it up. This app makes invisible files and folders viewable. Then:


    1.Delete all folders in /var/folders/*   (they are named randomly like "zn" or something like that.)


    2.Reboot Mac.


    3. Done


    Spotlight and Time Machine works fine after indexing and backup...


    Fingers crossed

Previous 1 29 30 31 32 33 Next