Previous 1 39 40 41 42 43 Next 628 Replies Latest reply: Sep 6, 2014 11:42 PM by sbock Go to original post
  • Cyberspace Travel Level 1 (0 points)

    Thanks for the suggestion.  I resolved it on my Mountain Lion 10.8.2 system,

    without any command line hacks (since that can complicates support if

    one needs resort to it later).


    I realized my first priority was backups, with Spotlight indexing behind that.


    After reading various forums, it seemed likely that Spotlight was thwarting

    Time Machine, not the other way around.  So here's what I did:


    1. Went to Energy Saver preference panel and disabled automatic power off

        of system (and disk drives), until such time as the issue was resolved.


    2. Stopped Time Machine (since it hadn't accomplished much more

        than 4Gb in 24 hours),


    3. Removed Time Machine backup disk as Time Machine's backup target drive,

        effectively disabling backups (in the time machine dialog, I didn't physically

        remove any drives).


    4. Dragged system disk into the privacy column, in Spotlight Preferences,

        under System Preferences, which terminated Spotlight's indexing efforts

        almost immediately.


    5. Booted system in failsafe mode, ran disk utility, fixed permissions

        and repaired system disk, though it reported no errors.


    6. Rebooted Mountain Lion 10.8.2, normal mode


    7. Set Time Machine backup disk again.  


    8. Time Machine steadily backed up and completed 200Gb in 2 hours,

        never pausing for any noticeable amount of time.


    9. When Time Machine completed, I went back to Spotlight Preference pane,

        and removed the system disk from the privacy list.


    10. Spotlight started indexing, reporting a 20 minute completion estimate, within

         a few minutes of starting.  (When it was in the stuck mode, previously, it kept

         promising an estimate, but never arrived at one).


    11.Spotlight completed on time and both Spotlight and Time Machine

         have been working flawlessly ever since.


    I suspect what got me into trouble was that I used Migration Assistant

    to bring over another system.  But there was a conflict with new and old

    user names, and so I wound up renaming accounts and having to chown -R

    my home directory (I'm a unixy guy).  While I was doing that, spotlight

    was probably indexing and got confused by the way things were changing

    around beneath it.



    Message was edited by: Cyberspace Travel

  • Larry Nolan Level 2 (175 points)

    Bravo and congratulations.


    Regarding your use of Migration Asst. - had you created a user account with the same name as one in the old system and then had Migration Asst. transfer files?  Trying to understand what you meant by 'a conflict with new and old user names'?

  • Cyberspace Travel Level 1 (0 points)

    Yes, I'd already established an account with the same name as I had on the old system, on the new system, before attempting the migration, so it reported a conflict and forced me to rename the incoming account that had the data I wanted to keep, away from the original user name.


    So, after Migration Assistent completed, I renamed the new (empty) account out of the way, and renamed the incoming acount to its original name, and then determined the user IDs/names of the new and old users and did a chown -R of the renamed directory to match the account I'd just moved the data over to. 


    Not too happy about the way Migration Assistant and the Users & Groups preferance panel handled that, as it wasn't obvious how to proceed there, but my plan worked, other than thwarting Spotlight.  So all is good now.

  • Pondini Level 8 (38,715 points)

    Just for future reference, using Setup Assistant when your new Mac first starts up avoids that hassle -- since there's no user accounts on it yet, that can transfer accounts "as is."

  • Angela Mac User Level 1 (0 points)

    Well done and thank you Cyberspace Travel.

    I was experienceing the same problems with my WD My Passport and Time Machine. 17 days was my estimated to back up 200GB!!

    After disabling Spotlight it backed up in just under 3 hours.

    Great :-)

  • joern42 Level 1 (0 points)

    i deleted my free avira installation, now it works fine.

  • Thanar Level 2 (290 points)



    I've been having speed issues lately with my Time Machine backups so ended up reading the entire thread. I think I did the supplemental update when it was issued, I am however in the same situation.


    My setup backs up on a network drive (USB HD connected to another iMac on the network running 10.8.2) and it's been a few days now it needs an hour for an 80MB worth of backup data. Reinstalled 10.7.5, applied supplemental update just to be sure, but things are not pregressing as expected.


    Will try deleting the entire Spotlight index and check again.


    I have also tried changing the Time machine destination using "tmutil setdestination" command to the mounted sparseimage volume and not the network drive. That way, the backup finished almost instantly, but upon changing the target back to normal (selecting the network disk through TM preferences), I am still getting very long backup times.

  • Thanar Level 2 (290 points)

    I should also add that, except from the backup process being very slow, I am facing great lags when acessing the backups, I have to wait a couple of minutes before I am able to navigate through time, looking at the starwars animation being able to do nothing.

  • Pondini Level 8 (38,715 points)

    Try Repairing the backups, per #A5 in Time Machine - Troubleshooting.


    If that doesn't help, try the rest of the things in #D2 there.

  • Thanar Level 2 (290 points)

    I have tried all of the troubleshooting techniques in Pondini's tutorial, however I have been unable to fix the issue. The only way to make TM work as fast as it used to is to set the target to the mounted volume using tmutil setdestination. That way, both backing up and searching though the TM database works blazing fast. However, as soon as I switch back to normal (that is, setting the network drive as the destination) the whole thing becomes sluggish again.


    My next bet is upgrading to Mountain Lion, but I am readings about some similar issues over there, too...

  • wcrowder Level 1 (0 points)

    I had no issues at all until I used my backup. since using it to restore the system, it takes forever to send a backup through timemachine to my external HD.


    should i just wait for spotlight to index my HD? im running the latest OSX. I tripple checked.

  • Csound1 Level 8 (46,335 points)

    Let Spotlight finish first.

  • wcrowder Level 1 (0 points)

    Im new to Mac. How to chech the status of the indexing, and if i used my backup to restore...why was the index erased? just as easy for apple to backup up the essential stuff, and let xsx rebuild it later- i guess?

  • Csound1 Level 8 (46,335 points)

    Click on Spotlight and see if it is indexing or not.


    Spotlight needs to reindex the disc after a restoration, it may well be largely the same but how does Spotlight know?


    Be patient.

  • Pondini Level 8 (38,715 points)

    Time Machine automatically skips a number of things, including the Spotlight index, system work files, most caches and logs, trash, etc.  See the tan box in Time Machine - Frequently Asked Question #11 for the gory details.


    Since many or most of those change frequently, they'd have to be backed-up in full on each backup, taking time and space on the backup drive, without accomplishing much at all.