Previous 1 2 3 Next 123 Replies Latest reply: Mar 7, 2014 3:27 AM by MarkQV
Thetechnogeek Level 1 Level 1

Got my white 32Gb iPhone today, but am having severe problems with WiFi. I have an airport extreme, and the iPhone detects both bands, and after a few attempts accepts the password required to connect. However, I get no internet connection, and the iPhone continuously drops back to indicating "3G" before it'll fetch any data. I have reset network settings, and now done a restore- neither make any difference.


Hugely disappointed, seems like I have a faulty phone- or is anyone else having the same problem?

  • Singx2 Level 1 Level 1

    I'm having the same issue. I'm able to connect to my WIFI network but can't seem to get internet working consistently.  I have 3 other iDevices working on the same wifi network, as well as an Android.  The NEW iPhone 5 with iOS 6 just refuses to stay connected. It would connect for 3 minutes before losing internet access on Wifi. I will then have to reset the network again to get it working for another few minutes before losing internet access. Mind you, I'm actually connected to the router (with a wifi symbol) but can't seem to get internet access.  Very frustrating. I hope its a problem that can be fixed with an update.  I'm kinda disappointed.

  • Singx2 Level 1 Level 1

    Okay...did some trial-and-error tests..It seems the iPhone 5 was having trouble with WPA/WPA2 wireless encryptions. I'm currently using WEP, and the iPhone is able stay connected (with internet access) for longer than a few minutes.  As of writing, it has not dropped access for 20 minutes.  Again, I really hope this isn't a hardware problem and a software update will be able to fix this issue.  I really don't want my iPhone 5 to work under WEP only as most standard hotspots are WPA. 

  • gapeee Level 1 Level 1

    You are not alone. I am facing the same problem here, on my 64GB IP5. Now trying a restore to see if it will do the trick. I hope it's a software issue as well, not a hardware one as it would pain me to have to get a new replacement set just within the first day. Any solutions other than having to change the WEP so far? I have tried this with 2 routers (WPA/WPA2) and have had the same issue - zero or little connectivity though I am connected to the network.

  • Thetechnogeek Level 1 Level 1

    Changing to WEP (or even no security) has not helped. Sad to say my new phone is going back, it's unuseable as it is. I hooked up to another network as well, didn't sort the issue, so I know it's not a router issue. Not impressed with Apple at all!

  • Singx2 Level 1 Level 1

    I have the 64GB as well.  Setting the Router to WEP seems to be the only solution that has worked for me.  Please let us know the result after restoring.  Thanks.

  • dissonation Level 1 Level 1

    Same problem here. iPhone 5 64GB, AirPort Extreme 5th gen, I get maybe 5 seconds of wi-fi before it fails. Changing to WEP (option click the security settings drop down if you want to try it) hasn't helped.


    I really hope theres a software fix for this...

  • radougherty Level 1 Level 1

    Half of the issue here with iPhone 5 32GB. I can connect to my band b/g/n network using WPA2 but can't to the band a/n network. No problems connecting to the a/n network with an iPad 2012 sitting right next to where I'm trying the iPhone 5.

  • michaelchan0427 Level 1 Level 1

    My IP5 32GB black can only detect personal hotspots created by my iPhone4...... no other WIFI can be detected at all......

  • gapeee Level 1 Level 1

    Apple needs to fix this and fix this fast. What are we to do while we sit there and wait without wifi access? Really hope a software update does help. Just did a restore and still no luck with WPA mode with WMM disabled. Every other device seems to be working fine. I really hope I don't have to settle for a replacement set, after just having applied and spending $$ for the screen protector...

  • Jettaguy03 Level 1 Level 1

    I to have a 32gb that cannot connect to wifi.  It connected for a short time this morning so I downloaded music and apps.  Then crapped out and went over my data downloading the rest!  Hasn't connected since.  My 4 next to it has no troubles.  Oh, it is an unsecured Netgear router.  It still shows that the router is available, but doesn't connect.


    The new screen is also yellow and looks dirty.  Disapointing compared to my 4.  I seriously hope I dont find myself at the Apple store for an exchange.

  • holdrege Level 1 Level 1

    FWIW I just got an iPhone 5, 32GB and it works fine with WiFi from multiple AP's. I'm mainly using it with an Orange Livebox and WPA2.

  • jason125 Level 1 Level 1

    I have tried all the reset and security options people are suggesting in various forums, but wifi still drops after 30 seconds of use.  Called Apple support, my guy hadn't even heard of the problem.  I am pretty frustrated.  Hopefully there will be a fix that doesn't involve replacing my unit--which probably wouldn't be able to happen for weeks anyway.

  • Jettaguy03 Level 1 Level 1

    I put it on top of my router and it found the signal (duh!) and seems to keep it.  I turned it off/on and the signal came back after i went into settings > network.....  It didnt last after i reset the phone, i had to go back into settings and manually connect.  It doesnt want to automatically pickup anything.  I am 15' from the router and the signal is strong.  Frustrating.

  • michaelchan0427 Level 1 Level 1

    Turns out it was simply because my iPhone5 was next to the iPhone4 and hence it can detect the personal hotspot. I tried putting my iPhone 5 on Top of the Time Capsule and wireless works fine..... and the furthest distance the iPhone 5 can connect to the wifi is 2 feet......

Previous 1 2 3 Next