5 Replies Latest reply: Sep 26, 2012 4:07 PM by traderx13
chip campbell Level 1 Level 1 (0 points)

I have had multiple attempts failed, which are followed by a warning message to repair the library.

After clicking to repair library it does so successfully and then tries to reopen Apreture, which proceeds

to fail and the cycle starts over again.  What may be causing this/ How do i go about fixing it?


MacBook Pro (13-inch Mid 2010), iOS 6
  • 1. Re: Aperture 3.4 will not open on OS 10.8.2
    Barry Fisher Level 3 Level 3 (655 points)

    I had a similar thing happen, not exactly the same, after updating to 10.8.2 Ap would open but would go black if I tried to take a photo to "full screen".  I closed and reopened a couple of times, repaired permistions, etc.  I then got a pop-up that there was an Aperture update.  Applied it and all is good.  Try check for software updates.

  • 2. Re: Aperture 3.4 will not open on OS 10.8.2
    chip campbell Level 1 Level 1 (0 points)

    I have dowloded an update that I was prompted to by the App Store after the 10.8.2 update and have repaired permissions since the trouble started. No new updates are available.  I will try again but in the meantime any other suggestion are welcome.

     

    Thanks for the help!

  • 3. Re: Aperture 3.4 will not open on OS 10.8.2
    KevinMcAleer Level 1 Level 1 (0 points)

    I'm also having the exact same problem. I'm on 10.8.2, have the latest patch of Aperture 3.4 installed and it just keeps saying my library needs repairing, completes the repair then crashes.

     

    I've checked the Aperture crash report and it says:

     

    *** Terminating app due to uncaught exception 'NSInvalidArgumentException', reason: '*** -[NSURL initWithScheme:host:path:]: path 819119309 is not absolute.'

  • 4. Re: Aperture 3.4 will not open on OS 10.8.2
    chip campbell Level 1 Level 1 (0 points)

    Ok I had the same issue. I had to delete aperture.app from my applications folder, which doesn't delete your library it is a separate file.

    Then I reinstalled from my disk (aperture 3.0), when I tried to open it told me my library could not be used because it was from a newer version of aperture. And the app would close.

    I then moved my aperture library from my pictures folder to my desktop and reopened aperture, which will open up a new library with nothing in it.

    Go ahead and update aperture now, I suggest doing it with nothing else running, as I believe this problem has been caused by not getting a Clean install while updating.

    Close aperture and move the aperture library file back from the desktop to the pictures folder and overwrite the existing on, that was created when you opened aperture.

    Then I opened aperture again and everything is back to normal.

     

    I suggest a backup before just in case something happens. And hope this helps

  • 5. Re: Aperture 3.4 will not open on OS 10.8.2
    traderx13 Level 1 Level 1 (0 points)

    Here's your solution. I had the same problem and the Genius at the Apple store was actually friends with the guy who wrote 3.4.

     

    http://support.apple.com/kb/TS4412