Previous 1 10 11 12 13 14 Next 267 Replies Latest reply: Nov 17, 2014 10:33 PM by flipperfeet Go to original post Branched to a new discussion.
  • Danny ICT Level 1 Level 1 (10 points)

    Hi Billy,


    Try a wired keyboard in stead of a wireless keyboard and see if this solves the wake-up problem.


    If not,

    go to your 'User library' and than to 'preferences'.

    Delete these two files:




    Restart computer.

    Repair disk permissions.

    Try again.


    If the problem is still there,

    make a (temporary) new user.

    Try the wake up issue in this new user and see if the problem is gone.

    If the problem is gone, maybe more preferences and/ or caches in your user library became corrupted.


    If problem is still there, disconnect all third party usb and firewire devices that are (wired) connected to your mac.

    Try again.



    Best regards,


  • Danny ICT Level 1 Level 1 (10 points)

    PS Billy:


    the little battery inside newer mac's are not re-charge-able battery's.

    Mostly they are just normal CR-2032's



  • T3GT Level 1 Level 1 (0 points)

    Thanks Danny....I'll give it a shot....


    I was having this issue bad yesterday, but today, it's been waking up like normal -- all day....


    Of course now since I've mentioned it, it'll probably start staying asleep on me now....LOL....


    Not sure about how to change the battery, I have a mid-2009 MacBookPro, and I know there's no battery compartment, it's built into the laptop.



  • Danny ICT Level 1 Level 1 (10 points)

    Hi Billy,


    I ment the PRAM battery on the print, not the normal (power supply) battery.

    Since your MacbookPro (MBP) is from 2009, the PRAM battery probably will be fine.


    It's possible that the (normal) battery in your MBP was almost empty (1-3%) so needed loading.

    It than sometimes happens that the MBP won't wake up.

    As soon as you connect the power supply and than try to wake it after 5 minutes,

    it will problably work.


    Best regards,




  • dcoughlin Level 1 Level 1 (5 points)

    Thanks so much for this fix!  I've had this sleep/wake issue for years with my Mac Pro 2009 and this finally fixed it.

  • Pharmacoapple Level 1 Level 1 (0 points)

    I'm left hopless still.


    MBP mid-2010 running ML 10.8.2




    1. Reset PRAM + SMC


    2. NO VIDEO CARD DRIVERS AVAILABLE TO INSTALL (Nvidea 320M) unlike the other cases where it fixed the problem


    3. Have delted:

    all it did was remove my login screen

    4. Have done a Clean install -- the problem did not happen for 5 days (a record) a then happened again


    5. Repair disk permissions several times


    Still no solution.


    Anyone have any other advice?



  • Danny ICT Level 1 Level 1 (10 points)

    Hello Pharmacoapple,


    As I posted on the 22th of February, try to do this:



    To temporary solve sleep mode problems in 10.8.2 with every Mac,

    is to change the sleep mode of the computer into 'never'.


    Best regards,


  • Berend de Meyer Level 1 Level 1 (10 points)



    My findings on my MP 3.1 OSX 10.8.2:


    Enabling in system preferences "SHARE"



    1. External Loggin

    2. External Management


    KILLED the wake-up from sleep option using mouse and/or wired keyboard!!!!


    Dissabling both got my MP back on track again.




    I'm still struggling to find out about the WOL issue!



  • Berend de Meyer Level 1 Level 1 (10 points)

    Additional information:


    I have no on my MP 3.1 OSX 10.8.2!





    Goodluck boys and girls! Enjoy your weekend!

  • Pharmacoapple Level 1 Level 1 (0 points)



    Unfortunately this has not solved my problem.


    I've changed the sleep preferences to never for computer sleep but not display sleep, as it's rather damaging in the long run.


    After changing computer sleep to never, the problem still persisted.



    *This is extremely frustrating and I hope that Apple fixes this already!

  • trypt Level 1 Level 1 (0 points)

    - MBP 13" mid 2012 i7

    - DIY upgrade to 16GB DDR3-1600

    - DIY upgrade to dual Intel 520 SSD 480GB

    - CCC whole system from my old MB 13" early 2009 (10.8.2)


    I had the similar problem, finished work on MBP, left the lid open and go out or goto bed, came back and press spacebar or enter twice, the screen woke up in pure black, I can see the dim led light at the edge of the screen. One thing to point out, if I left it to sleep mode but came back within 3~5 minutes, it will resume to normal, but longer than that it's dead black.


    These are the things I've tried and didn't work:

    • Reset PRAM, NVRAM, SMC, safe mode, etc.
    • pmset hibernate mode to 0, 3, 25 or whatever numbers.
    • CalChloe methods:
      - Boot with Command+R mode.
      - Run Disk Utilities, repair permissions, repair disk.
      - Reboot.
      - Open Finder, hold down Option and click Go from the menu and select Library.
      - Delete Cache & Cookies folders, empty the trash can.
      - Reboot.
    • Mess around with all the possible combinations at Energy Saving prefs.


    *** There's this old widget called DeepSleep, delete it if you have it at all cost, it does nothing but mess up your hibernatemode. No matter what hibernatemode I've setup, it alters to 5 & 7, which are not compatibible with 10.8.2


    These are the things I've tried and might have worked as the solution, in exact steps:

    • Grab a clean install 10.8.2 on my external backup hd and migrate all my profile and settings to it.
    • Perform the CalChloe methods on it.
    • CCC (delete every thing) it back to my MBP main bay SSD.
    • Reset PRAM, NVRAM, SMC, safe mode, etc.
    • Open Terminal and pmset hibernate to 3, "sudo pmset -a hibernatemode 3"
    • Open Energy Saving prefs:
      - Uncheck every checkboxes.
      - Battery set to 5 secs / 5 secs.
      - MagSafe set to Never / 15 mins.
    • Swtich back to Terminal and type "pmset sleepnow".
    • Test to wake up from 3, 5, 10, 15, 20, 60, all night upto 420 mins and it's normal.
    • Each wake up "pmset -g log" to see the differences.
    • Each wake up "pmset -g | grep hibernatemode" to check your mode is intact.


    Now my MBP with 10.8.2 is working fine, I'll keep testing for upto a week to see if any comebacks.

    I also check the update list, I have installed.

    I haven't installed, and


    Also attached my Terminal SS for ref.2013-03-04.jpg


    That's about it.

  • Berend de Meyer Level 1 Level 1 (10 points)

    Is Apple forcing all of us to prepair our MAC's for a trip around Mars or something like that? Some work-arounds are pure rocket-sience to me!!!!!


    Come on APPLE give us a break and fix this!!!!!

  • aviram Level 1 Level 1 (5 points)

    I believe that this is an in ability to wake up from "safe sleep" which turned into hibernate after a certain amount of time


    there are several sleep modes:


    regular sleep just cut off power to disk and monitor, but keeps the RAM powered.


    safe sleep keeps RAM powered but also writes the contents of RAM to disk, just in case power is cut off (usually for laptops where battery can be drained/removed, but normally would wake up from RAM


    deep sleep is full on hibernation, RAM is written to disk and the machine is shut down.


    check your hibernatemode:


    pmset -g | grep hibernatemode


    0 = no hibernation i.e. regular sleep


    1 = immediate hibernation i.e. deep sleep


    3 = safe sleep


    25 = agresive pageout with deep sleep.


    therefore it could be that you mac can wakup from short sleeps before hibernation, i.e. before writing RAM to disk, but once memory is written to disk and power is cut off, it will not wak up.


    check your hibernatemode



    my first iMac (27" late 2012) was exhibited the fan going on full blast upon connecting to power, off when the machine was booted, and on again when the machine was off.


    I am now on my third replacement iMac, the last two are exhibiting identical issue with sleep: the machines will go to sleep and will not wake up, and in addition the power button is disabled, i.e. pressing the power button will not restart the machine.


    I am guessing that the SMC crashed, as the only course of recovery is to reset the SMC by removing power, pressing the power button for a while, and attempting to restart (does not work all the time, so I sometimes have to repeat the SMC reset procedure).


    after doing some research on the net, I found how to view the hibernate mode, and saw that my machine was set to hibernate mode 5, which is NOT an approved setting, see below.


    I used the system pref -> energy saver and clicked restore defaults which restored the hibernatemode to 0.


    HOWVER, upon plugging in a powered USB hub, the hibernate mode was automagically reset to 5.

    once at hibernate mode 5, putting the machine to sleep manually exhibited the same symptoms, i.e. not wake from sleep and disabled power button.


    this was done with an apple care tech on the phone, and he recommended replacing the iMac once again, and sending me a fourth replacement!


    overnight I played some more with this


    I reset the hibernate mode but this time to 3 and I tried a different USB hub.


    hibernate mode stayed at 3 after plugging in the USB hub.


    I then created a small shell script to monitor and display the hibernate mode:


    function showhibernate() {

      while true

        do echo -n `date` " ";pmset -g|grep hibernatemode;sleep 10




    and executed it overnight


    this evening after I came home from work, I noticed that the  hibernate mode somehow was switched from 3 to 7!?


    unfortunately, I did not have the echo `date` on the first version, so I do not know when it was switched from 3 to 7.


    however, the machine did wake up from sleep... (so it seems that 7 is not as bad as 5?)


    I am guessing that some powered USB hubs cause unexpected changes to the hibernatemode, which in turn cause the SMC to crash, disabling the power button.


    why plugging in some powered USB hubs but not others will cause the hibernatemode to switch to 5?


    why hibernate mode would automagically switch from 3 to 7?


    neither 5 nor 7 are documented in the man page, and the only recommended modes are 0 3 and 25:


    We do not recommend modifying hibernation settings. Any changes you make are not supported. If you choose to do so anyway, we recommend using one of these three settings. For your sake and mine, please don't use anything other 0, 3, or 25.


    For now I cancled the shipment of the fourth replacement, as this seems to be an issue affecting all iMacs (and a specific USB powered hub), so that a new machine will not resolve the issue...


    bottom line, remove the USB hub, and/or try another one.


    hope this helps.

  • phased Level 1 Level 1 (0 points)

    so, still no real fix here? really disappointing, i must say.


    same problems as most in here, mid-2009 macbook, running 10.8.2.


    i also suspect it has something to do with the graphics card, as I do not remember experiencing this problem when the 'better battery life' option was selected in the energy saver preferences, as opposed to 'higher performance'. has anyone experienced / tested this? i'm tempted to return the settings to 'better battery life' to test this theory, even though such a setting is detrimental to my workflow.

  • trypt Level 1 Level 1 (0 points)

    Mine's fixed, I haven't met the problem ever again, thought you might wanna try my precudure~ Cheers.

Previous 1 10 11 12 13 14 Next