Previous 1 5 6 7 8 9 Next 267 Replies Latest reply: Nov 17, 2014 10:33 PM by flipperfeet Go to original post Branched to a new discussion.
  • Thor777 Level 1 Level 1 (0 points)

    Hi,

     

    I had the same problem after installing a new SSD and reinstalling Mountain Lion fresh from the AppStore: after going to sleep I got problems when waking up. Either the whole system froze instantly, sometimes I could use it but within seconds one application by another started to freeze. It seems, the system could not access the disk (no entries were written into the system.log upon wakeup !)

     

    I finally solved the issue by first starting the original 10.8.0 Installer which gave me - after reboot into the main installer - the option to "repair" (or "restore") my system.

     

    After that everything worked perfectly. All my settings still existed.

    I only got some problems which were resolved after clearing all cashes etc. (using Onyx).

    As the latest iPhoto won't work with 10.8.0 (needed 10.8.2) I finally decided to give it a try using the downloaded Combo-Installer (10.8.2) from apple.com.

     

    Now I am using 10.8.2 incl. Suppl.Update for over a week with no problems concerning wake up from sleep !

     

    Hope, it will help you !

  • Kurtz25 Level 1 Level 1 (0 points)

    Mine is fixed now, too, after runing disk repair and deleting cache and cookies from the Library.

  • Barbara Passman3 Level 2 Level 2 (180 points)

    resetting SMU did nothing for me. My MBP awakens easily if I sleep it from the Apple menu or let it go to sleep per what I set in Energy Saver preference

    I Only have issue when reconnecting the  powered up - but lid closed MBP to my Thunderbolt monitor.

    That seems to cause deep sleep or shut down. I now wonder if my issue is related to  the MagSafe connector of the Thunderbolt display or the converter I need to use to connect my MBP to the Thunderbolt monitor.

    Last night when I went to manually power up the "dead" Mac I also was alarmed as the power button on the MBP did not respond for four or five pushes. FInally, a heavy push on it got the Mac going.

    Very weird

  • Sascha_Rheker Level 1 Level 1 (0 points)

    "Mine is fixed now, too, after runing disk repair and deleting cache and cookies from the Library."

     

    Permanently or temporarily?

  • Tak Boleh Sebut Level 1 Level 1 (0 points)

    I'm observing the exact same problem. Logged report with Apple and still waiting for their reply.

  • Barbara Passman3 Level 2 Level 2 (180 points)

    sorry you, too, are having a problem

     

    I took my MBP Retina to our apple store this weekend

    Genius is convinced my MBP does not shut down but, rather, goes to sleep  so i have a variant of the "not wake up" problem . But 99% of the time only when trying to re attach to my Thunderbolt 27" monitor. Lots of tests, lots of console log checking. We tried to replicate the problem with the MBP on its own, attached to several different monitors.

    Could not replicate

    The issue could be my monitor.- I may have to take it in to the Apple Store (not fun; the thing weighs 30+ lbs)

    The only other thing I just did was,in Energy Saver, to UNCHECK the Power Nap feature as  I wonder if that might confuse the Mac when I reconnect it to my monitor

    My MBP wakes up well all other times, just not when put to sleep via closing lid (clamshell mode) and then attaching to my monitor.

    Very strange, indeed

     

    Tak Boleh Sebut, please post if Apple give you any infornation.

  • bonfire Level 1 Level 1 (10 points)

    Ok, I've got great news for some of you.  I've got a macpro (early 2009).  After upgrading to 10.8.2 and changing the energy saver preferences to use the wake on ethernet option, I've had the un-wakeable sleep problem and its driven me nuts the past week!

     

    I suggest you all carefully look at your /var/log/system/system.log file, as well as the /var/log/DiagnosticMessages/{date}.asl file.  (you can read those with syslog -f {filename}).  That is how I traced down the source of my problem.

     

    So here's my situation. My monitors would sleep at exactly the time interval specified in energy saver preferences, note that the status light next to the powerbutton would stay solid.  Then computer would then sleep roughly the time I expected it to, but rarely at the exact time.  Anyways, after going to sleep, I'd hear a click and the status light  would go from solid to the heartbeat thing.   After reviewing the system.log, I noticed that precisely 2 hours after sleeping, the computer would go into a maintenance mode.  You'll see this in the system.log:

     

    Oct 26 14:51:25 MacPro kernel[0]: Wake reason: RTC (Alarm)

    Oct 26 14:51:25 MacPro kernel[0]: RTC: Maintenance 2012/10/26 21:51:24, sleep 2012/10/26 19:51:27

    Oct 26 14:51:25 MacPro kernel[0]: No interval found for . Using 8000000

    Oct 26 14:51:25 MacPro kernel[0]: Graphics suppressed 0 ms

    Oct 26 14:51:25 MacPro kernel[0]: Previous Sleep Cause: 5

    Oct 26 14:51:25 MacPro kernel[0]: Intel82574L::setLinkStatus - not active  1face000, 0

    Oct 26 14:51:25 MacPro kernel[0]: Intel82574L::setLinkStatus - not active  1face001, 0

    Oct 26 14:51:25 MacPro kernel[0]: Intel82574L::setLinkStatus - not active  1face000, 0

    Oct 26 14:51:25 MacPro.local configd[17]: network changed: v4(en1-:192.168.1.239) DNS- Proxy- SMB

    Oct 26 14:51:25 MacPro kernel[0]: Intel82574L::setLinkStatus - not active  1face001, 0

    Oct 26 14:51:28 MacPro kernel[0]: Ethernet [Intel82574L]: Link up on en1, 1-Gigabit, Full-duplex, Symmetric flow-control, Debug [796d,af48,0de1,0200,c5e1,3800]

    Oct 26 14:51:28 MacPro kernel[0]: Intel82574L::setLinkStatus - active  1face001, b

    Oct 26 14:51:32 MacPro.local configd[17]: network changed: v4(en1+:192.168.1.239) DNS+ Proxy+ SMB

    Oct 26 14:51:34 MacPro kernel[0]: Intel82574L::timeoutHandler - no link - reset the chipset once  1face000, 0

    Oct 26 14:51:34 MacPro kernel[0]: Intel82574L::setLinkStatus - not active  1face000, 0

    Oct 26 14:52:05 --- last message repeated 2 times ---

    Oct 26 14:52:10 MacPro kernel[0]: NVDA::setPowerState(0xffffff801df17000, 0 -> 1) timed out after 45476 ms

     

    Note the 4th line, where it says graphics suppressed, then the last line where it says NVDA:: .... timed out....  That was the clue I needed.  It seems that this maintenance mode wakes up to turn on the network interfaces, but tries to suppress the graphics card from waking up... However, the graphics card just times out. Apparently it doesn't support this action very well.  I carefully watched my system and precisely 2 hours after it goes to sleep, I hear the system click, and the status light would go from heartbeat to solid....  Thats when the system freezes and you can no longer revive it.  Actually, to be clear, the system was still accessible by ssh, so more accurately I'd say that probably it was just the graphics card was frozen... Nothing but a reboot would fix it.  Note that I even tried issuing a reboot via SSH (thinking that was slightly safer than just holding the powerbutton), and although it did shut down some services (like SSH) it wouldn't complete the reboot and I'd still have to hit the Power button....

     

    So anyway, now that I was pretty sure it was graphics card related (and triggered by the maintenance mode apparently related to the wake-on-lan), I googled 10.8.2 and nvidia... and what do you know?  Nvidia released new drivers specifically for 10.8.2 this month!

     

    This is the driver I needed for my stock GeForce GT 120:

    http://www.nvidia.com/object/macosx-304.00.05f02-driver.html

     

    PLEASE read the notes, it says its that this particular driver is for MacPro's only and 10.8.2 only.

     

    Possibly check for drivers for other nvidia cards if this isn't you!

    http://www.nvidia.com/Download/index.aspx?lang=en-us

     

    So I installed the driver, rebooted, and voila, all works fine.  I let it sleep, it went into maintenance mode after sleeping for two hours, and this time the monitor came on for 30 seconds, then went back to sleep (again with the heartbeat).  I could issue a wakeonlan signal and then ssh in, or I could wake the computer by pressing the power button briefly.  From my perspective, all is working fine.  I can wake it properly from the power button, and I can wake-on-lan it properly too.

     

    And just for reference, I use this wake-on-lan perl script.  It works great, even through a router and wifi.

    http://gsd.di.uminho.pt/jpo/software/wakeonlan/

    I didn't realize this at first, but when sending the wakeonlan through a router you don't specify the IP address of the computer you're trying to contact.  Just use the default ip (255.255.255.255 or your local network broadcast ip, like 192.168.1.255).  The problem with routers is that once you're computer sleeps the router forgets your computer, so you need to broadcast the message to ALL ips and wait for the right one to match the macaddress and wake up... So just run it like "wakeonlan <macaddress>" and it works perfect.  It even wakes my macbookpros connected only by wifi.

     

    Also note that I tried the "darkwake=0" thing as well.  I'm not really sure if that made any difference, but it is still set that way on my machine.  You may or may not need that, I'm just not sure.

     

    And one last note, I called applecare thinking my macpro still had coverage, but it turns out it expired a few months ago.  They had me explain the problem anyways and said this is a "known issue" and that they could fix it for $59 or whatever.  I told them no and figured it out on my own, but, it kinda ****** me off considering this was NOT really a hardware problem.  It was an issue introduced by OS X 10.8 and I just recently PAID for this O/S upgrade.  Personally I think they should be supporting this since I bought the O/S.  My hardware was fine, it was the stock graphic card drivers bundled in 10.8.2 that was the problem!  I fully assume that a future upgrade (maybe 10.8.3 if you're lucky) will include the updated drivers...  Until then they're happy to NOT publish this simple fix anywhere and charge you for it instead.  VERY LAME APPLE!

     

    Best of luck to the rest of you.  If this doesn't solve your problem, check those log files I pointed out, try to pinpoint the time your machine freezes and look for related events in the log files!

     

    Cheers,

    Rob

  • Sascha_Rheker Level 1 Level 1 (0 points)

    Thank you very much, Rob!

     

    This was the first thing that really resulted in an improvement.

     

    I can't say if it is completely fixed as I  installed the driver less than hour ago, but for now I can say that my Mac Pro woke from sleep for the first time since weeks!

     

    Sascha

  • Chet Rindfuss Level 1 Level 1 (40 points)

    I thought I had my MacBook Pro fixed but after reading bonfire's post I checked and found I was running with the better-battery-life option. That does not use the graphics card. I changed the graphics to higher-performance and the wake from sleep issue returned. My graphics card is NVIDIA GeForce 9600M GT and I cannot find any updates for it.

     

    Still looking into this to see if there are alternatives.

     

    Turning off the wake-for-network-activity avoids the problem so I'll be running with that option turned off until I can find a better solution.

  • Sascha_Rheker Level 1 Level 1 (0 points)

    Mine froze again tonight despite of the graphic card driver update.

  • bonfire Level 1 Level 1 (10 points)

    bummer, sorry to hear this didn't help.

     

    clearly, there are various video driver / sleep issues going on, I even read on the NVidia site about known osx/sleep issues.

     

    If you look closely at your /var/log/system.log - if you find something like this line:

     

    NVDA::setPowerState(0xffffff801df17000, 0 -> 1) timed out after 45476 ms

     

    then you know this is likely a video driver problem.  If so, then I'd keep my eye on the nvidia website, maybe even try emailing their support so you can get notified when an update does come out for you.

     

    it was that message that popped up at precisly the time my machine would freeze up - and after my driver upgrade, that message no longer shows up, and I no longer have the problem.  if you're lucky, they'll be releasing more updates soon.

     

    Best of luck.

    Rob

  • bonfire Level 1 Level 1 (10 points)

    Sascha, were you getting the "NVDA .... timed out ..."  message before the driver update?  Are you still getting it after?

     

    Note that it was the maintenance mode that runs precisely 2 hours after sleeping that triggered this problem.  If this is when your system becomes un-wakeable (like mine), investigate your /var/log/system.log file, look for the first logged "Wake reason: RTC (Alarm)" after your last crash.  That should be logged at 2 hours after sleeping.  Your computer wakes up and runs, turns on your network interfaces, etc...  It was right after that I used to see the "NVDA ... timed out..." messages.  If thats not your problem, maybe its another device that is having problem waking up and shutting down, causing the issue.  There might be some clues there somewhere.

     

    best of luck,

    Rob

  • Chet Rindfuss Level 1 Level 1 (40 points)

    Just had a wild thought on this problem.

     

    The condition appears to start with an RTC alarm. This is related to wake-for-network-access as it does not occur when that option is off. RTC generates a Full Wake / Dark Wake / Maintenance Wake mode--see messages in system log file. As this is a dark wake the display is turned off. Following this wake we see a time out of the graphics driver (or card.)

     

    Is the graphics card timing out because the dark wake turned it off? When the next command to the card is issued, the card isn't listening. I noticed that if I use the better-battery-life energy saver option that uses memory instead of the graphics card, I do not have the hang problem. System sleeps and wakes normally even with wake-for-network-access on. Anyone want to bet the problem is the graphics card is turned off?

  • Sascha_Rheker Level 1 Level 1 (0 points)

    Ron, I deactivated "wake on LAN" and things seem to have improved.

     

     

    Before that it even woke once or twice instead of freezing.

     

    It's a strange thing, I never experienced anything like that with a Mac...

  • NatureHelps Level 1 Level 1 (0 points)

    I have voiced my problem previously on this forum: MacBook Pro7,1 13" 8GB RAM 256GB HD. After trying many varied suggestions made in forum. MacBook still often fails to wake from sleep. It use to be every time but the disable wake from Network setting seems to have pushed the problem to "very often" from "every time." Important to note that this is the ONLY issue I have with my MacBook and it started happening IMMEDIATELY after the 10.8.2 update.

    Seems clear APPLE need to provide a definitive solution with an official software fix/update. It's not good enough that their loyal clients are left with a haphazzard collection of half fixes we have put together ourselves!

Previous 1 5 6 7 8 9 Next