Previous 1 2 3 4 Next 226 Replies Latest reply: Jan 3, 2016 12:07 PM by u1012270 Go to original post Branched to a new discussion.
  • sinthang Level 1 Level 1

    MIght be a bad antenna. I had the same problem and tried the same remedies you listed. I went back to the Apple store and they gave me a new iPhone. Problem solved, now it stays on the network continously.


    Initially the Apple care representative said it was due to security settings in my router but this seemed unlikely since the other 13 Apple wifi devices (4 of which are running IO6) in my household never have issues with my wifi. After reseting the iphone and playing with network settings it seems it was the phone that was at fault.


    Also, FYI even though Apple stores are sold out of iPhone 5's they do have brand new replacement units for warranty issues

  • dancerdeb Level 1 Level 1

    My router runs on WPA...


    Well I also went into apple today. Bloke looked at my handset and said I just need to go to settings and reset network settings. This sounding too good to be true I asked if he could detect the store wifi and do it....Jon trying he couldn't even get it to register there was a wifi network so pronounced it as broken!!


    They offered replacement but it won't be the se serial numbers etc so has recommended I get my network provider to send me a new that's what i've done! Hopefully it won't take too long....

  • Frocktar Level 1 Level 1

    We got 2 iPhone 5's in the house, both drop wifi after a short whole and both won't automatically reconnect if you leave the wifi area. Also still have our old i4's and an iPad on ios6 and they play fine still, do its not ios6.


    Bummer, come on Apple, this needs to be addressed ASAP.

  • drbmoore Level 1 Level 1

    Here is what I did that has fixed this issue for me.


    Goto Settings.......Wi-Fi.....and make sure Ask to Join Networks is set to ON


    Shut iPhone down and then start back up.


    So far so good and it has bee almost 24 hours.  One family iPhone stayed in WiFi all day and kept it's connection and the other family iPhone left the house, reconnected upon return and has kept the connection since.

  • matrixxzero Level 1 Level 1

    Same here. When I first ran the setup and entered the wifi key, I got through the setup and then it "forgot" the wifi. But, as soon as I reentered the key and switched on "ask to join" it has kept wifi since friday. I haven't left the house yet but it hasn't dropped the wifi so far here. Just after the first setup before switching on "ask to join".


    Good luck to the OP

  • bush144 Level 1 Level 1

    I am having the same problem, everytime my iPhone 5 goes to sleep it disconnects from wifi and when I pick it back up to use it, it is back on Edge.  I have to go back into my settings, wifi, and reconect to my network.  It is an unsecured network so I know it is not a password issue.  I have tried reseting my network settings, restoring the iPhone through iTunes, forgetting the network and readding it, tuning on and off the ask to join networks....and am STILL having the same problem.  I have spent 2 hours on the phone with apple already and am calling them again now.  This is very frustrating to spend this much on a phone and it not work as well as the 3Gs I got rid of.

  • Shawnp204 Level 1 Level 1

    I'm also haveing same problem with my new iPhone 5 it won't auto connect to my wifi, but it will auto connection to my friends.. I have done all trouble shooting and still nothing.. My iPad 3 with os6 connects fine so could I have a bad iPhone?

  • Daz150969 Level 1 Level 1

    I am having the same problem. It is also effecting the mac laptop i believe through icloud linking them is anyone else having this problem  and does anyone know the answer

  • SherriLynn913 Level 1 Level 1

    I am having the same issue.  Disconnects from wifi every time the phone goes to sleep. I ordered my phone online.  Took it to my nearest A T & T store this morning.  They refused to exchange.  Said I have to wait for a fix from Apple.  Very disappionted. 

  • SherriLynn913 Level 1 Level 1

    The following was on the support page and so far it has worked for me.  I have not been disconnected when the phone goes to sleep the last few times.  Go to Settings....General.....Cellular.   Toggle Cellular Off and back On.  Restart phone.  Also, make sure "Enable LTE" and "Data Roaming" are ON.  Hope this helps some of you.

  • Shawnp204 Level 1 Level 1

    just got back from apple store and they did a restore on my phone and they had no problem auto connecting to there wifis, i told him that i am only having a problem auto connecting to my home wifi, he told me that this is a known problem and apple is working on the problem so we just have to sit back and wait till they attack the proble, for the meantime i need to make sure to turn wifi on my self

  • Nilotec Level 1 Level 1

    Just to clarify on this issue... I am NOT experiencing greyed out wifi selections or the wifi forgetting the network information. Those are two seperate issues. Also WEP does not connect at all, WPA connects for 30 seconds, unsecured stays connected indefinitely. Some of the troubleshooting steps I have tried here in the forums will work for about an hour or 2 but then the problem returns. My WiFi does not disconnect from going to sleep (a third issue?) and it's not that I can't connect to any wifi (4th issue?). I can connect just fine, I just can't get data through the connection.

  • Nilotec Level 1 Level 1

    OK, Spent almost 2 hours at the apple store today to get a replacement phone which they refused to do. I get home after all of their troubleshooting and am having the SAME problems. Now I have another appointment tomorrow. URRGHH this is frustrating. The gave me some BS about their in store restore being different than my 3 other restores both from backup and without backup that I did earlier in the day.

  • Frocktar Level 1 Level 1

    Well I've fixed both of mine.

    Here is what I did, no idea why it would fix it, but they are both working perfectly now.


    Turn on "ask to join networks". Let it do that once next time it disconnects. Then turn off cellular data, leave for a minute then turn on again and then turn off "ask to join". Fixed both of mine.

  • Nilotec Level 1 Level 1

    I did that. I stayed connected for 5 minutes before the problem returned.

Previous 1 2 3 4 Next