Previous 1 12 13 14 15 16 Next 226 Replies Latest reply: Jan 3, 2016 12:07 PM by u1012270 Go to original post Branched to a new discussion.
  • bte52 Level 1 Level 1

    My iPhone 4S, as well as my 3GS before it and my wifes 4th Generation iPod Touch all randomly lose wifi connection with our ASUS RT-N66U wireless router at home. I've been searching for a resolution to this issue for a very long time and recently came across this thread and thought I'd add my sad story to it.


    After reading all 13 pages here I've tried every suggested fix at one time or another to no avail. I can tell you that I have found one temporary fix that works for me. When the wifi disappears I log into the router and change the channel. I rotate between 1, 6, and 11. The Apple devices stay connected after doing so for several hours and in some cases a full day.


    I am really shocked that Apple ignores this problem. My gut tells me that they really don't know what the problem is and this will never get fixed. Shame on them.

  • ChrisD999 Level 1 Level 1

    I seem to have found a solution to this issue on my iPhone 5 go to settings wifi other enter ur router name enter security details since I have done this I have never lost connection

  • bte52 Level 1 Level 1

    Thanks but have been there and done that. No joy for me. I'm happy to hear that it works for you ChrisD999

  • Ellywyte Level 1 Level 1

    I just figure it out guys go into settings then click the blue arrow beside the wifi u want to connect and select forget this network. Exit then go back and select the wifi u want wait till it connects when it does select that blue arrow and select renew lease it should try to recconect again after that exit pressing the back arrow not the home button

  • bte52 Level 1 Level 1

    Ellywyte....I'm almost afraid of posting this for fear of jinxing my Apple devices. As I mentioned in my original post I've had difficulty maintaining connection to my wireless network for a very long time with both my iPhone 4S and 4th Generation iPod Touch. It's now been more than 48 hours since following your renew lease procedure and both of my devices have stayed connected. They would never stay connected to the network for more than a few hours previously. Thanks for posting.

  • Ellywyte Level 1 Level 1

    No problem just let me know if u have anymore problems feel good to know I helped someone :)

  • bte52 Level 1 Level 1

    I knew that I should have never mentioned my good fortune with this problem Ellywyte. No sooner than I posted yesterday morning. My wife came to me with her iPod Toucn because it was not connected to the wifi any longer. I then checked my iPhone and neither was it! Go figure. I'm still using your fix but have to also change wifi channel to stay connected. Thanks for trying.

  • Ellywyte Level 1 Level 1

    How many device do u have connected to the wifi? And is it open or secured, because u could do a static IP which gives devices a permanent address so when reconnected it won't be conflicted with another

  • jalmk Level 1 Level 1

    For what it is worth, this is how I fixed my problem. I had the same issue as the OP. I would connect to my home network and put in the password and it would stay connected, but if I left and came back I would have to put the password in again every time I reconnected to the network. After trying many of the suggestions on this thread (none of which worked), I finally tried something else and it did work. This may not work for everyone because I still use WEP security, but it may.


    The name of my network was just "linksys", so when I chose that network and clicked on the blue arrow, of course there was no "forget this network" button. So I went back to the previous screen and clicked "other" to connect to a new network. I simply typed in "linksys" (same exact name) and set my security to WEP, then I entered my password. After doing this, it stayed connected and would reconnect when I came back in. The funny thing was that if I chose WPA2, it would still connect, but would not reconnect next time. I had to manually choose the right type of security. So now, I still only see the one "linksys" network, but when I click on the blue arrow to see its properties, I have the "forget this network" button back. So the forget button must only show up for manually entered networks.


    So I think there is still an inherent problem with the phone in that I needed to do this manually to get it to work, but at least it does work now. So maybe someone else can try it with WPA2 and see if they get the same results.


    Good Luck.

  • catherine32176 Level 1 Level 1

    Thanks for the information.  I finally solved my wifi issues completely by going back to WEP security.  I have not been dropped ONE TIME since then on either the iPhone or iPad.  So for all those who say WPA2 was not my problem, I beg to differ.  In my case, it obviously was the problem.  No wifi connection issues prior to changing to WPA2 and no wifi connection issues since changing back to WEP.  You  make the call.  My concern was the WEP slowing down my notebook but that hasn't occurred, so WEP is the one for me.  None of the suggestions worked with the WPA2 security, and I truly believe the phone and tablet have bad chips as my research on the internet indicated.  Replaced the iPad one time, no difference, so didn't bother with the phone or a third iPad.  Apple really needs to address this problem rather than letting thousands of customers flounder around trying to fix it by trial and error.  I am most disappointed in the customer relations dept. of Apple.

    Good luck fellow Apple users, next time I upgrade, I plan on buying something else.

  • catherine32176 Level 1 Level 1

    Actually, I believe they do know.  Check out a memo on the site:  Look for one called /2012/04/04/apple-investigating-new-ipad-wifi-issues (goes on  with "tells Applecare to replace").  They were and still are aware the devices are defective, that's why if you jump through the proper hoops you will get a new device mailed to you.  I replaced one and it didn't stay connected either.  Waste of time.

    The only thing that has solved my problem was resetting my router to WEP from WPA2.  No problems since then.

    I think its terrible that a company ignores literally thousands of valid complaints from its customers.  Why do people keep on buying their products?

    Buyer beware is still good advice.

  • macandmercedes Level 1 Level 1

    Good to know that you have finally found a solution.

  • rotillar Level 1 Level 1

    I just took my SIM card out and put it back in and voila things are working like a champ - so far it has been about 1 hour.

  • Joseph F. Level 1 Level 1

    If your network connection is very poor, it will switch to 3G/4G/LTE. A possible solution is to go to settings-->Wi-Fi-->click on arrow next to your network name-->click "forget this network" and then just reconnect

  • Spider44 Level 1 Level 1

    Sherrylynn turning cellular Data Roaming on iPhone 4S and ipad2 with 3G worked for me. Thank you.