Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Trackpad "Double Clicks" on Dashboard Calculator

This is stressing me out to no end. Ever since I upgraded to Mountain Lion, my dashboard calculator double enters every digit I click. I haven't had this issue anywhere else but the default calculator on the dashboard. I can see from the rest of the threads I've read that it is to do with the software development. Has anyone found a solution for this problem? Every thread I read went dead before any solution came about (way too much rhyming in that sentence). I will note that if I "right click" the buttons on the calculator or enter them through my keyboard, it works fine. Please someone tell me I can fix this - I use it all the time! 😟

Macbook Pro, Mac OS X (10.6.2)

Posted on

Reply

Page content loaded

Sep 29, 2012 11:13 AM in response to 5TAR5 In response to 5TAR5

I got the same problem...tried clearing PRAM, SMC, caches (for dashboard), preferences, changing tracking/clicking speeds, nothing works...what is interesting is that I installed a different calculator widget (scientific calc) and it had the same double entry effect. I turned on developer mode and moved the standard calculator to the regular desktop. Still got the same result....same thing moving the scientific calculator...

regular calculator app (not the widget) works fine on desktop with trackpad click...I guess we have to upgrade to 10.8...

Sep 29, 2012 11:13 AM

Reply Helpful

Jan 19, 2013 8:18 AM in response to 5TAR5 In response to 5TAR5

I have a similar issue. I noticed that the "second click" is actually being triggered with a mouse up event. Try clicking down with the mouse on "5" and then with the mouse still down and held, hover over a different number say "8" and then release the mouse. I think you'll find "58" showing in the calculator.


Another test, if you use the keyboard to enter "1 + 1" and then use the mouse to click on "=", you'll see "2" after the mouse down and then "3" after the mouse up. Of course, if you click on the "=" very quickly and release, you may only see the final result of "3".


I've tried with both the trackpadand USB mighty mouse with the same results.


I've also noticed frustrating mouse behavior when clicking between apps. My guess is the OS is catching the mouseup event and registering it as a second click.


Very frustrating!


Any ideas on how to fix it?


(10.8.2 Mac Pro)

Jan 19, 2013 8:18 AM

Reply Helpful

Apr 17, 2013 3:49 AM in response to 5TAR5 In response to 5TAR5

Check your login items people. I had the same problem and I found where the problem was. It's possible that an application in your login items is causing the problem. If by any chance any of you have KeyCue in you login items, remove it. That's how I solved my problem. You shouldn't probably blame any of Apple's apps, I don't think they would cause the problem. If you have more than 1 third-party app in your login items, remove them one by one and restart the computer. If the problem continues, add back your old login item and remove the next one. Restart the computer. Repeat this process until you have found the app that was causing the problem. Hope this helps.

Apr 17, 2013 3:49 AM

Reply Helpful

Dec 19, 2013 11:57 PM in response to Jeff Zavaleta In response to Jeff Zavaleta

Hi Jeff,


I have the exact same problem. Were you able to solve it? I also see weird behaviour in mail which has a lag of a click. If I click on one message the click doesnt register, then I click on another and the previous message click registers. Very annoying.


I went to apple and they set up a new user for me. It does not happen with this new user so it could be something to do with preferences, but noone seems to know which.


The Apple Genius suggested to either backup/swipe and then manually pull all my data back (not a full restore since that would likely re-instate the same problem) or to manually move my data from one user to the other.


Both of these options would be very time consuming so I am hoping there is another way.


I am very careful with what I install on my mac, I have very few apps installed.


Any help would be appreciated.


Best regards,

Bobby

Dec 19, 2013 11:57 PM

Reply Helpful

Nov 22, 2015 12:20 PM in response to diggsyang In response to diggsyang

Hi This worked for me.


Go to launchpad and click on calculator. do a simple sum 1 + 1 (it should work) then swipe across to your widget and try the same sum (widget calc should now work) swipe back to calc you opened from launchpad and quit it, then go back to widget calc and try it again just to confirm its working.

Nov 22, 2015 12:20 PM

Reply Helpful
User profile for user: 5TAR5

Question: Trackpad "Double Clicks" on Dashboard Calculator