11 Replies Latest reply: Aug 30, 2013 11:49 PM by léonie
kiwispoon Level 1 Level 1 (0 points)

Since I upgraded to 3.4 Aperture opens but then crashes - is anyone else having this problem. I can open the library in iPhoto....


Aperture 3, OS X Mountain Lion (10.8.2)
  • 1. Re: aperture crash
    léonie Level 9 Level 9 (51,640 points)

    is anyone else having this problem.

    Quite a fewposters - look at the recent threads. There is a problem with the Aperture installer. In some cases the installation is not complete, if you update on top of a recent version.

     

    For most posters here (there must be 20 and more discussions by now) it helped to reinstall Aperture after removing the Application from the Applications Folder and the reinstalling again.

     

    • If you installed Aperture initially from the boxed retail version, reinstall from the CD/DVD.
    • If you installed from the AppStore, download again from the AppStore.
    • If you unlocked the Trial or bought online previous to the AppStore, use the saved installer or download the Trial again.

    http://appldnld.apple.com.edgesuite.net/content.info.apple.com/Aperture/061-8328 .20101020.AprE3/ApertureTrial3.1.dmg

     

     

    Upgrade immediately after installing the previous version; you cannot open your current library with the previous version.

     

     

    Post back, and let us know, if you still have crashes after the reinstall.

     

    Regards

    Léonie

  • 3. Re: aperture crash
    Gianky Level 1 Level 1 (10 points)

    Guys, I've solved today by simply use a tool, AppDelete.

     

    Drag & Drop Aperture app into AppDelete opened app. Then uncheck Aperture app end leave checked the rest. Proceed with purge sequence of entire resgistries and folders and all the listed files you've into the list.

     

    Then try to open aperture and restore your database (converting the old one or open a new one.)

     

    This works for me.

     

    Regards

     

    Giancarlo

  • 4. Re: aperture crash
    Thomasaab Level 1 Level 1 (0 points)

    Thanks for the info, but nope, didn't work.  If you're thinking about getting this app, I'll give you 62,193 reasons not to. Ask me if you'd like to see what's left of my library.  I'm beginning to detest the purchase of this rotten piece of software. 

  • 5. Re: aperture crash
    phost Level 1 Level 1 (0 points)

    Help!  I went down to Snow Leopard and found that Aperture doesn't work with it, so I am up to Lion and will go no farther.  So.. The App Store only show the upgrade to aperture, not the original download (nothing is hidden).  I install that and there is no Aperture in Applications.  I find it in Launchbay and drag it to the Dock, still not in applications.  It opens but gives me the same errors I got when I uploaded Mountain lion and the Aperture upgrade.  It fixes my damaged Library for 5 minutes before opening and the colors of the project boxes have changed to all grey.  So. I cannot follow directions by dragging the app to the trash as there is no Aperture in Applications.  I also suspect I will NOT see the original upload of Aperture I. The App Store, this is why u should have a disk and if I give up on Aperture and but photo shop, I will go into best buy and but it with a DISK!

  • 6. Re: aperture crash
    shuttersp33d Level 4 Level 4 (1,540 points)

    Maybe try doing a spotlight search for Aperture. Also, make sure you're looking in the correct folder. Hard to believe that Aperture wasn't installed in your Applications folder.

     

    And if you think about it, the App Store is better. If you lost your disk, you wouldn't have the app at all.

  • 7. Re: aperture crash
    phost Level 1 Level 1 (0 points)

    thanx.  I really want the dowload and a back up disk.  I tried to import and export some recent iPhoto work to the Aperture library and Aperture mode folders for every folder on my computer.  I located the back up app in Carbon Copy and dragged it to my Application, so maybe I can try Gianky's process although I think I am looking at phot shop!

  • 8. Re: aperture crash
    pashayan Level 1 Level 1 (0 points)

    I am having problems with Aperture crashing, so followed these instructions (removed Aperture from Applications) and used the Aperture Installer, but found that the installer no longer works.  How can I reinstall Aperture 3.0 which I purchased from Apple (before the App Store) as a download, but they no longer offer the download? The last boxed version I have was Aperture 2. 

  • 9. Re: aperture crash
    pashayan Level 1 Level 1 (0 points)

    i found a different Aperture 3 installer (3.0 not 3.1) and THIS one seemed to work.  I did the 3.4.5 upgrade and my password was already in place and it found my library so it seems to be ok.  I'll see if this one crashes now.  thanks all

  • 10. Re: aperture crash
    vspiegel Level 1 Level 1 (0 points)

    Bought Aperture 3.4.5. Crashed on open. Read the fixes. Deleted Aperture. Went to Purchases. Reinstalled. Still crashes.

     

    Not happy.

     

    Victor

  • 11. Re: aperture crash
    léonie Level 9 Level 9 (51,640 points)

    Victor,

    you'd better start a new thread with your question. A crash may have many reasons, that are unrelated to this old thread.

     

    In your own thread specify your MacOS X version, and also what you already tried, also the error message from the crash report (max. the first 50 lines).

     

    Regards

    Léonie