4 Replies Latest reply: Sep 23, 2012 5:16 AM by Lil Dee
newlysngle@yahoo.com Level 1 Level 1 (0 points)

I got a new phone today and and it requires that I update my itunes to a 10.5 version. However, when I tried installing the newest version (10.7), a message pops up saying I need the 64 bit installer. So I installed that however when I attempt to plug my phone in, it still says I need to install the 10.5 version. Seriously at a lost, please help!


Hewlet Packard, Windows 7
  • b noir Level 9 Level 9 (72,025 points)

    However, when I tried installing the newest version (10.7), a message pops up saying I need the 64 bit installer. So I installed that however when I attempt to plug my phone in, it still says I need to install the 10.5 version.

     

    Let's try a standalone Apple Mobile Device Support install. It still might not install, but fingers crossed any error messages will give us a better idea of the underlying cause of why it's not installing under normal conditions.

     

    Download and save a copy of the iTunesSetup.exe (or iTunes64setup.exe) installer file to your hard drive:

     

    http://www.apple.com/itunes/download/

     

    Download and install the free trial version of WinRAR:

     

    http://www.rarlab.com/

     

    Right-click the iTunesSetup.exe (or iTunes64setup.exe), and select "Extract to iTunesSetup" (or "Extract to iTunes64Setup"). WinRAR will expand the contents of the file into a folder called "iTunesSetup" (or "iTunes64Setup").

     

    Go into the folder and doubleclick the AppleMobileDeviceSupport.msi (or AppleMobileDeviceSupport64.msi) to do a standalone AMDS install.

     

    (If it offers you the choice to remove or repair, choose "Remove", and if the uninstall goes through successfully, see if you can reinstall by doubleclicking the AppleMobileDeviceSupport.msi again.)

     

    Does it install (or uninstall and then reinstall) properly for you? If so, can you get a normal iTunes install to go through properly now?

     

    If instead you get an error message during the install (or uninstall), let us know what it says. (Precise text, please.)

  • Lil Dee Level 1 Level 1 (0 points)

    b noir -  I have a similar problem and have tried your work around, several times. It seems I keep going around in a vicious circle. It has gotten to the point I am giving this one last try and if I still cant get this to work I am ditching my PC and going to the Apple store for a Mac!

     

    Here goes - I am currently running Windows 7 Ultimate 32 bit. After downloading and installing Itunes 10.7 from Apple, I have no  Mobile Device Support (itunes wouldn't update from 10.6 so I had to do a complete uninstall and then download & reinstall). After a lot of searching on line and on different Forums I found your thread and followed the instructions for a standalone AMDS install using WinRAR.

     

    I did not have an option to remove or repair since the file wasn't on my pc to begin with so it just started to run an install. It looked like it was going to work but just as it was getting to the end an error message came up that said:

     

    "Apple Mobile Device Support wasn't installed on your computer. The installer encountered errors before Apple Mobile Device Support could be configured. Your system has not been modified.

     

    To try these operations at a later time, please run the installer again. Click Finish to exit."

     

    I then went to the Itunes.exe and tried to Repair, hoping that it might replace the missing Apple Mobile Device Support file. I received an error message saying:

     

    "Service Apple Mobile Device (Apple Mobile Device) failed to start. Verify you have sufficient priveleges to start system service" There were three choices, Abort, Retry & Ignore.

     

    Before doing anything I went down to Start, Search, Services and opened the Apple Mobile Device. I clicked "Start"  and got   Error 2: The system cannot find the file specified.

     

    At this point I went back to the previous error message, hit Abort and continued to look for answers. Mind you I had to uninstall & reinstall Itunes about 3-4 times before I figured out if I didn't uninstall iCloud I couldn't reinstall iTunes. Then I also tried something else you had suggested to someone that involved downloading Autoruns, but nothing with that did any good. The only things under Winsock were Bonjour & Windows. I looked under the Services tab & found Apple Mobile Device highlighted in Yellow and it said File Not Found.

     

    If you have any suggestions or ideas I welcome them. This has been the most frustrating thing I have been through. Like I said, I am seriously ready to bag the whole computer & get one that already has the current version of iTunes on it.

     

    Thanks!

  • b noir Level 9 Level 9 (72,025 points)

    I don't have good numbers on your complication with this, I'm afraid, Dee.

     

    There's one experiment we can try that would do no harm.

     

    Try another standalone AMDS install, but this time right-click on the AppleMobileDecviceSupport.msi and select "Runa as administrator".

     

    Any better luck with that?

  • Lil Dee Level 1 Level 1 (0 points)

    I wish I could say Yes but I have already tried that I have also gone in and made sure I have permissions checked as "Full Control".

     

    I forgot to mention that my netbook computer which is running windows 7 Home, updated from itunes 10.6 with no problems. They are on the same home network so it cant be a network thing. I have also tried downloading itunes from IE 9, Firefox and Safari (for my desktop pc) and still get the same results.

     

    The only thing I did differently between the 2 computers, was not install the windows updates before updating itunes on my netbook. Unfortunately I rarely use the netbook since getting my iPad and there were about 20-25 windows updates between now & the last time I used it. (I would just say screw it & use that to sync everything, except I am trying to sell it.) I thought about uninstalling the updates on my PC and actually started doing that, but 2 hrs later and only 5 uninstalled updates I thought there had to be another way!

     

    I don't know if this additional info makes a difference or  not.  I also heard about one other thing and I am not even sure exactly what it is but what about totally uninstalling everything again (I can't believe I just said that) and trying the windows intaller cleanup utility? 

     

    Believe it or not, I am not very "techie" and have learned alot of this stuff just from playing around with the computer so if I sound lost its probably because I am. I really do appreciate your help though. It seems like if there is an answer you would be the one to have it - No pressure   Thanks - Debi
    .