Previous 1 2 Next 24 Replies Latest reply: Nov 20, 2014 2:04 PM by joanne_sp
Tmajor28 Level 1 Level 1 (0 points)

I know there are a lot of wifi issues regarding the new iPhone, but mine is quite strange and I am wondering if anyone else is experiencing or found a fix for it.

 

When I am at home on my Comcast xfinity router/ modem combo wifi connection, I cannot send pictures or videos through iMessage. I can send via mms, which is eventually what happens after it spends 5 min trying to send through iMessage. I can send iMessages all day, but not photos or videos. I can, oddly enough, send my location from maps. I can also receive pics through iMessage and was able to send some today on another wifi router. All other Internet features seem to work fine.

 

On the same network my 4s can send imessage pics/videos and so can my iPad, both are on iOS 6. I tried port forwarding and turning off the Internet security on the router, but that didn't work. Any ideas?


iPhone 5, iOS 6
  • Jeekree Level 1 Level 1 (0 points)

    Just replying to say that I am having the exact same issue.  Hoping to find a fix.

  • DenverSteveo Level 1 Level 1 (0 points)

    Tmajor -

    I just ran the same tests with the same results you received.  It definitely appears to be a conflict between IOS 6 and Comcast/Xfinity.  I am using an iPhone 4S and a 3rd Generation iPad and both stopped sending photos over my home Comcast-enabled wi-fi once I upgraded to IOS 6.

     

    I am sitting at my office right now on an independent internet connection having no issues over wi-fi - iMessage, MMS, and Email all send without problems.

     

    Now if someone could just resolve the issue - QUICKLY!

  • Tmajor28 Level 1 Level 1 (0 points)

    Well I spent a hours on the phone with Apple care and the guy submitted a ticket to the higher ups. Nothing ever came of that though. I figure that the iphone 5 has to be sending pics/videos through a different port or with added security and the xfinity gateway blocks it.

     

    I called Comcast yesterday and the rep was trying to turn my gateway into just a modem, but it wouldn't listen to her commands. I decided that it's not worth the hassle and am returning the gateway to comcast. I went out and bought a stand alone comcast modem for $99 at best buy, but if you don't want to do that, you could always just exchange the gateway for a separate modem and router at the comcast office. My parents have comcast and they rent their modem and router from comcast, but the router is netgear and is a separate unit.

     

    So my current set up is a comcast cable modem: Motorola Surfboard docsis 3.0 high-speed cable modem and an older b/g netgear router that I had in the closet. Everything works great and my iMessage can now send photos and videos with no issues. The Xfinity gateway is the issue, at least for me it was.

  • DenverSteveo Level 1 Level 1 (0 points)

    Tmajor -

    I will have to try that when I get home tonight.  I recently updated to the Comcast/Xfinity modem & wi-fi router unit after my old modem crapped out.  I also used to have a Netgear router (b/g/n) connected, so moving back to that solution isn't that big of a deal.  I just hate dealing with the rigamorole that is Comcast Customer Service.

     

    Thanks for sharing your headache and hard work finding resolution - I'm guessing this will solve at least one problem for quite a few people out there.

  • Craig18wheels Level 1 Level 1 (0 points)

    I'm having the same problem and its getting on my nerves!!!

  • Craig18wheels Level 1 Level 1 (0 points)

    It's what tmajor28 said!!!

  • illest. Level 1 Level 1 (0 points)

    Samething is happening to me. My temporary fix is turning off WiFi, send the MMS and then turning WiFi back on.

     

    I wonder if we can port forward?

  • sneirbo2k7 Level 1 Level 1 (65 points)

    I'm not only having the problem with MMS via iMessage on my Xfinity gateway but also my Chase Mobile APP as well!  The APP lets me login when I'm on WiFi but I can not check any account details or deposit a check.  When I switch off WiFi on my iPhone and go to cell data it all works the way it should.  The Comast / Xfinity gateway definitely appears to be the issue!

     

    Looks like I need to go pull my old Cable Modem out of storage and see if that will work.  It's a good thing I never gave anyone the VoIP number that came with the bundle to anyone ...

  • Jeekree Level 1 Level 1 (0 points)

    I am now noticing the same thing with iMessage using Mountain Lion on my Mac. Hopefully Comcast can get this resolved. Strange issue.

  • sneirbo2k7 Level 1 Level 1 (65 points)

    So I went and found an old D-Link DCM-202 I had - plugged it in, called Comcast to add the modem MAC address info to get it to work.  Was told by the Tech, that since I have an incredible Triple-Play rate from a promotion when they started phone service - if I ditched their wireless gateway for my D-Link modem, I would lose the phone service, and thus the great rate.  When I explained the issues / problems I'm having - the Tech ...

     

    1) didn't believe me, he said it was impossible that their gateway was the issue with MMS and Chase Mobile App.  When I explained my troubleshooting approach - turn off WiFi on iPhone use Cell Data and everything works, he didn't have an explanation.

     

    2) suggested they replace my wireless gateway with a Motorola modem / phone adapter.  I told him I currently was only using their gateway as a modem attached to my Apple Time Capsule, I wasn't using their WiFi, so that should work.

     

    The package is supposed to ship today, should arrive by the end of the week.  We'll see if that works.

  • iphonerocks12 Level 1 Level 1 (0 points)

    I have the exact same issue.  I cannot send messages over iMessage with my Comcast XFiniti WIFI connection.  I have a Netgear router providing my wifi but even connected directly to the Xfinity gateway it won't go through.  I have no problem with iMessage over cellular.

  • sneirbo2k7 Level 1 Level 1 (65 points)

    Received the new Comcast modem this afternoon - an Arris TM722. 

     

    Short answer - solved all of my issues.

     

    Long answer - the setup was a PITA!

     

    Connected per included instructions - activated per instructions - no problem

    iMac connected to modem via ethernet cable - no interent or mail problems

    Connect modem to Apple Time Capsule - the problems begin.

     

    No connection at all - no internet, no mail, nothing.  Call Comcast - they don't know how to troubleshoot an Apple router.  I ask them what the DHCP Setting should be - they answer "automatic".  That's not an option - they don't know an answer.

     

    Ended up calling Apple Tech Support - the solution was to reset the Time Capsule to Factory Settings, then reset it up using the exact Network Name and password so that everything would still connect.

     

    After it was finally setup - I tested sending MMS from iPhone and iPad, as well as sending photo through Messages on iMac - all went as they should.

     

    Finally checked Chase Mobile APP on iPhone - was able to login and deposit check as it should.

     

    The problem HAS to be those Xfinity Gateways!  All my problems were solved once it was out of my system.

  • InvisibleMonkey Level 1 Level 1 (35 points)

    I'm having the same issue as well. Xfinity and Apple have both been no help to me as far as troubleshooting. iMessage works perfectly at work over wifi but as soon as I get home I can't send pictures and they always go through as regular MMS messges.

  • wstarr Level 1 Level 1 (0 points)

    I am having same issue....just got Xfinity have the ARRIS TG862.. my photos taken on iphone 5 will not go to the photostream and I can not log onto Chase mobile while connected to network...

Previous 1 2 Next