1 Reply Latest reply: Sep 22, 2012 7:08 AM by hpr3
Gixxerjoe04 Level 1 (0 points)

I have the 10.5.8 software and i need the 10.6.8 or better to run the new itunes for my iphone 5.  Can i just download the 10.6.8 snow leopard version and be fine or are there other things i need to download?  I know nothing about macbooks.

MacBook, Mac OS X (10.5.8)