Previous 1 2 Next 15 Replies Latest reply: Apr 6, 2015 3:41 AM by senrab148
RonL Level 1 Level 1 (45 points)

I'm running OS X 10.8.2 with QuickTime 10.2 and can't get the screen recordings to record audio.

 

I've tried all of the settings in System Preferences > Sound for both Output and Input and even have Soundlflower installed and have chosen those as options also, but I can't get the audio to record. Or that is... no matter what settings I use for Input... it ONLY records from my 27" iMac's internal microphone.

 

So... while recording the video that's playing on screen if I talk (to test it) the audio recording of my talking is fine... but no setting will allow me to record what the audio on the video is.

 

This didn't just begin in 10.8.2... I'm just finally getting around to posting about it because I'd like to occasionally record videos on the screen.

 

The videos record without a problem.

 

EDIT:  If I select Soundflower (16c) for the Input then the Sound preference pane displays the sound on the video is being recognized by the system (i.e. the Input level shows the bar changing from the audio in the video). But when I play the QT file back... no sound.

 

Any advice?


iMac, OS X Mountain Lion, 27" iMac, 32" secondary monitor
  • RonL Level 1 Level 1 (45 points)

    So since there's not even one reply... can I assume no one can record audio using QuickTime?

  • RonL Level 1 Level 1 (45 points)

    Pathetic that QuickTime can't record streaming video audio.

     

    I've found an app that will do this and that is "Voila!"

     

    http://www.globaldelight.com/voila/mac-screen-capture-overview.html

     

    It's on sale on the App Store for only $9.99 until November 4th.

     

    Normally it's $29.99

  • Kato419 Level 1 Level 1 (0 points)

    RonL:  If I understand your question correctly, the pathetic comment is a bit harsh.  I have recorded both audio and video from a streaming webinar source.  Launch QuickTime Player. (I'm using 10.2) Under the File menu select "New Screen Recording"  A black rectangle will appear with a small inverted triangle on the right side.  You can't miss the black box.  Toggle the white inverted triangle and select to use the Built-in Microphone.  Worked for me.  You'll need to highlight the area of the screen you wish to capture, etc but here on in it's fairly self evident.  Hope this helps.

  • downeyt Level 1 Level 1 (0 points)

    I agree with Kato419. Clicking the inverted rectangle brings up the sound options. I did not need an external program, QuickTime allowed me to record audio with my screen recording.

  • RonL Level 1 Level 1 (45 points)

    Still not working for me with 10.8.2 and QTP 10.2.

     

    Went through all of the possible selections in the delta dropdown and none of them result in a screen recording that also includes the audio.

  • danallenhouston Level 1 Level 1 (0 points)

    Hi, I am not sure if I understand the details of your instructions and the results you are getting. 

     

    When I record audio/video coming through my browser (example link) using the built-in microphone, the sound gets recorded, but if I talk, or the phone rings, or someone else talks during the recording, then the recording includes the sounds they are making.

     

    I don't see a way to get the sound into the recording except via sound waves between speakers and microphone.  I am thinking there should be a way for the sound get recorded without allowing input through the microphone.

     

    Any assistance would be extremely much appreciated.

     

    Thanks.

  • RonL Level 1 Level 1 (45 points)

    Still not working in 10.8.3.

     

    Again... looking for a way to record audio using QT so that it __only__ records internally (i.e. microphone disabled).

  • empofant Level 1 Level 1 (0 points)
  • RonL Level 1 Level 1 (45 points)

    empofant,

     

    Thanks... that looks like it may do it.

     

    I'll definitely try that as soon as I have time and post back as to the results.

     

    Again thanks!

     

    Ron

  • Matt Tomlinson Level 1 Level 1 (0 points)

    All - I was able to replicate this issue in OS X 10.9 with Quicktime 10.3.

    The solution I found was to un-mute my speakers.  After that the screen recording with sound worked just fine.

  • chillspike Level 1 Level 1 (0 points)

    Try this: click on the apple in the far upper left of your screen. Choose "system preferences", then "sound", then "output". Look what selections are available there. For instance, I have Sound Flower on my Mac so both the 2ch and 16ch options are listed under "Output". I selected one (doesn't matter which one) in Output and then select the same one from the triangle drop down menu in quick time. I was having the same problem as you until I did this and it worked. I think it should work for you. Note: while recording you won't hear any sound from your speakers or headphones and you have to manually switch it back to speakers or headphones in "system preferences", "sound", "output" in order to hear the audio on playback. Good luck!

  • sgormley Level 1 Level 1 (0 points)

    Yes, finally!!  The solution chillspike has suggested works. Just remember to switch back from "sound flower" to "built in output" in preferences when you want to listen back. Also before recording make sure the volume control in the QuickTIme pane is turned all the way down. Thanks everyone for

    the suggestions.

  • wayne mitzner Level 2 Level 2 (400 points)

    Kato419, I belatedly just found your post, but am curious what you mean by "You'll need to highlight the area of the screen you wish to capture, etc".  Have you found a way to crop or highlight just a specific area of the screen to record? 

  • Benjaminsyne Level 1 Level 1 (0 points)

    I have found a solution to your problem!

     

    I have Logmein installed, and I selected it for the sound output.

    Screen Shot 2014-10-18 at 2.24.32 AM.png

    I than selected it as the audio source in quicktime and it worked like a charm. I was able to record video with system audio and it was perfect!

    Screen Shot 2014-10-18 at 2.26.00 AM.png

     

    I hope this helps!

     

    If @apple is listening tho, There should be an option to select system audio when recording a screen cap with quicktime.

Previous 1 2 Next