3 Replies Latest reply: Sep 22, 2012 7:23 PM by Roddy
Romo01 Level 1 Level 1 (0 points)

I want to make sure I download and install the correct Adobe Flash Player,  I have the iMac - Mac OS X Lion 10.7.5. Thanx


iMac, Mac OS X (10.7.4)