3 Replies Latest reply: Sep 23, 2012 9:03 PM by techcafe
techcafe Level 1 (20 points)

HEY APPLE!

 

WHEN are you going to FIX the iTunes vs Firewall issue?? this has been a recurring bug for a LONG TIME; from Snow Leopard to Mountain Lion.

 

The usual workaround is to delete com.apple.alf.plist from the /Library/Preferences folder (which i did); then delete/reinstall the iTunes.app in the Applications folder; BUT after upgrading to Mountain Lion, the system refuses to allow iTunes to be deleted (see screencaps below).

 

SO NOW WHAT?!

 

Screen Shot 2012-09-23 at 8.48.41 AM.pngScreen Shot 2012-09-23 at 8.48.25 AM.png

Screen Shot 2012-09-23 at 8.58.06 AM.png


iMac, OS X Mountain Lion
  • b noir Level 9 (72,060 points)

    On Lion or Mountain Lion systems, the following set of instructions are worth a try:

     

    http://www.mikesel.info/fixed-do-you-want-the-application-itunes-app-to-accept-i ncoming-network-connections/

  • techcafe Level 1 (20 points)

    the article talks about invalid code signatures due to a modified iTunes.app - which i have not done. this problem has happened to me in the past, after upgrading Snow Leopard to Lion, and now again, after upgrading to Mountain Lion. the last time it happened, i had to do a complete reinstall of SL, and delete the iTunes.app before i did the upgrade to Lion, then download/reinstall iTunes after the upgrade. i assumed that Apple would have fixed this serious bug by now, but apparently not.

     

    i ran the codesign utility (see screencap below), it shows MANY iTunes resource files that aren't valid. this only happens after upgrading from Snow Leopard to Lion/Mountain Lion. i have no 3rd party plugins installed. i did a clean install of SL, then Mountain Lion (but i forgot to delete iTunes.app this time), and this is the result.

     

    i'm really starting to despise Apple.

    Screen Shot 2012-09-23 at 11.55.00 PM.jpg

  • techcafe Level 1 (20 points)

    problem solved (i hope). turns out the reason iTunes cannot be modifed or deleted is because the installer restricts permissions on the iTunes.app to read-only. see this article on OSX Daily on how to change the permissions so that iTunes can be deleted. i followed the instructions, then downloaded/reinstalled iTunes. the code signatures are now valid and the firewall no longer blocks iTunes sharing.