Previous 1 10 11 12 13 14 Next 543 Replies Latest reply: Apr 22, 2015 12:27 PM by drachenfeder Go to original post
  • BigZ12 Level 1 Level 1


    Tried both b/g only, and n only with my ASUS RT-AC66U router with WPA2/AES.

    Didn't work.


    99,9% sure that this is AES related.

  • clickmeas Level 1 Level 1

    Its is time to Sue Apple ,Guys.

    The issue is not big yet becasue, Some people use their "Unlimited data" plans they still have.And some fortunately in the neighbourhood with router(s)/firmware(s) that are working fine for iphone 5.


    Somebody in Apple beter understand this, and do the research and fix.

  • theswerm Level 1 Level 1

    This is quite a nightmare. My phone starts 88:53 as well ,but does have the same issue with WPA2. I am reading all of this and wondering what the best course of action is. Do I wait? Looks like I will be headed to the store.

  • C4RLOCO Level 1 Level 1

    theswerm, can you post the first 6 digit of your MAC address? it seems that 88:53 is not exclusively from Intel, meaning it might belong to Apple as well.


    In other words, if your prefix is 88:53:95 then you might have the Apple Wifi chip.

  • theswerm Level 1 Level 1

    Sure: 88:53:95 and it did come up as Apple when checked earlier. I made an appointment as I am not confident that it will/can be fixed anytime soon. I apologize as I am working and checking this at the same time. I must have missed that detail.


    Message was edited by: theswerm

  • C4RLOCO Level 1 Level 1

    Yep, I replacement is your best course of action. Good Luck and please let us know how did it go.

  • theswerm Level 1 Level 1

    I will. Today at 5pm Est. Should be fun.

  • Shaddow Level 1 Level 1

    C4RLOCO: So what is your first 6 (i only found where you mentioned 4)? I still have found it odd that in would have an intel MAC address. I have never seen a product from Apple with anything but an Apple mac ID.

  • theswerm Level 1 Level 1


  • C4RLOCO Level 1 Level 1

    Good point shaddow, back then when I wrote my theory, I only looked for my 4 digits and since my new replacement worked well and did not went further.


    My first six MAC digts are also 88:53:95 (same as theswerm). He has been the first person who had reply to this post stating issues with WPA2-AES. That is odd!


    What is even more confusing is that most of the users proved that phones with MAC addresses starting with 98:B8 seems to be the ones with this issue.


    Either way theswerm, get your phone replaced!

  • Braccobaldo Level 1 Level 1

    I'm back from Apple store, this is my update:

    At the begin Apple refused to replace my iphone, they said it is a software issue that will be fixed inthe next days, anyway they didn't know about the problem and after showing them How my IP5 worked they pick my iphone and tested it for about one hour.

    When they came back they said there was no way to check the mac address of a new boxed iphone so probably I'd had the same problem.

    At the end, after about one hour later and after having talked with 4 more people of the genius bar, they replaced the iphone with one with the same wifi apple module, but IT WORKS!!!!!!!


    my working mac address start with: 54:26 manufactured by apple.



    before I had 98.b4

  • C4RLOCO Level 1 Level 1

    Does anyone knows how to edit an old post? I don't see the "edit" button available anymore, I would like to update (Thanks to everyone who provided your input) with more information my initial post where I explain my thought process about this issue.

  • theswerm Level 1 Level 1

    This phone arrived on Monday. I am for sure going to replace it today.

  • Shaddow Level 1 Level 1

    Yea I wronte on a thread here or macrumors that I dont think the mac has anything to do with it. As almost every MAC that I saw someone have a problem on, someone else claimed it was fine. Mine is fine at work on WPA2 AES, but wont connect after being away from my home network. (3 different routers!) and a reboot fixes it everytime and I am good till the next day, 25mbit+ speeds etc..

  • Braccobaldo Level 1 Level 1

    we can affirm only one thing, Intel modules have no problems, apple modules can have WPA2/AES issue.

Previous 1 10 11 12 13 14 Next