Skip navigation

iPhone5 issues with WPA2/AES Wifi

186023 Views 537 Replies Latest reply: Feb 22, 2014 7:49 AM by jenniefromnew york RSS
  • s10e Calculating status...
    Currently Being Moderated
    Oct 17, 2012 9:57 AM (in response to C4RLOCO)

    Got mine replaced yesterday and my wifi works perfectly now, although I still have an Apple-manufactured wifi chip. My old one even started working a bit better after a restore before going to the Apple store, but I didn't want to take any chances and already had the replacement set up.

  • awl168 Calculating status...
    Currently Being Moderated
    Oct 17, 2012 10:15 AM (in response to awl168)

    Ok...some more info to share.

     

    My iPhone 5 could not join a wifi network using WAP2, but it works when security is downgraded to WEP and no security. This is on an old Netgear router (at least 7 years old) that does not support IPv6.

     

    This morning I tried a different wifi WAP2 network that uses a current model router that supports IPv6. My iPhone 5 connected with no issue and I have not experienced any network degradation over time since connecting.

     

    Curiouser and curiouser...

  • awl168 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 17, 2012 10:16 AM (in response to awl168)

    Oops...sorry. I meant to say WPA2.

  • gmansc1 Calculating status...
    Currently Being Moderated
    Oct 17, 2012 8:57 PM (in response to C4RLOCO)

    Reset All Settings -- follow up #2

     

    Beyond doing a Reset All Settings (see previous post on what to expect) I set the DNS to google's 8.8.8.8 and also set the HTTP Proxy to Auto.  These last two changes show up in a number of tech posts and recommendations.  Don't know if it's a placebo effect, but it seems that each change leads to a modest improvement.  The google DNS was especially helpful.  I compared my webpage download times to those on a 4S running iOS 5 and my IPH 5 with iOS6 beats it by a smidge every time.  So I think WPA2 probs are solved for me, at least as far as I can tell.  Also suggests to me that the problems (mine, at least) are software and will hopefully be fixed with an iOS update.

  • jackcr01 Calculating status...
    Currently Being Moderated
    Oct 17, 2012 9:36 PM (in response to C4RLOCO)

    Hi C4RLOCO,

     

    I just got my iphone today and am sad I can't connect to my Airport Express Wifi.  Again, the 4 connected with no issues.

     

    I checked my MAC address and it does confirm that it is apple.  Your suggestion is to visit the Apple Genius Bar and send my phone in for a replacement?

     

    Thanks,

     

    Cristi

  • jimbocook Calculating status...
    Currently Being Moderated
    Oct 18, 2012 4:48 PM (in response to C4RLOCO)

    I got my replacement iPhone 5 today from Verizon. I got my first one the day they came out and it had the problem with WPA2/AES connectivity (it connected and worked briefly but then, in spite of showing a solid connection, it would quit receiving data).

     

    I contacted Verixon support by phone and they arranged to send me a replacement but I had to wait almost a month.

     

    Well, the new phone arrived today and, after a slight glitch activating it which required a trip to the local Verizon store, everything is working as it should. I'm a few hours in now without a glitch so I'm very hopeful. It never held the WPA2/AES this long or with intensive use before.

     

    I don't see how this can be anything but a hardware issue, at least for me. Maybe glitchy wifi chips that manifest problems in different ways making it hard to pinpoint and fix all the issues with a software update which I'm sure is what Apple is hoping to do.

     

    My advice - go for a replacement.

  • voipfrisco Calculating status...
    Currently Being Moderated
    Oct 20, 2012 12:09 PM (in response to C4RLOCO)

    I have this issue as well.  I cannot connect to my WPA2 network at work at all.  I was able to connect with my iPhone 4 with IOS 6.  I am also able to connect with a Samsung Galaxy s3, the only device that will not connect is my iphone 5.

     

    I originally preordered my iPhone 5 when they first came out.  That phone would not connect.  I found this discussion and also other articles on the web that indicated there seemed to be a problem, so I requested a replacement phone.  I went to the Apple store and exchanged the phones hoping that would solve it.  It did not, so I still have the issue.  I contacted Apple support, explained the issue including the possibility of the Apple versus Intel chip (both the original iPhone 5 and the replacement have the apple chip) I provided them with the information that is here on their own forum and I have gotten nothing but the run around.  They want to transfer me over to the enterprise support dept because they saw my work email, which if course would charge a rate for support.  I told them this phone has nothing to do with my employer (it is my personal phone not provided by my employer)  I am only trying to connect to the WPA2 WiFI - which as I told them works with my other devices.

     

    Needless to say I am beyond frustrated and not really sure where to turn next.  It's pretty clear there is an issue, whether its the chip, or something else there are enough people with this issue that it's not a simple config issue. Is there a case number that is a good reference point for actually getting help from Apple?

     

    Any advice would be really appreciated.

  • perlfather Calculating status...
    Currently Being Moderated
    Oct 20, 2012 7:02 PM (in response to voipfrisco)

    As this seems unusual (most other cases were solved with the replacement) I have a perhaps obvious suggestion. I noticed that with the iPhone after you type in the password you actually have to tap "connect" on the lower part of the screen,  that is part of the keyboard rather then the "connect" button at the upper right.

    Are you connecting with the right button?

  • CClayFox Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 23, 2012 5:02 AM (in response to voipfrisco)

    I had the exact same issue, but on my home network.  It was not the iPhone5 specifically, but instead I had two SSID's with the same name.  In my case I had a 2.4Ghz router radio and a 5Ghz router radio with the same name.  IOS6 devices could not connect, but all non-IOS6 devices did, including my Galaxy S3.

     

    Check with youR IT and make sure each wireless router has a unique SSID until Apple fixes this.

  • mojer Calculating status...
    Currently Being Moderated
    Oct 24, 2012 12:23 PM (in response to C4RLOCO)

    I've had two iPhone 5s now, each with a seemingly different wifi issue. The first one simply refused to connect to any wifi network, WPA2 or otherwise, for more than a couple of minutes. When it did briefly connect, the signal was poor and speed was slow. I had no issues getting it exchanged and the new phone, which I still have, connects to wifi networks, including WPA2, and I get great speeds. The problem? When I go to a location with another WPA2 network, I can't connect unless I reboot my phone. After my phone restarts, no problems getting and keeping a good connection. Until...you guessed it, I go to another WPA2 connection, which requires another reboot. This would be less of a problem if I didn't have WPA2 at work and home and my parents' house, three locations I'm in every single day. If I go back and forth, I've had days when I've had to reboot ten times. I'd be tempted to keep wifi off, if 4G weren't so expensive and so quickly throttled.

     

    This second phone seems like it has a software issue, since the reboot totally resolves it- albeit temporarily. I'm reluctant to try to exchange it again for fear of getting a phone that doesn't connect at all.

     

    Anyone else have this issue? I suspect a lot of people simply might not know that they do because they don't use multiple WPA2 connections, or don't use them often. Shaddow- I think you have this same problem, although yours seemed to be solved. Is it still working?

     

    So so so frustrating.

  • olivemc Calculating status...
    Currently Being Moderated
    Oct 25, 2012 3:37 PM (in response to Silverstar555)

    SilverStar555  Thanks so much!  Fixed my brand new phone's wifi connection without ever having to visit the genius bar!

  • rusynr Calculating status...
    Currently Being Moderated
    Oct 29, 2012 6:11 PM (in response to Silverstar555)

    I tried that same technique on my 3rd iPhone with Apple Technical Support and it did not resolve the issue. On my 4th iPhone i did not do a restore and just resync'd with iCLoud. Much better results.

     

    I also noted that many of the iphone cases WILL cause the wifi to drop connections (went through 3 of them on the 4th phone). Seems that the high density of the material around the antennas will interfere with the wifi reception. Took off the last case and the phone had much better results. Neary zero drops and a stronger signal. Tested for a full week and had a strong signa with zero drops. Put each case back on and the issues with wifi reappeared! A case with thin plastic worked. The rubberized ones did not. Any one else that can confirm this?

  • Yuri75 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 30, 2012 3:03 PM (in response to Silverstar555)

    silverstar555 solution worked for me! thans very much. I have an iphone5 with apple wifi chip and problem connecting to my router. The network reset sorted this out.

     

    update; worked only for 5 minutes, problem seems to be back

  • FunkyFlo Calculating status...
    Currently Being Moderated
    Oct 30, 2012 3:53 PM (in response to Silverstar555)

    Dear Frank,

     

    resetting the network settings totally solved the issue. The signal strenght changed from one to three bars immediately.

     

    Thank you

  • Silverstar555 Calculating status...
    Currently Being Moderated
    Oct 30, 2012 10:32 PM (in response to FunkyFlo)

    Am glad a simple worked for you and many others. It has been working ok for me connecting to 6 hotels and 4 airports wifi. Also fine at home on WPA2 and AES.

     

    Frank

1 ... 23 24 25 26 27 ... 36 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (29)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.