Skip navigation

iPhone5 issues with WPA2/AES Wifi

185384 Views 537 Replies Latest reply: Feb 22, 2014 7:49 AM by jenniefromnew york RSS
  • jnc621live Calculating status...
    Currently Being Moderated
    Jan 6, 2013 7:10 PM (in response to pjbatten)

    Recently I have updated my iPhone 5 to iOS 6.0.2 and found that there was wifi connection problem in certain places, like office, copi tiam. But home wifi is ok.

    Discovered if the wifi security type was using WPA2, then the connection is intermittent or super slow.

    To resolve iPhone 5 6.0.2 wifi connection with WPA2 security type:
    - The solution was to manually enter wifi connection
    1. Goto Settings
    2. Select Wi-Fi
    3. Select Other... (instead of automatically select the predefine network)
    4. Enter the network name (the Wifi connection name)
    5. Select the security WPA2

     

    It works!

  • Yale DONG Calculating status...
    Currently Being Moderated
    Jan 7, 2013 2:40 AM (in response to C4RLOCO)

    i was checked my WIFI MAC Adress , it's strats with 34:C0:59:A8... made by Apple

     

    i have a question , plz tell me , if i go to the Genius Bar asked them to change that WIFI chip within my iphone , only select the MAC Adress strats with 98:B8 , or right ?

  • Steven Martin5 Calculating status...
    Currently Being Moderated
    Jan 7, 2013 6:44 AM (in response to jnc621live)

    I tried your tip but unfortunately it didn't work for me.

     

    I bought two new iPhone5's in December, a black and a white one. The black one connects to my secure AirportExtreme network without a problem, the white one sees the network but refuses to connect.

     

    Apple were kind enough to do a full replacement of the white one, but the new phone arrived today and still has same issue. I did all the usual stuff: WiFi button on/off, re-set network setting, reboot the phone, etc. I even set up a non-protected guest network but it didnt help.

     

    Any tips are welcome. With the second phone showing same prob, while the other one is flawless (as is my iPhone4) I fear there may indeed be production issues on some batches? if so, I guess the more we post the more is will become evident.

     

    My house is full with Apple gear and I am a big fan, but this stuff is annoying, certainly taking into account I paid the full, European unlocked price of over 1.000 $ per phone!

  • sb73253 Calculating status...
    Currently Being Moderated
    Jan 7, 2013 7:47 AM (in response to C4RLOCO)

    My iPhone 5 is doing the same thing.  I just had the express replacement set up to receive a new phone next day.  However, it is not completely free.  Just for those of you like me who live hundreds of miles from the nearest apple store, it will cost you a minimum of $29 dollars for this service.  They hold a pending charge for the no contract price of the phone on your credit card until they recieve your phone back.  Granted, this is probably cheaper than the gas it would take to drive to the nearest store, it is still a sucker punch when you consider I bought Apple's premimum product less than 30 days ago and it is defective.  I tried to look up my chip manufacturer with your web address and could not get it to work properly.  I would be interested to be able to do that if you could verify that the address you listed was working and accurate.  I'll let everyone know if the express replacement process goes smoothly or not.

     

    Thanks,

    sb

  • SunnyE Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 9, 2013 10:41 PM (in response to C4RLOCO)

    +1

    I bought two iPhones 5 on same day, one is working fine and other is not since upgrade to 6.0.2. This is so random. I simply can't connect to a WPA2 wifi from one of the phones. I've been thinking of two options

    - downgrade to 6.0.1

    - restore to factory default 6.0.0

     

    Its just a pain. Has anyone tried these options yet? any results?

  • Sebby* Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 9, 2013 10:46 PM (in response to SunnyE)

    In general, you cannot downgrade to an earlier version. Have you tried resetting network settings?

  • SunnyE Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 9, 2013 11:08 PM (in response to Sebby*)

    Yes, have reset network setting several times. Just won't connect.

    I thought a factory restore would take it to 6.0, I guess not.

     

    Has anyone tried a factory restore?

  • Sebby* Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 10, 2013 12:02 AM (in response to SunnyE)

    A restore via iTunes will always restore the latest version of iOS.

  • Steven Martin5 Level 1 Level 1 (5 points)
    Currently Being Moderated
    Jan 10, 2013 12:21 AM (in response to SunnyE)

    As mentioned earlier, I have the same prob as SunnyE. I am now on my third new white iPhone in 2 weeks (maybe all from the same batch?) and the problem continues. While my new black iPhone 5 connects like all my other Apple stuff to my airport extreme without a problem, the white ones recognise the network but don't connect.

     

    I did a full restore several times (as Sebby says this does install 6.0.2 by now), which didnt help - but it wasn't working with 6.0.1 either. If I had bought just one phone I would assume something was 'wrong' (or at least could be changed) on my side, but with the black phone working perfectly I have to assume this is a whole batch of problem phones. I cannot imagine Apple doesn't know about this?

     

    Any other ideas...?

  • Sebby* Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 10, 2013 12:13 AM (in response to Steven Martin5)

    Sorry if this is a silly question, but are you perhaps restoring a backup to this phone?

  • Steven Martin5 Level 1 Level 1 (5 points)
    Currently Being Moderated
    Jan 10, 2013 12:19 AM (in response to Sebby*)

    No silly questions : any help is great. The answer is that I tried everything: I have restored from scratch as well as tried to set-up a restore of previous phones. None of it worked. But certainly the last few restores I tried were from iTunes factory settings on a 'virgin' phone.

  • Couchar Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 10, 2013 1:18 AM (in response to C4RLOCO)

    I also tried to connect manually. This didn't help either.

    Any news on the release of iOS 6.1?

    I cannot image that Apple is unaware of these issues. But it's strange that even in the press (where Apple bashing has become an international sport) - apart from the Wifi issues in September/October- very few articles can be found.

    So I am wondering what their reaction will be: a solution or just: "too bad, bad luck"?

  • Kevin Stanchfield Calculating status...
    Currently Being Moderated
    Jan 10, 2013 11:14 AM (in response to Yale DONG)

    They won't change the chip in your phone.  I have the same chip and 6.0.2 fixed all WPA2/AES problems I had.

     

    Have you tried your phone with multiple routers?  Make sure it's not just your router that the phone doesn't work with.

     

    If you do decide to see an Apple genious, simply tell them that your phone does not work with WPA2/AES encrypted wifi networks and that you want your phone replaced.

  • Richard Cranium Calculating status...
    Currently Being Moderated
    Jan 10, 2013 8:17 PM (in response to Kevin Stanchfield)

    Yeah, when I tried that, I was told that since the phone could connect to a unsecure WIFI access point then it wasn't a hardware problem.

     

    Of the 6 devices in my house, precisely one will not connect to my AP (which is a linux box running hostapd) and that one is my wife's iPhone5 (running 6.02).   As far as the iPhone is concerned, I never enter the correct passphrase (which is an error that I have not seen mentioned in the forum).

  • Steven Martin5 Level 1 Level 1 (5 points)
    Currently Being Moderated
    Jan 10, 2013 11:58 PM (in response to Richard Cranium)

    Surely something is wrong with a series of iPhone5's either from a hardware or software point of view? I wish Apple would come clean on this.

     

    I am awaiting the delivery of my 4th replacement white iPhone today. And like Richard I have many other devices (including a black iPhone5, one MacBook Pro, 2 Mac Pro's, 2 iPads, and an iPhone4, ) running flawlessly on my Airport Extreme WiFi network....

     

    It cannot be that I have to go through so many attempts with each replacement phone to see if something is either wrong with the settings of the new phones or with my own (Apple) network: everything else runs fine, the conclusion seems obvious.

     

    From a trouble-shooting point of view: the iPhones that won't connect do recognise my WiFi network, they even recognise it when I try a faulty password (not sure what Richard meant with not entering the right passphrase) but after that the little wheel just keeps on spinning and no connection is ever made, even with the phone next to the router.

     

    I'll let you know what happens with iPhone no.4 today...

1 ... 30 31 32 33 34 ... 36 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (29)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.