Previous 1 2 3 Next 543 Replies Latest reply: Apr 22, 2015 12:27 PM by drachenfeder
C4RLOCO Level 1 Level 1

I am using a Dual- Band Linksys E2500 router with WPA2 Personal (WPA2/AES) enabled. None of my other apple products (iPhone4S, iPhone4, iPad2 and the New iPad) have had problems connecting to my router. But everything changed when I got my iPhone5.


Basically the iPhone5 is capable to connect to the WPA2-Personal wifi network but after 1-2min starts to drop network packages, hence, I cannot browse any page (not even the router page even though I still have a valid IP and the wifi icon is shown on my top screen.


I pinged the phone from my router diagnostics page and while I can browse the web with the iPhone5, I can see no packages lost. However after 1-2min the iPhone5 cannot open any websites while still connected to the wifi, it starts to show network packages lost.


A workaround that I found was to create a "Guest" network (which is not WPA2-Personal) or even WEP. There are no issues when connecting to these alternate networks.


Can anyone out there confirm this issue?? Is it software or hardware related?? It seems to me there are issues with WPA2-Personal (WPA2/AES)


Thanks in advance,


iPhone 5, iOS 6
Solved by C4RLOCO on May 3, 2013 9:45 AM Solved

Ok Folks! UPS just dropped off my new replacement iPhone5 and I have an update for you: The new replacement works BEAUTIFUL with my WPA2 network and I did not change a thing. I got the new phone, restored my backup and I was able to connect and hold the Wifi connection.



P.S: My only complaint now is that the new phone came with some scuffs




Durham, NC USA


<Edited by Host>

Reply by C4RLOCO on Oct 3, 2012 8:44 AM Helpful

theswerm, can you post the first 6 digit of your MAC address? it seems that 88:53 is not exclusively from Intel, meaning it might belong to Apple as well.


In other words, if your prefix is 88:53:95 then you might have the Apple Wifi chip.

All replies

  • Lon Seidman Level 1 Level 1

    I'm having the same issue with my phone and an Apple Airport Extreme.  Works fine on a guest network set up with no encryption but drops dead after a few minutes when WPA or WPA2 encryption is turned on. It stays connected to the Wifi AP but no data gets transmitted or received.


    Also I can confirm it's not just WPA2, it's also doing this with the AP configured for WPA only.

  • AndrewCapon Level 1 Level 1

    Yep mine is the same WPA/WPA2 has problems and only lasts 5 - 10 seconds before giving up.


    WEP and unsecured work fine.


    To me it looks like a hardware issue, as far as I can see from the other threads people have got replacements which then work perfectly.


    I had apple support ringing me today but got an email saying I had cancelled it! So now they are ringing tomorow.


    I am going to push for a replacement.

  • Joe5150 Level 2 Level 2

    Some people are reporting problems here with wifi connectivity, I use WPA2 Personal (WPA2/AES) with no problems with my iPhone 5 (router Apple time capsule new version) so I dont think its that.

  • AndrewCapon Level 1 Level 1

    Hi Joe,


    This thread is for people that have problems with the iPhone 5 and WPA/WPA2 not for any other wifi related problems.





  • OllieO96 Level 2 Level 2

    I have the same problem, got my iPhone via pre order and worked on the wifi fine but had a big chip in it, took it to my local apple store to get a replacement and the new one will not work on wifi 802.11n with WPA/WPA2 encryption. Works fine on b/g bands on WEP encryption or open networks.

    Currently on the Phone to apple trying to get to the bottom of it, highly doubt a software issue and pretty upset seeing as this is already my second iPhone and its only been out 2 days! Will post any info I get from apple if any ...

  • GregM1 Level 1 Level 1

    I made an unsecured "guest" wifi account on a MBP at home.  The iPhone 5 sees and apparently connects to the guest account, but the phone has absolutely no Internet access. (shrugs)


    I've already tried:
    --restarting the router

    --logging into the iPhone 5 with different encryption schemes

    --disabling security via the online router software


    Still nothing has worked.

  • hudder Level 1 Level 1

    Good afternoon all, rang apple support and after going through all the different things to do, confirmed it was a hardware issue.  Will exchange from store I purchases tomorrow.  Hope all goes well for everyone.

  • ricsteinberger Level 1 Level 1

    One has to wonder how it came to pass that, on top of the new Apple Maps fiasco, a problem with connecting via Wi-Fi came to be present in Apple's latest iPhone.  There are now almost 20 pages here: of loyal iPhone users expressing their frustration with being unable to easily connect via Wi-Fi, often to Apple made routers.


    My sense is that this is a software issue, as it's hard to believe that so many users ended up with defective phones.  That's good news because it means that Apple should be able to fix it once they acknowledge that the problem exists and is serious.


    Until then, iPhone 5 users may have to either do without WI-Fi, or reconfigure their router to a less secure setting.  Obviously not an option when in other Wi-Fi networks.


    This never would have happened had Steve Jobs still been alive... sigh...

  • OllieO96 Level 2 Level 2

    I confirm apple care have also told me that i need (another) new handset, will also be going to my local apple store within a few days to hopefully get one that works. Will definitely be testing it before i leave!

  • OneMoreAnimal Level 1 Level 1

    I fixed the issue by setting up my iPhone 5 with a static IP address in my router using the phone's Wifi MAC address. Now I get fast speeds and a consistent connection using WPA2 (AES).

  • C4RLOCO Level 1 Level 1

    I'm giving it a try to this workaround... I'll post my results..

  • C4RLOCO Level 1 Level 1

    No change... This did not work for me. I called Apple and I spoke with two Senior iOS advisors. We troubleshoot everything that they could possible think and no improvement was made.


    I having my phone replace through Apple Express Replacement for free. They can send you a new phon for free and you can ship your phone back to  them once the new one arrives.


    I will post an update on Tuesday or Wednesday with the new phone. I am planning NOT to make ANY changes to my WiFi network (since all my devices work with no issues) to see if a new phone is definitely the solution.

  • mweholt Level 1 Level 1

    The static ip address solution described by OneMoreAnimal solved my problem of my phone cycling wifi connection on/off every three or four seconds. So far, anyway.

  • C4RLOCO Level 1 Level 1

    My phone Serial Number starts with "DN" and according to this website my phone was manufactured in:


    Factory: DN (China, Chengdu - Foxconn)

    Production year: 2012

    Production week: 37  (September)


    I wonder if all of us with the WPA2 issue have phones that came from the same Factory and also the serial numbers with DN manufactured on the same week.

Previous 1 2 3 Next