Previous 1 2 3 4 Next 213 Replies Latest reply: Nov 22, 2013 2:43 PM by JTiss Go to original post Branched to a new discussion.
  • DigitalSciGuy Level 1 (0 points)

    I just went to one of my local Apple Stores this evening for an appointment I had set up to see what the Geniuses had to say. During my wait for my appointment, I plugged my device into a big, beautiful, expensive Bang & Olufsen portable sound system with attached iOS device dock. Professional Griefers from the latest Deadmau5 started playing loudly and richly through the $800 appliance.


    I unplugged my device and lo and behold, the volume control UI returned to the already open iPod app. I clicked to resume playback and sound started coming out of my phone's built-in speakers.


    I held down the sleep/wake button and the home button until the phone reset; upon boot, the volume control was again missing from the iPod app and any video I opened up on the web.


    To replicate the resolution, I plugged my phone back into the dock connected into the picnic basket-looking speaker and it started playing music again. I unplugged the device from the dock, shut down the phone properly by holding down the sleep/wake button until prompted with the slider button to shut off the device.


    Upon reboot, the phone was again able to play audio through the built-in speakers from the iPod app, web videos through the browser, the Settings app, etc.


    So far, docking then undocking the iOS device appears to be the most common resolution to this issue as corroborated by the Genius that ended up helping me about 10 minutes after my scheduled appointment and those who have reported successful resolution on the web. I am submitting a bug to Apple through Apple's Bug Reporter; it is in their bug reporting database as Problem ID 12390526.


    One thing I'd like to take note of as a possibly significant contributor to the bug is whether you updated OTA (Over the air) using the update directly on the phone or if you updated through iTunes.

  • Seluma Level 1 (0 points)

    Thank you.  My iPhone 4s iOS 6 had the exact problem you described. Used my Sony Dock to listen to some music and the problem was replicated and solved using your advice.  Hope Apple fixed the problem. Thanks for your posting.

  • sboccardo Level 1 (0 points)

    Surprise, today I can notw hear in my earpiece in the phone.  Not sure what happened but it is working for now, fingers crossed!

  • hoorge Level 1 (0 points)

    The sounds on my phone started working late yesterday afternoon and so far so good.  But, I'm not optimistic that it'll stay that way.  We'll see.

  • hoorge Level 1 (0 points)

    Well, I spoke to soon. I have once again lost sounds.  I've hardly used my phone today and have not done anything different.  I'm really hoping that Apple is paying attention to these complaints and will release a fix soon.

  • 4h Level 1 (0 points)

    I lost all sounds from my iPhone 4S few days after I installed the IOS 6 , as if the phone in compete mute mood !!

    It works only on docking stations , no response from hone speaker

  • _morgan_ Level 1 (0 points)

    Hi, I was having the same issue. No keyboard clicks, or any other sounds for my iphone 4s. I then read a thread somewhere else about the mute button right above the volume contol on the top left hand side of the phone. you can mute and unmute the sounds that way. this is on the upper left hand side above the volume buttons on the phone hardware.

  • ATXJ Level 1 (0 points)

    I agree w digitalsciguy. Lost my sound twice. Got me very frustrated. Read somewhere about putting the iphone4s into a sound dock and I tried. It worked for me. I had put mine into a radio w an iPhone/iPod dock and it wasn't even powered! That worked twice for me so I'm inclined to think that it's the solution for now.

    Might be some bug which tricked the phone into thinking its plugged to some music dock and hence muted the device's speakers.


    Anyways in response to digitalsciguy's Qn, I had updated mine over the air via wifi.

  • bustersdad Level 1 (0 points)

    Have someone at the apple store look at your dock connector on your phone. If there is any corrosion the sounds won't work. They replaced my 4s the other day because of a touch of corrosion and everything is fine. I thought it was IOS 6 too but it is running fine now on my replacement 4S.

  • hoorge Level 1 (0 points)

    It not not a physical issue or a hardware issue with the dock connector or earphone connector.  This is definitely a bug with iOS 6.  Verizon replaced my phone this week in as they claimed it was a hardware issue, but I'm having the same problems with my replacement device.  Sound works off and on depending on what kinda mood it's in. 

  • AshleyRussell Level 1 (0 points)

    Hi everyone,


    I had the problem of once i updated to iOS6 my sound completely went, apart from on calls and my alarm. Vids were silent on my camera roll and youtube.


    What i did was went into:



    Turn "Change With Buttons" off then on again


    now i have my sound back albeit without the Volume bar you would normally have on videos!


    but the buttons and sound both work so im happy now.


    Hope this helps, should be the same on iPad too



  • LuLuBabii23 Level 1 (0 points)

    I'll be going into apple on Tuesday. My sounds go in and out on my iPhone since the iOS 6 update. If I turn my phone off (which it doesn't stay off it powers itself back on), charge it, or switch it from vibrate I lose the notification sounds, keyboard clicks for anywhere up to an hour at a time. What's strange is my husband has an iPhone 4S as well (his is white) and he has NONE of these problems. I updated his phone the exact same way as mine. Also to when my sounds came back earlier today they sounded very distorted. Robotic. The only thing that works to get my sounds back is for me to leave it alone 

  • steve4425 Level 1 (0 points)

    My earpiece sound came back. . and aIthough I did re-plug phone back into laptop and re-toggled buttons- I had done that before- I think it simply started working. Odd.

  • yelnatsxxx Level 1 (0 points)

    Go to Music, set Sound Check "ON" - solved the issue for me

  • Jac1984 Level 1 (0 points)

    This worked for me! I updated OTA via wifi. Hope they fix it soon. I'm not looking forward to running to find a dock every time I want to hear anything. But thanks!

Previous 1 2 3 4 Next