Previous 1 5 6 7 8 9 Next 127 Replies Latest reply: Jan 1, 2014 2:38 AM by geomac91 Go to original post Branched to a new discussion.
  • Soyhandm Level 1 Level 1

    First of all, I can guarentee that iphone/ipad has no design for saving battery by disabling wifi on screenlock. I have been using my iphone/ipad without this bug until 5.1.1. After many tries, I have found that the issue comes after syncing with itunes on pc. To fix it:


    - turn your wifi "on" and connect to the wifi.

    - go to settings>reset> and reset your network settings while wifi is "on"


    After reset is complete, do not sync or connect your ipad/iphone with itunes; not even from wifi sync.



    I've tried this for many times and it solves my problem. I sync once a week, and every sync brings the issue back.

  • Tumberry Level 1 Level 1

    Ios 6.1 gave my iPhone 4 a better battery life and wireless in background works as well.


    Try the update !

  • JasonBekar Level 1 Level 1

    Ok i came up with this solution. It seems working for me. So try this out may be it ll work for you too. First consider the router you are trying to get Wi-Fi connection also serves other I-Phones in the same time. Now, Go to Settings>Generel>About>Name and change the factory released (I-Phone) name to your own unique name. Then go to Settings>Wi-Fi and hit the "OFF" button for "Ask the Join Networks" and switch it to "ON". Later go Safari and try to load a webpage. I-Phone automatically will pop a window showing you available networks. Choose your Wi-Fi spot and enter password. Let I-Phone see and recognize your Wi-Fi spot. Reboot your device. I-Phone will restart with Wi-Fi icon on meaning connecting to your Wi-Fi network. You can now turn off "Ask Join Networks" if you want.

    Hope that will work for you. Reply if it works for you. Thanks


    Device Info: I-Phone 5 64 GB, Version 6.1 (10B143)

  • Nishdesai95 Level 1 Level 1

    My friend thanks a lot for your help but after doing the steps you mentioned was the problem of wifi off when screen locked solved??

    I tried your solution it showed wifi connected after reboot only when PASSCODED WERENT SET ELSE IF PASSCODE WAS THERE IT WOULD CONNECT UNLESS WE UNLOCK WITH THE PASSCODE.

    SO FRIENDS IF YOU WANT MR.JASON's solution you should keep PASSCODED OFF

  • twinkletoesmofo Level 1 Level 1

    Ok, thank me later.


    I have an iPhone 4S with 6.1.3 and same issue/problem since the beginning.




    Turn screen auto-lock in settings to "NEVER", and wifi will stay connected while screen off. I've tested it after waiting 1 hour with screen manually turned off.

  • Nishdesai95 Level 1 Level 1

    Thanks a lot friend!!

    But i think there has to have another workaround like reset and stuff hecause they do work

  • twinkletoesmofo Level 1 Level 1

    Well, if you want your wifi to work while your phone is locked, as of this point there's only one thing you can do.


    What I said above.


    It's just one simple step of manually locking the screen.


    What's the big deal?


    Do you want wifi or not?

  • Nishdesai95 Level 1 Level 1

    Im really sorry but your workaround is not working on my 4S.

    I just got it a month back!

    I have tried everything!! But no luck;(

    But friend can you tell ne whether i have to resesr network settings or turn of ask to join networks

  • danielharris Level 1 Level 1

    Try resetting your network settings, works for me everytime we have an update

  • Nishdesai95 Level 1 Level 1

    Thank you friend but i have already tried that!!

    I think setting proxy to auto worked for me but then i changed aitolock to never and then all the problem began!!

    Please help

  • TimmyRaa Level 1 Level 1

    Lots are saying this is expected behaviour with iPhones, they have a mobile/cellular network connection to fall back on, but what if you're on an iPod or wifi-only iPad?


    My iPod has just started doing this since updating to the latest version of iOS6 - no messages come through if the screen has gone off, I have to unlock it to check. Useless. So much for "it just works".

  • Nishdesai95 Level 1 Level 1

    Actually mine works very well for the first10minutes then the same problem'!! When i press home my wifiis connected but no notifications:( i open the apps and i get all of them there!! I tried resetting setting like so many times  and soft reset but no luck;(

    My ipad mini works just perfect!! Both on 6.1.3

  • suhail1786 Level 1 Level 1

    I think iOS 6 has the problem this was not the case in iOS 5 so according to me to turn wifi  on even when your phone is in sleep is to let the safari browser running in the background yes it could use your battery a little but I think it is the only option available it worked for me 

  • suhail1786 Level 1 Level 1

    Sorry not safari browser but any social network apps like FB or what's app or we chat

  • Lawrence Finch Level 8 Level 8
    Mac OS X

    suhail1786 wrote:


    I think iOS 6 has the problem this was not the case in iOS 5 so according to me to turn wifi  on even when your phone is in sleep is to let the safari browser running in the background yes it could use your battery a little but I think it is the only option available it worked for me 


    Actually, NO. iOS 1 had this FEATURE. iOS 2 had this feature. iOS 3 had this feature. iOS 4 had this feature. iOS 5 had this feature. iOS 6 had this feature. And its likely that iOS 7 will have this feature. You can confirm this by doing a search of the forum going back 7 years. You will see mention of it for every version since the beginning.


    Its there because WiFi, when it is on, requires a continuous 30 mw of power, unlike cellular, which only uses power when sending or receiving. If WiFi stayed on all the time it would drain the battery in a few hours. Then you would see complaints about the battery draining fast, rather than WiFi turning off when the phone goes to sleep.


    It is BY DESIGN this way. If you want to keep WiFi on when the phone is asleep just plug the phone into its power adapter. This overrides the automatic shutoff.

Previous 1 5 6 7 8 9 Next