10 Replies Latest reply: Oct 27, 2012 7:58 AM by Hans Eklundh
RyanRRC Level 1 Level 1

I am hopeing someone can help.  Since I upgraded my iPad2, new iPad, iPhone 4s, and iPhone 5 to iOS 6 I am unable to print to my HP 3050A.  One app says "a connection problem occurred: SSL problem (possible causes may include a bad/expired/self-signed certificate, clock set to wrong date)" while notes acts like the file was sent but printer does not react.  I've rebooted the router, printer, Apple devices, everything.  I don't believe it is a HP issue since it still works when printing from my windows laptop (sorry guys, haven't upgraded it yet).


iPhone 5, iOS 6
  • lmurillo19 Level 1 Level 1

    I believe iOS 6 has an AirPrint bug because at work we have Linux CUPS AirPrint server and on iOS 6 devices doesn't show AirPrint printers, while on iOS 5 devices that haven't been updated to iOS 6 show the printers....I think apple rushed the iOS 6 and many bugs were left unpatched.

  • Alaska Paganini Level 1 Level 1

    AirPrint don't work on iOS 6... :(

  • jimmypowder Level 1 Level 1

    In my experience, iOS 6 has more bugs then Florida .

     

    This is definitely the worst update in terms of bugs I have ever seen from an Apple product.

     

    I have had  Notification problems ,messaging problems , map problems , iTunes Store problems,

    And on and on.

     

    Fortunately , I have not run into a AirPrint problem yet .

  • Arraial Level 1 Level 1

    AIrPrint does not work on my Canon MG5350 after installing IOS 6.....

    The Apple Service Center in Holland tried to help me fix it, Unfortunately without result.

  • kramere_wrk Level 1 Level 1

    This post has the answer for allowing iOS 6 AirPrint to OS X server:

     

    iOS 6 AirPrint not working with 10.6 Server - FIX!!!

  • ryebread00 Level 1 Level 1

    Reboot your router.  That's all I did.  iphone 5 now sees my printer just fine.

  • lmurillo19 Level 1 Level 1

    Found the solution to the Linux CUPS Server what apple did was change the programming language in the AirPrint printing communication with the printers. For the majority of you guys restarting router may work but since they changed the language you'll need to update the firmware of your printer...go to the manufacturer's website and look for your printer and see if there's an update for your printer...if there isn't ask the printer's support team. But you'd need to update the firmware. For HP D110 you can update from the panel (we have these at work). Best of luck!

     

    If you have a Linux CUPS server see solution below, did this at work and all the users were happy again :)

     

    First, you have to create new mime stuff and restart cups:

     

    echo "image/urf urf string(0,UNIRAST<00>)" > /usr/share/cups/mime/airprint.types

    echo "image/urf application/pdf 100 pdftoraster" > /usr/share/cups/mime/airprint.convs

     

    service cups restart

    Then you must regenerate the avahi service using the airprint-generate.py script from:

     

    https://github.com/tjfontaine/airprint-generate

    This will again create .service file(s) for each of your printer(s).

     

    Then copy the generated .service file(s) to the appropriate directory and restart avahi-daemon:

     

    cp AirPrint*.service /etc/avahi/services/

     

     

    service avahi-daemon restart

    That’s it. Printers should now show up (again) on devices updated to iOS 6.

  • dlcrow Level 1 Level 1

    Duplex printing does not work even with the suggested changes to the CUPS configuration.  Any thoughts on why or if it will be possible to resolve this?

  • IPod touch 4g user (Malik) Level 1 Level 1

    well theres lots of bugs in iOS 6. it means apple company did a very poor job on it. like the app store, still safari, and of coarse not adding ALL printers. but they probably didnt be care when typing in the codes, and didnt care whats been deleted

  • Hans Eklundh Level 1 Level 1

    I restarted my AirPort Exreeme and my AirPrint Printer and after that it all worked fine.