10 Replies Latest reply: Dec 5, 2012 12:13 AM by Terry P
shilpam Level 1 (0 points)

I was trying to update the iOS to version 6. The iPad was backed up and when trying to update the iOS 6 it errored with -1 error code. I set the iPad in recovery mode and tried to Restore it. It then gave an error code of 1604. I have tried the steps mentioned in the troubleshooting article for 1604 error and so far no luck restoring my iPad. Please help.


iPad 2, iOS 4.2.7
  • Philly_Phan Level 6 (13,261 points)

    If you're unable to do the Restore, go into Recovery Mode per the instructions here.

  • shilpam Level 1 (0 points)

    I have done that multiple times and iTunes recognises that iPad is in Recovery mode. I start the restore. iTunes shows that it is extracting software, then preparing iPad for restore and after some time I get the 1604 error. I have done this at least 5 times.

  • AnaMusic Level 9 (57,110 points)

    Error 1604

    This error is often related to USB timing. Try changing USB ports, using a different dock connector to USB cable, and other available USB troubleshooting steps (troubleshooting USB connections. If you are using a dock, bypass it and connect directly to the white Apple USB dock connector cable. If the issue persists on a known-good computer, the device may need service.

    If the issue is not resolved by USB isolation troubleshooting, and another computer is not available, try these steps to resolve the issue:

    1. Connect the device to iTunes, confirm that the device is in Recovery Mode. If it's not in Recovery Mode, put it into Recovery Mode.
    2. Restore and wait for the error.
    3. When prompted, click OK.
    4. Close and reopen iTunes while the device remains connected.
    5. The device should now be recognized in Recovery Mode again.
    6. Try to restore again.

    If the steps above do not resolve the issue, try restoring using a known-good USB cable, computer, and network connection.

  • Philly_Phan Level 6 (13,261 points)
  • Texas Mac Man Level 8 (46,565 points)

    iPad: Basic troubleshooting

    http://support.apple.com/kb/TS3274

     

    iOS: Resolving update and restore alert messages

    http://support.apple.com/kb/TS1275

     

    iPad: Unable to update or restore

    http://support.apple.com/kb/ht4097

     

     Cheers, Tom

  • shilpam Level 1 (0 points)

    Thanks everyone for the replies. I have followed all the steps specified in the articles posted on the support site. I upgraded my iPhone 4 to iOS 6 using the same cable and same USB port. But to make sure, I changed the USB port, I tried a different cable and to no luck so far. Belive me, I have done everything mentioned in the articles related to 1604 error and still get the same error.

  • shilpam Level 1 (0 points)

    I trying something different now. I have rename the ipsw file assuming it was bad when it downloaded. Opened up iTunes and downloading iOS 6. Hopefully it will work this time. If not, I will have to take it to the Apple store since I have run out of options.

  • K9Tracker Level 1 (0 points)

    shilpam,

     

    EXACT same issue here.  Did you ever have any luck getting the iPad going?

     

    Thanks

  • We love the Manchego Level 1 (0 points)

    Hi all,

     

    When the ipad is in recovery mode, it's USB ID is '05ac:1281 Apple, Inc. Apple Mobile Device [Recovery Mode]'.

     

    During the restore process (after the software has extracted and when the message 'preparing ipad for restore' comes up) the USB ID changes to '05ac:129a Apple, Inc. iPad'. This makes the operating system think that a usb device has been unplugged and a different one plugged in (even though it's the same physical ipad!).

     

    From what I can tell the error comes when Windows fails to detect the new USB ID and so itunes thinks the ipad has been unplugged. In Windows XP you hear the 'de dum' noise when it thinks the ipad is disconnected.

     

    I run a linux operating system and run windows through Virtualbox, so to solve the problem I reconnected the ipad via the Virtualbox settings whenever I heard the 'de dum' sound during the restore process. It was then re-detected before itunes noticed anything was wrong and the restore process completed.

     

    If you are getting this error when connecting directly into Windows, you may find that taking the cable out of the usb port and reconnecting it whenever the 'de dum' sound is heard will have the same result...hope this helps.

  • Terry P Level 1 (0 points)

    Thanks a bunch for posting that!

     

    I was at my wit's end having tried over most of the day yesterday to restore my iPad from this alien 'recovery mode'. After some trial/error with the timing of unplugging and reconnecting, I finally hit some winning combination on this XP PC and, an hour or so later, had a working iPad again.

     

    I'm not technically savvy enough to interpret its relevance, but as you see from my last post in this thread

    https://discussions.apple.com/thread/4570252

    at one point it seemed that iTtunes was calling my iPad by a different name. Or perhaps that was just a 'generic' name?

     

    One other factor that may have contributed to my difficulty was that before starting the task of

    Step 2: Updating iTunes to v 11

    Step 3: Updating my iPad iOS from 4.2 to 5

    I bit the bullet after several years and

    Step 1: Updated XP to Service Pack 3 (I'd had a major failure back in 2008 and had postponed another attempt.)

     

    It seems that this may have affected all my USB settings, as I had the New H/W Wizard popping up during my subsequent work with iTunes.

     

    --

    Terry, East Grinstead, UK