Skip navigation

Command-line instruments on older but supported iOS/Device combinations?

1838 Views 1 Reply Latest reply: Mar 5, 2013 11:00 PM by guoleii RSS
karl.krukow Calculating status...
Currently Being Moderated
Sep 24, 2012 1:40 AM

I noted Eric Wings post on: "Command line instruments broken with pre-iOS 6 devices".

 

http://lists.apple.com/archives/xcode-users/2012/Sep/msg00187.html

 

I'm running XCode 4.5 and I too am experiencing similar problems:

 

3GS with iOS 6 -- works

3GS with iOS 5.1.1 - unable to start: Instruments Trace Error: Failed to start trace.

 

iPad2, iPhone4S with iOS 5.1.1 - works

iPhone 4 with iOS 4.3.3 - unable to start: Instruments Trace Error: Failed to start trace.

 

Note that this is invocation via commandline (instruments script).

 

When invoked through XCode UI (UIAutomation tool) it works on all configurations - so it seems this is a commandline issue only.

 

Did anyone manage to get closer to a solution (other than managing several installations on different machines/virtuals)?

 

 

Kind Regards,

- Karl

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.