Previous 1 2 3 4 Next 249 Replies Latest reply: Nov 17, 2013 8:51 AM by Bill Stephenson Go to original post Branched to a new discussion.
  • Emanuele1985 Level 1 Level 1 (5 points)

    we can add my brother's iPhone 4s: same annoying problem

  • MikeT in NJ Level 1 Level 1 (0 points)

    Well, I can confirm that turning off cellular data does not fix the issue.  A ping test shows the phone unlocked, then going to sleep.  This is with cell data off.  Noted below is when the home button is pushed.

     

    Reply from 10.10.10.46: bytes=32 time=120ms TTL=64

    Reply from 10.10.10.46: bytes=32 time=42ms TTL=64

    Reply from 10.10.10.46: bytes=32 time=65ms TTL=64

    Reply from 10.10.10.46: bytes=32 time=66ms TTL=64

    Reply from 10.10.10.46: bytes=32 time=113ms TTL=64

    Reply from 10.10.10.46: bytes=32 time=137ms TTL=64

    Reply from 10.10.10.46: bytes=32 time=60ms TTL=64

    Reply from 10.10.10.46: bytes=32 time=186ms TTL=64

    Reply from 10.10.10.46: bytes=32 time=422ms TTL=64

    Reply from 10.10.10.46: bytes=32 time=394ms TTL=64

    Reply from 10.10.10.46: bytes=32 time=59ms TTL=64

    Reply from 10.10.10.46: bytes=32 time=81ms TTL=64

    Reply from 10.10.10.46: bytes=32 time=105ms TTL=64

    Reply from 10.10.10.46: bytes=32 time=104ms TTL=64

    Reply from 10.10.10.46: bytes=32 time=51ms TTL=64

    Reply from 10.10.10.46: bytes=32 time=75ms TTL=64

    Reply from 10.10.10.46: bytes=32 time=99ms TTL=64

    Reply from 10.10.10.46: bytes=32 time=113ms TTL=64

    Reply from 10.10.10.46: bytes=32 time=106ms TTL=64

    Reply from 10.10.10.46: bytes=32 time=52ms TTL=64

    Reply from 10.10.10.46: bytes=32 time=78ms TTL=64

    Reply from 10.10.10.46: bytes=32 time=100ms TTL=64

    Request timed out.

    Request timed out.

    Request timed out.

    Request timed out.  <pushed home button>

    Reply from 10.10.10.46: bytes=32 time=144ms TTL=64

    Reply from 10.10.10.46: bytes=32 time=464ms TTL=64

    Reply from 10.10.10.46: bytes=32 time=280ms TTL=64

    Reply from 10.10.10.46: bytes=32 time=96ms TTL=64

    Reply from 10.10.10.46: bytes=32 time=96ms TTL=64

    Reply from 10.10.10.46: bytes=32 time=17ms TTL=64

     

    If I did not have another 4s with iOS5 I would not have found this.  The other phone ping tests for over 3 minutes with the phone locked with no lost packets.

     

    Apple, this could be why some people have very bad battery issues, and others do not.  If iOS5 was made to sleep the WiFi, and not all phones do for whatever reason, this could be substantial.  I clearly have one in my possession that does not, and the battery life is quite bad. ;-)

     

    I do think this should be a user option in the autolock area of settings.

     

    Battery pack for me... I hate my building!

     

    Mike

  • yanipopo Level 1 Level 1 (0 points)

    Thank you for providing even more results! So it is only on iOS 6, we can confirm that, right?

  • MikeT in NJ Level 1 Level 1 (0 points)

    I can only confirm that the other 4s running iOS5 does not sleep the WiFi.  If this is really not the intended behavior, then maybe this working this way is in fact a bug.  This could also be a battery issue that some people seem to have, and some people do not. 

     

    I have no way to check my 4s with iOS5 because it was already upgraded.  I can tell you that mail, iMessage, and other data always came through in my building with ZERO service.  After the iOS6 update, I have nothing until I wake the phone up.  Once waking, mail, iMessages, and other data arrives. 

     

    I could certainly understand from Apple's perspective why this would be the intended behavior (battery life), but I would rather have the choice.  Most people are not in the situation I am in, and this would never be an issue for them.  For me, I need WiFi all the time, or the phone just as well could stay in my car.

     

    I am going to check with other friends that have not updated, and see how their phones fuction.

     

    Thanks,

    Mike

     

    EDIT:

     

    Arrow you could be correct, this might be something intended from iOS5 on. But again, the phone I can use for testing does not confirm that.

  • arrow7 Level 1 Level 1 (30 points)

    you guys are all sure you don't have "do not disturb" mode turned on or scheduled?

  • yanipopo Level 1 Level 1 (0 points)

    Even with do not disturb, wifi IS STILL active.

     

    Our issue is that when iphone goes to sleep mode, the wi-fi is turned off and the notifications dont push through. Only happened in ios 6.

  • arrow7 Level 1 Level 1 (30 points)

    I know ... but some of you complain about not being notified until they light up the phone screen

  • Emanuele1985 Level 1 Level 1 (5 points)

    It seems that WiFi keeps running during sleep-mode if the iPhone is connected to my Macbook Air via USB (iTunes open)

  • yanipopo Level 1 Level 1 (0 points)

    Yeah. But hopefully apple makes it a point to give us a choice. This is such a setback!

  • yanipopo Level 1 Level 1 (0 points)

    Hey Mike! can you try setting your wi-fi's proxy to AUTO?

     

    I've done this and ever since, my notifications seem to be on-time again.

  • Brown2110 Level 1 Level 1 (0 points)

    Turn off ask to join all networks in the wifi settings.

  • alicia226 Level 1 Level 1 (0 points)

    We have a similar problem. Maybe we can help you

     

    https://discussions.apple.com/thread/4339914?start=0&tstart=0

  • Sk8Dreams Level 3 Level 3 (855 points)

    WiFi has always been shut off in sleep mode, long before iOS 6.  When the phone is connected to a power source, it stays connected to WiFi also.  This is nothing new.

  • zainman88 Level 1 Level 1 (0 points)

    This is the exact experience i've had MikeT

     

    updated my iPhone 4S 16GB to iOS 6 the day it came out (19th of September) and i've noticed this change ever since.

     

    I also live in an area where there is no cellular reception and therefore when i get home, i turn my phone to Airplane mode to save battery but leave the wifi on as i can get push notifications like iMessage, facetime and whatsapp.

     

    Now though, after upgrading to iOS 6. When my phone is locked, it disconnects  the WiFi and when i manually unlock it, takes a couple of seconds before the WiFi icon re-appears and i get all my notifications/messages etc.

     

    Extremely annoying.

     

    I can confirm that if you leave the phone plugged in to a power source, the WiFi will not turn off.

     

    I am yet to try the Auto-proxy setting, but if anyone has any solutions, it would be greatly appreciated!

  • LouisNeville Level 1 Level 1 (0 points)

    I have used iphones for years and I get a lot of email so i carry my phone in my pocket and I'm notified within seconds of incoming mail. I just installed IOS 6 and now my phone turns the wifi off when its asleep so i have to get it out my pocket every 5 minutes to press the home button to reengage the wifi...

     

    This is ridiculous.

     

    Ian Parkinson stop being so immature 'You are incorrect, and won't listen, so no point us helping anymore, bye, bye.' That type of comment is not helpful so please don't comment anymore as we are trying to get to the bottom of a problem and negative input is not welcome...

     

    This is for you Ian - With IOS 6, wifi is disabled when the phone is asleep after locking, when pressing the home button while locked the Iphone wakes and in 1-3 seconds the wifi is enabled even though its still locked, that is when you took your screenshot...

     

    This new implementation into the OS should be controllable by the user.....

Previous 1 2 3 4 Next