Skip navigation

iOS 6 disables wi-fi on sleep mode - disappointing

91157 Views 249 Replies Latest reply: Nov 17, 2013 8:51 AM by Bill Stephenson RSS Branched to a new discussion.
  • ehar Calculating status...
    Currently Being Moderated
    Mar 22, 2013 1:32 PM (in response to ehar)

    In reference to my last post above, appearantly the shutting down of the internet that the iPod does when it uses the Autolock feature is different than if you manually click once to lock it. The shutting down of the internet seems to be "tied to the autolock setting", but "NOT tied to being locked manually."

     

    So a solution IS FOUND. Simply go to settings/general and set AUTOLOCK to NEVER turn off. Then when you are done using it, or want to lock it manually that's fine. As long as the autolock is set to never it will not shut down the internet when you lock it manually.

     

    The internet being shut down is not tied to whether the iPod is locked or not. It is tied to the AUTOLOCK setting.

     

    So remember, even if you lock it manually; if Autolock is not set to never it is still on and will shut everything including your internet off even if you lock it manually. So shutting it off manually alone will not do it. You MUST turn autolock to NEVER, and then when you lock it manually everything will stay on and life is good.

     

    Problem solved.

  • ljcool Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 22, 2013 1:41 PM (in response to ehar)

    I don't know where you get your theories but it's basically the same. Auto-lock or not, it shouldn't be disconnecting the wifi. It doesn't on my device.

  • sototel Calculating status...
    Currently Being Moderated
    Mar 22, 2013 2:02 PM (in response to ehar)

    I think most people see this as a problem breaking an essential functionality of inbound connectivity for push notifications, inbound email, text, inbound voip calls, etc. It affects more than one device. This thread clearly mentions iPods, iPads and iPhones. The solution to put the device in a stanby mode instead of sleep (autolock) is definitely worth trying. Hard reset, reboots and other voodoo do not really point to any user controlled setting and this is why they work only for some. The standby mode vs sleep solution point to a user controlled setting and the results should be able to replicate across multiple devices. I think I would like to point out that this approach dramatically lowers the security of the device. Real life case study: My daughter had her iPod stolen without auto lock. Her iPod remembered passwords for her email any many online accounts she used frequently. Following the theft we spent hours changing passwords and evaluating which information was compromised.

  • ljcool Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 22, 2013 2:14 PM (in response to sototel)

    That solution however as you mentioned is quite compromising. There are no user controlled settings that will definitely solve this problem. The one ehar mentioned is no different than hard reset, reboots and other voodoo as you want to call it. Because the problem doesn't have a definite cause to begin with.

  • simcam68 Calculating status...
    Currently Being Moderated
    Mar 22, 2013 2:41 PM (in response to ehar)

    This seems to be a good discovery. I will test this to see if it really has an effect.

     

    But as far as "problem solved", no,  it is more like "bandaid applied". The problem is that apple chose to change the way the product operates with no regard for how the customer uses the product.

     

    I also agree with sototel that this could be a security problem...

  • abfield Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 25, 2013 10:40 AM (in response to simcam68)

    Well, so much for AUTOLOCK being the band-aid. My corporate security policy removes "Never" from the options because it is a security issue. So, I can't try this solution. Again, this only happens on my corporate WiFi network but on my home WiFi, which is WPA, everytihng works perfectly. Everything used to work perfectly on both until iOS 6.

  • ehar Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 26, 2013 4:59 AM (in response to abfield)

    The solution does work perfectly. But I'm not sure I understand why there would be any security issue involved. Setting autolock to never prevents the device from loosing WIFI, but if you lock it manually when you are done using the device it is still locked. The only difference is that your WIFI doesn't go down. You must still swipe the unlock to get back in. So security is on all the time you have placed it in standby (it's locked). Am I missing something?

     

    So there is a simple solution (that involves no vo-do) and there is still the same security as if the device was locked via autolock.

  • abfield Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 26, 2013 5:04 AM (in response to ehar)

    It's a security issues (and my company prevents setting this to "Never" because of it) because they don't want someone leaving their iPhone on a table at Starbucks unlocked allowing someone else to pick it up having access to everything. Having autolock enabled reduces that chance. Like I said, my company's security profile makes me set an autolock if I want to connect to the corporate Exchange server so this work-around doesn't work for me.

  • simcam68 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 26, 2013 10:18 AM (in response to ehar)

    Well i have tried the never lock solution. It did not work for me on the company wifi. I tried it with the guest network because the main/exchange network has the "never" option blocked like abfield described, so I didn't even make an attempt with that network.

     

    I got the exact same behavior with the "never" setting as I did with the 1 minute setting, dropped wifi as soon as it was asleep. The only thing that has worked at all for me is a reset (power and home buttons held down) at the beginning of the day and again if I leave the area/lose the connection due to signal loss.

     

    With the reset it works just like it did in ios5. This "improvement" in ios6 is wonderful...

     

    Again apple, let me worry about how much battery I consume in a day. A full battery on a useless device is not a win.

  • ehar Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 26, 2013 10:27 AM (in response to simcam68)

    simcam68. Respectfully, this solution will work for everyone, every time. It is impossible that it wouldn't have worked for you. Now, having said that I feel fairly confident that the reason you lost wifi is because of something to do with the guest network you tried it on. Most likely it was a non-activity timeout or something else like that. But I can pretty much guarantee that this solution works universally.

     

    "

    In reference to my last post above, appearantly the shutting down of the internet that the iPod does when it uses the Autolock feature is different than if you manually click once to lock it. The shutting down of the internet seems to be "tied to the autolock setting", but "NOT tied to being locked manually."

     

    So a solution IS FOUND. Simply go to settings/general and set AUTOLOCK to NEVER turn off. Then when you are done using it, or want to lock it manually that's fine. As long as the autolock is set to never it will not shut down the internet when you lock it manually.

     

    The internet being shut down is not tied to whether the iPod is locked or not. It is tied to the AUTOLOCK setting.

     

    So remember, even if you lock it manually; if Autolock is not set to never it is still on and will shut everything including your internet off even if you lock it manually. So shutting it off manually alone will not do it. You MUST turn autolock to NEVER, and then when you lock it manually everything will stay on and life is good."

     

    ---------

     

    The Autolock must be set to NEVER. 2nd, you do NOT shut down. You simply put it in standby (1 click). The Autolock must already be set to never before you go into standby. After that it will always keep wifi up unless it is a local network issue.

  • iditsuda Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 26, 2013 10:29 AM (in response to ehar)

    Why is keeping wifi on during sleep controlled by the Autolock option?

     

    Maybe it's not a feature/solution, it's just a bug that Apple will fix in the future!

  • simcam68 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 26, 2013 10:53 AM (in response to ehar)

    Sorry ehar,

    It is not network dropout or timeouts or anything of the sort. The never option had no effect. For three days I tried this idea and it dropped just like it did when the autolock is set. I tried several times during the three days the reset method and it works just fine. Switched back to the "never" method and dropped it every time.

     

    Not sure what to tell you... It seems the "bandaid" is different for everyone. Reading this thread from the beginning will certainly show you that. The only real solution is can see is ios5, which if you didn't save your blobs you are not going back to.... Since apple seems to ignore this subject with all their recent updates.

  • ljcool Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 26, 2013 12:31 PM (in response to simcam68)

    This is what I've been trying to explain. The root cause of the issue is unknown, therefore to tie it up to the anti-lock bandaid and call it a security issue and say it can be replicated to multiple devices just because it's "user controlled" bewilders me.

  • twinkletoesmofo Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 30, 2013 7:13 AM (in response to ljcool)

    I have an iPhone 4S with 6.1.3 and same issue/problem since the beginning.

     

    Solution:

     

    Turn screen auto-lock in settings to "NEVER", and wifi will stay connected while screen off. I've tested it after waiting 1 hour with screen manually turned off.

     

    Listen to ehar

  • twinkletoesmofo Level 1 Level 1 (0 points)

    If setting auto-lock to "Never", and manually locking the screen STILL turns your wifi off?

     

    You got some other problem going on buddy.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (6)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.