Skip navigation

iOS 6 disables wi-fi on sleep mode - disappointing

91020 Views 249 Replies Latest reply: Nov 17, 2013 8:51 AM by Bill Stephenson RSS Branched to a new discussion.
1 2 3 ... 17 Previous Next
yanipopo Level 1 Level 1 (0 points)
Currently Being Moderated
Sep 24, 2012 5:05 AM

I'm still quite not sure as to whether this was intentional or not. As I've read on other discussion threads, some people like it, however, MOST people do not.

 

 

I personally dislike it. It takes away, for me, somewhat a nice feature of having push notifications: that you can get notifications anytime, 24/7(given you are connected to wi-fi or you have your mobile data on) even when the iPhone is on sleep mode. And since there is the Do Not Disturb feature, it won't be much a of a problem if it's about the notifications disturbing you.

 

If it's about battery saving, well, it does help. But I think, if it is(which we're still not sure) intentional that the iOS 6 disables wi-fi on sleep mode, Apple should at least add an option for us to choose as to whether we would like to keep the wi-fi on, or off when the iPhone/iPad/iPod is on sleep mode.

 

As with most people, I would like to keep my wi-fi on, anytime, anywhere, and it's up to me to deal with the battery consumption.

 

 

 

 

Thoughts please?

iPhone 4S, iOS 6
  • Ian Parkinson Level 6 Level 6 (10,365 points)
    Currently Being Moderated
    Sep 24, 2012 5:14 AM (in response to yanipopo)

    When my iPhone is in "Do Not Disturb' mode, my WiFi is still active and work fine.

    You can see in the photo that on the lock screen the 'Do Not Disturb' logo and WiFi logo are both on.

    The photo of the screen was transferrred over WiFi by Photostream while the phone was locked and do not disturb was on.

     

    IMG_0985.PNG

  • arrow7 Level 1 Level 1 (15 points)
    Currently Being Moderated
    Sep 24, 2012 5:29 AM (in response to yanipopo)

    wifi has always been automatically turned off here when the phone is locked (in iOS 5 etc... ) after a few minutes ... that's an iOS feature, as Apple considers that the phone in standby will use less battery on cellular data than on wifi. This said, as soon as you turn the phone back on (light up the lock screen), you'll notice that the phone switches back very quicly from 3G to wi-fi, and this, already before you unlock. If you don't like that behavior, switch off cellular data when you're at home, or wherever you know you can have a constant wifi connection.

     

    ps: this built-in behavior won't change in "do not disturb" mode on iOS6.

     

    edit: this said, wifi must still always work - when needed - in the background when the phone is locked, as automatic iCloud back ups run that way.

     

    Message was edited by: arrow7

  • Ian Parkinson Level 6 Level 6 (10,365 points)
    Currently Being Moderated
    Sep 24, 2012 5:54 AM (in response to yanipopo)

    You are incorrect, and won't listen, so no point us helping anymore, bye, bye.

  • arrow7 Level 1 Level 1 (15 points)
    Currently Being Moderated
    Sep 24, 2012 6:44 AM (in response to yanipopo)

    you obviously didn't read the answers, or didn't understand them. iCloud was just an example, but nevermind

  • Dennis Phillips1 Level 1 Level 1 (10 points)
    Currently Being Moderated
    Sep 24, 2012 7:24 AM (in response to yanipopo)

    I am having this problem too.  I work in a building where i get no phone signal but was able to always communicate with people using iMessage, all day long, when my phone was asleep/locked.  Since upgrading to iOS6 i have to wake up my phone to get it to reconnect.  This is wildly annoying for me.

  • Emanuele1985 Level 1 Level 1 (5 points)
    Currently Being Moderated
    Sep 24, 2012 9:57 AM (in response to yanipopo)

    same problem here!! With iOS 5 it was fine and i recevied all notifications during sleep-mode.

    It's quite annoying to miss so many messages and notifications

  • arrow7 Level 1 Level 1 (15 points)
    Currently Being Moderated
    Sep 24, 2012 10:53 AM (in response to yanipopo)

    I know this can be annoying, a bit time consuming to do, but something close to the issue has happened to me already after upgrading to 5.1 from 5.0.2 etc... third party apps wouldn't get push notifications anymore (built-in apps would though). So the only way I found to recover that was to:

     

    1 disable all notifications for all apps (everything ... from banners to alerts, lock screen, notification center etc...)

    2 reset network settings,

    3 once back on iOS, re-enable manually everything for each app.

     

    ... and 4, for apps that still wouldn't get push notifications, delete them and re-install them.

    and again, I never had any issue with push and built-in apps.

     

    ... sorry guys but that's all I got.

  • MikeT in NJ Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 24, 2012 11:08 AM (in response to yanipopo)

    For sure this happens.  I am in a building, and an overall poor service area, so iMessage was always my best bet.

     

    I have a 4s with iOS5 and a 4s with iOS6

     

    A ping test of the IP clearly shows that when the phone sleeps with iOS6 the IP no longer responds about 10 seconds after the phone going to sleep.  This does not occur on my iOS5 version. 

     

    This is a HUGE problem for me.  I am not going to go back to putting my phone by a window just to make sure I get messages.

     

     

    EDIT:  Semi workaround for me.

     

    It seems if the phone is plugged into a charger, the WIFI stays active. 

  • MikeT in NJ Level 1 Level 1 (0 points)

    workaround #2

     

    I have a battery pack case.  With this on the phone, running as an always on option, the phone thinks it's plugged in.  A ping test shows the phone does not sleep the WiFi.

     

    Apple, this really needs to be a user choice setting, not a decision Apple should be making for us.

  • arrow7 Level 1 Level 1 (15 points)

    I agree this should be a user's decision. Never really had a real problem with that because I constantly got 3G available where I use wi-fi. But yeah, this also means that notifications go through 3G when the phone is locked and this can - although not disproportionately - eat your data subscription. So again, you can always disable cellular data to force the phone use wifi when locked (and dimmed) and unplugged.

  • Emanuele1985 Level 1 Level 1 (5 points)
    Currently Being Moderated
    Sep 24, 2012 11:44 AM (in response to yanipopo)

    i tried to wipe out all data and setting up a fresh new iOS 6 but the problem persist. If you have data disabled, notifications disappeared during sleep mode. Waiting for an Apple update

1 2 3 ... 17 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (6)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.