Previous 1 2 3 4 Next 929 Replies Latest reply: Apr 14, 2014 10:35 AM by RaghuSatya Go to original post Branched to a new discussion.
  • superclay Level 1 (0 points)

    Can those of you have opened cases with Apple give me Case numbers? I'm finally getting escalated.

  • SabihM Level 1 (0 points)

    Hi guys, thank you for starting this discussion. Just wanted to add in my own experiences here.


    I'm on a 4S with AT&T but the carrier is not the issue for me. I'm on WiFi and was having no issues with my Google Apps work account setup as an Exchange mail account in pushing new mail immediately to my iPhone (and I mean immediately, it was amazingly fast).


    However after upgrading to ios6 last night, I'm no longer getting push notifications.


    I tried making the changes recommended in this thread but still am not getting any new emails pushed to my phone, I have to manually open in order to retrieve them.

  • Frank Malloy Level 2 (350 points)

    I am on AT&T and have this problem as well. It also happens over WiFi, so it's unrelated to the carrier. Worked frne from Friday to Monday afternoon.


    One thing to check is:




    Check each setting, and make sure Notification Center is ON, New Mail Sound is set, Show Preview is ON, View in Lock Screen is ON (if you want that).


    You might try going to the account not pushing and turning some options OFF and back ON.

  • DQMIA Level 1 (0 points)

    Hi Superclay,


    I have my case escalated up to Apple Engineering.  They said it would take 1 to 2 days for them to contact me.  My case number is 353735858.  I think you have a good idea in that we should provide these case numbers to apple and refer back to these posts so that the issue comes to the forefront of their attention.


    I have a curious observation:  In my case now if I leave my phone connected to my wireless but turn off cellular, push works without a problem.  When I turn on cellular data and a LTE connection is established with Verizon; push works but only for 5-10 minutes then it just stops working.  As users that are feeling this pain we need to band together and let Apple know that they need to fix this.  Thanks for everyone's posts in here.  Its good to know that we are not alone!  For what its worth 

  • Frank Malloy Level 2 (350 points)

    For me, it failed in either cellular or WiFI. What I did was check/re-enable settings in Settings>Notifications>Mail and reboot. Now push is working again. I can't say that will work for everyone.

  • DQMIA Level 1 (0 points)

    Hi Frank,


    The reboot is what fixes it, but only for a little while or in my case, a few minutes.  I'm pretty sure its going to stop working at some point in the next few minutes to an hour.  Its the same symptoms for everyone whom has posted on this board.  Frustrating to say the least....

  • SabihM Level 1 (0 points)

    Well FWIW the "change some settings/reboot" method hasn't made any difference for me, I've have yet to receive any push email notification after upgrading to ios6.

  • 23103a Level 1 (0 points)

    I'll add my name to the list of people with this problem. Veriozn iP5, push hasn't been working since day one. I have to manually open the app for it to fetch mail.


    I've tried the steps in the first post, no dice... hope Apple can fix this soon.

  • efrain88 Level 1 (0 points)

    I got the same issue. Verizon iPhone 5.  My Yahoo and iCloud email push no problem.  Can't get my exchange to push, it only does it for a short time after a reboot.

  • 23103a Level 1 (0 points)

    Just called Applecare about it, they told me the email department is aware of the issue and trying to fix it..

  • DQMIA Level 1 (0 points)

    Interesting that they are aware of it.  I guess enough people have called about it?  Hopefully they are able to recreate the issue in their labs.  I hope for a fix sooooon!

  • Frank Malloy Level 2 (350 points)

    What is thoroughly annoying is that this same problem seems to pop up at every iOS release, and then it takes a long wait for the next release's fix.


    You'd think after this happens 2 or 3 times they'd be able to have it working reliably.

  • noahs Level 1 (15 points)

    I'm having a similar issue on my iPhone 5 (Verizon). It affects all push notifications, including push email (iCloud & Exchange), iMessage, and third-party apps. Push notifications will work for some period of time (on average, a few hours, sometimes less) and then stop working. Toggling airplane mode or restarting the phone will restart the push notifications service and temporarily fix the problem. But it then recurs. I've tried resetting network settings and backing up & restoring the phone with no long-term success.


    I've also noticed that the apsd process is crashing on my phone. APSD is the Apple Push Service Daemon. It seems every few hours or so, it crashes with exception EXC_CRASH (SIGABRT), and the phone stops displaying push notifications. Take a look in Settings-->General-->About-->Diagnostics & Usage-->Diagnostic & Usage Data and see whether you have similar crash logs from the apsd process.


    I have no problems (and no similar crash logs) on my iPhone 4S (AT&T) and iPad 3rd-gen (Verizon), both of which are also running iOS 6. Tonight, I'm going to try doing a fresh backup of the 4S and restore that to the 5, and I'll let you know if that works.


    Please update this thread as you hear back from Apple.

  • Frank Malloy Level 2 (350 points)

    Yes - 4 apsd process crashes since I got the phone Friday, last two today. That is not good. Have you determined if the apsd process is relaunched automatically after a crash? Since this is a basic service, you shouldn't have to restart or toggle Airplane Mode to get it to relaunch.


    Good find, noahs. Let's hope Apple can push a fix out quickly and not make us wait for two or three months.


    This broken push seems to happen with almost every major release. You'd think Apple would have it down by now.

  • noahs Level 1 (15 points)

    I'm not sure if apsd is supposed to auto-relaunch (you would think it should). But I've found that after each time it crashes, I need to toggle airplane mode or reboot to get it to reconnect to Apple's push servers.


    Frank, did you restore from an iCloud backup? That's what I did initially. I'm going to try restoring from a local backup of my known-to-be-working 4S, in case the problem is created by some weird iCloud bug.

Previous 1 2 3 4 Next