Previous 1 2 3 4 5 6 Next 929 Replies Latest reply: Apr 14, 2014 10:35 AM by RaghuSatya Go to original post Branched to a new discussion.
  • SabihM Level 1 Level 1

    BTW I tried this fix (turned off Safari sync in Settings > iCloud) in another desperate attempt to make push work for me and *it's been working for over 1.5 hrs* for me on my iPhone 4S with iOS6 (testing over WiFi only).


    Thank you! Hopefully it will continue to work...

  • BeeJaay00 Level 1 Level 1

    I turned off that setting (Safari sync) and it did not work for me.   I also tried deleting my entire iCloud account and the push service is still crashing.   This is also affecting any other push notifications from other apps.   When I reboot my phone I get a few push emails as well as other push notifications for a short period of time then the push crashes again.   This shows in the diagnotics of the phone soon after push stops working.


    Incident Identifier: 0D29D431-35BE-42FF-9219-85D32DCB2423

    CrashReporter Key:   27db296be58698a641c5df9a4fa3b280aa21f6a3

    Hardware Model:      iPhone5,2

    Process: apsd [73]

    Path: /System/Library/PrivateFrameworks/ApplePushService.framework/apsd

    Identifier:      apsd

    Version: ??? (???)

    Code Type:       ARM (Native)

    Parent Process:  launchd [1]


    Date/Time:       2012-09-26 11:42:27.060 -0600

    OS Version:      iOS 6.0 (10A405)

    Report Version:  104


    Exception Type:  EXC_CRASH (SIGABRT)

    Exception Codes: 0x0000000000000000, 0x0000000000000000

    Crashed Thread:  0


    Also, not sure if this is related to this problem, but I am also having issues with sending via iMessage as stated in this thread.

  • SRGITMGR Level 1 Level 1

    I am seeing the issue with all iPhone 5 in my company, not with any 4s running iOS6. All phones are Verizon Wireless. The overall issue is that new emails are not being received by the phone until you open the Mail app. Affects Exchange (Active Sync) type accounts (MS Exchange 2007, Gmail) set for Push, does not affect iCloud set to Push. Affects phones that had settings restored from iCloud and those that were new iPhone/iCloud users with no previous settings. Issue occurs the same on both LTE and WiFi.


    The issue has been sporadic. I have tried every suggested change option: reboot of phones, delete/add accounts, reset of all data on phone, setting account to Fetch then turning Push back on. Sometimes a change won't fix the issue, then making the same change again will fix the issue, but only for a short time. Or vice versa, a change that fixed the issue, for a short time, won't fix the issue when making the same change later.


    Workaround: This will allow new mail to be received automatically, but will add up to a 15 minute delay in getting new email

    - Settings > Mail, Contact, Calendars > Fetch New Data > Advanced > Select an account > Select Fetch


    Also, I spoke with 2nd level tech support at Verizon. The tech was not aware of the issue. After troubleshooting common steps, the Verizon tech placed a call to their Apple tech support channel. The Apple tech says it is news to them, but Apple Engineering could know about it and not have told tech support yet until there is a fix. And from the Apple tech: "there are some other well-known issues with iOS6, so expect an update to be released soon". The Apple tech could offer no other suggested fixes. And yes, I am aware that both Verizon and Apple techs will say they are completely unaware of a problem when they are fully aware of a problem.

  • Frank Malloy Level 2 Level 2

    As I've said, Apple first-level support will always say they are unaware of problems, even if they get dozens of calls per day, so just toss that aside.


    It's good that this was raised at the corporate level (Verizon->Apple) as now it may get higher priority attention. It's especially annoying since I have seen this same bug (broken email push notifications) at least 3 times previously since the iPhone 3G was released.


    There are multiple issues with the iOS 6 software, particularly with the new iPhone 5. We can only hope there will be an OS update soon. Sometimes, it has taken up to three months to get fixes.


    Thanks for updating us. It's very helpful.

  • Zaukul Level 1 Level 1

    I have been seeing this same issue and after a few days of trying everything (toggling various settings, delete/re-add account, doing a full phone reset/restore), I finally have a workaround that is working for me.


    I also have an iPhone 5 with Verizon Wireless, and disabling cellular data and then toggling airplane mode caused push to start working and continue working as long as I left cellular data disabled. I've had it working for most of today with this method. DQMIA posted this earlier but he said it only worked for 10-15 minutes for him. I've had it working for a few hours and counting.


    Obviously this can only work if you have access to wifi, but if it's connected to the cellular data it would explain why the issue seems to be correlated with only iPhone 5s on Verizon.


    So, not a solution, but at least a temporary workaround when wifi is available.

  • Frank Malloy Level 2 Level 2

    I've heard toggling Airplane Mode re-launches the crashed apsd process, so you'll start receiving push notifications again. A restart will also do it. But, eventually something causes it to crash again later. Apple has to fix the crashes with an iOS update.


    To check for apsd crashes on your phone:


    Settings>General>About>Diagnostics&Usage>Diagnostic&Usage Data


    Look for entries starting with apsd_<date>. The date is the date and time of the crash. I've gotten 4 of them since the 23rd.

  • Zaukul Level 1 Level 1

    Yep, I have tons of them. During all the testing over the past few days, I've always seen it crash and push stop working between 5 and 15 minutes after toggling airplane mode. Today, I've had it working with cellular data disabled for hours. At one point earlier I re-enabled cellular data and it stopped working within 5 minutes.


    After disabling cellular data again it has now been working again for another few hours without crashing. The reason I toggled airplane mode was to get the process started up again after making the change, since it had crashed previously.


    I would suggest trying it on wifi with cellular data disabled, and see if push stops working again.


    Settings>General>Cellular>Cellular Data

  • 23103a Level 1 Level 1

    Weirdy, mine seems to be working all on it's own again this morning. Maybe they fixed something, somehow..

  • Frank Malloy Level 2 Level 2

    I believe the fix has to be done in the iOS software. I can't see it magically start working.


    Some set of events is happening to cause the push software to crash on the phone. There seems to be evidence it's related to push over cellular on the Verizon network.


    Once the push daemon has crashed, it has to be restarted to get your push emails again...until it crashes again later. Toggling Airplane Mode restarts the push daemon, I believe...

  • lls4f Level 1 Level 1

    I'm on Sprint and having the same issues. Toggling Safari sync or airplane mode fixes for a bit, then it'll stop again.

  • DQMIA Level 1 Level 1

    Hi Zakul,


    Push with wifi turned on and cellular data turned off WORKS, ALL THE TIME in my tests.  Like you, the minute I turn on cellular data it crashes push.


    23103a:  you claim push has been working for you since this morning...are u on Verizon and have you had the phone connected to wifi since this morning with cellular data turned off?


    Frank:  you're right, what the heck is causing the aspd daemon to crash?  Could it be LTE or signal aquisition?  Apple better not take months to fix this.  I'm hoping they come out with a patch sooner than that.  Apple if your listening....GIVE ME MY F'IN PUSH SERVICE BACK, NOW!

  • DQMIA Level 1 Level 1

    If anyone who is having this issue has not called Apple Support to report it...please do so now.  The more people call about this issue the more the become aware of it.



  • Frank Malloy Level 2 Level 2

    There's no telling what's causing the crash. I work in software development, and there could be a million things that could cause a SIGABRT crash, and a specific sequence of events that you probably won't be able to determine without software debugging tools and expertise. Probably a wild pointer or something similar. That's Apple's job to figure out, and hope they can find the cause, fix it, and release an updated iOS more quickly than they have in the past.


    As I've said before, I've had the iPhone 3GS, 4, and 5, and with every major new iOS release they break push email. Unfortunately, in each case the fix did not come quickly as I remember.


    Yes, it is very important for everyone to call Apple to report it. High volumes of calls will give this higher priority.


    You know what's funny? Mine just crashed three minutes ago after being up for almost 24 hours (I'm on AT&T using WiFi all day).

  • A F 1 G 3 Level 1 Level 1

    Verizon iPhone 5 32 GB, same problem no push e-mail. Would imagine this is a software issue that needs to be addressed in an update ASAP.

  • spidertaker23 Level 1 Level 1

    I am having this exact same problem!  I just activated my Verizon iPhone 5 to replace my Verizon iPhone 4s.  I use my exchange connection for work email and I am very upset this isn't working.


    It works for a bit then push notifications crashes and it won't work until I toggle airplane mode or reboot.  So not happy right now.


    I will probably call Apple today or tomorrow!  Ugh!

Previous 1 2 3 4 5 6 Next