Previous 1 33 34 35 36 37 Next 929 Replies Latest reply: Apr 14, 2014 10:35 AM by RaghuSatya Go to original post Branched to a new discussion.
  • Frank Malloy Level 2 (350 points)

    Settings>General>About>Diagnostics & Usage (at the bottom)>Diagnostic & Usage Data

     

    Scroll down and look for:

     

         apsd_<date><time>

     

    and tap on the entry. Look for:

     

         Exception Type: EXC_CRASH (SIGABRT)

     

    This means the Apple Push Support Daemon (apsd) crashed and is a sign of the bug.

  • Frank Malloy Level 2 (350 points)

    iSam88: So far it has not failed and I am receiving push email notifications and no apsd crash, however previously I could run for days until it stopped working. For others, it fails in minutes. So, it's not deterministic.

  • lorennerol Level 1 (0 points)

    "No Diagnostic Data"

    Does it get flushed during a sync?

  • Frank Malloy Level 2 (350 points)

    No it does not, as I understand it. Unless you flush it manually from Console or delete the files.

     

    If you have that, it is great news - you have no crashes. I've got a bunch of apsd, other Apple daemons, and third-party app crashes.

  • lorennerol Level 1 (0 points)

    If push was working for me I'd be thrilled. But it's not. Does "Automatically Send" (to Apple) need to be enabled for it to collect the info?

  • Timmc Level 1 (0 points)

    Same here...installed update and still no push for my exchange email...

  • Frank Malloy Level 2 (350 points)

    Yes, it does.

     

    I'm surprised you have push failures without apsd crashes. We originally theorized that the crash sets off the push failure.

  • lorennerol Level 1 (0 points)

    I had "Automatically Send" disabled, so no info was being collected. It's enabled now and I just set/unset Airplane Mode, which fixes it briefly.

  • Frank Malloy Level 2 (350 points)

    Automatically Send just sends the log to Apple. But even if you have it off it still creates the logs.

  • waytogoidaho Level 1 (0 points)

    Push has not worked for me from day one (5 weeks now) and I have never had an apsd crash.  I installed the latest patch today and it broke 10 minutes after the reboot.  I mentioned this earlier but this IS an LTE problem!  We have 5 users on iphone 5's with AT&T where we don't have AT&T LTE service and push has always worked on their phones.  All phones are set up exactly the same, I am the only one on Verizon.  Verizon does have LTE in this area.

  • Frank Malloy Level 2 (350 points)

    waytogoidaho: Thanks for the info. I am on ATT with LTE service and I get the lost push, but I also have apsd crashes in my logs that (I thought) were correlated.

     

    For what it's worth, it seems the severity of my lost push is not as bad as others on Verizon, but I still have issues. I have updated to 6.0.1 and it's pushing ok, however it's only been a few hours...

  • squam1 Level 1 (0 points)

    Also on VZ and have had the issue since day 1 and never have seen the apsd error log. 

  • James Mullins1 Level 1 (5 points)

    Well, push worked for a few hours and then gone.  The last two times this has happened, push worked fine while at my office and logged into company wireless network (same network that mail server is on), once I left that network, and I guess hopped on 4G is when pushed stopped.  Guess I'm master of the obvious with that statement!

  • Caesarp Level 1 (0 points)

    I can confirm that IOS 6.01 did NOT fix this issue.  In fact, it is not even listed in the bug fixes for this update.

     

    So I guess we can only hope that the fix will be in 6.1, which I understand will come out around the New Year (either late December or early January).

     

    Wow. Can't believe it is taking this long to fix an enterprise issue.

  • lorennerol Level 1 (0 points)

    I can confirm that on my phone I do *not* have any APSD-specific entries in the diagnostics log and push works only for a few (<30) minutes after I switch in and out of Airplane Mode. I have two Exhange accounts on the phone, both running against Exchange 2010 SP2 with the current rollup.

Previous 1 33 34 35 36 37 Next