Previous 1 3 4 5 6 7 Next 929 Replies Latest reply: Apr 14, 2014 10:35 AM by RaghuSatya Go to original post Branched to a new discussion.
  • noahs Level 1 Level 1

    I tried restoring from an iPhone 4S backup that didn't exhibit these problems, and the problem recurs. So backup and restore will not fix this. Don't bother wasting your time.


    I'm going to try the cellular data off workaround (at least while I'm at work during the day) and will call Apple now. I'm sure they'll be of no use, because this is obviously a software bug that needs to be fixed. But at least it will add another complaint and bump up the priority of this this issue.


    It seems like it's only affecting iPhone 5 CDMA models (Verizon & Sprint). Are any AT&T users also seeing the apsd process crash?

  • GrayBird88 Level 1 Level 1

    All those in my corporate office who updated to the iPhone 5 have this problem with push mail.  We've called and escalated to Apple, Verizon, and Sprint.  As mentioned above, it's beyond irritating to report it and have their customer serice folks act as if this is something completely new, despite knowing we've all posted and escalated. Given that I have yet to meet one person who does NOT have this problem with the 5, I am actually surprised this post isn't much, much bigger--especially given the corporate enterprise scope. 

  • noahs Level 1 Level 1

    Also, for those of you toggling airplane mode to get the push notifications service to temporarily relaunch, I would recommend waiting 10-15 seconds between turning it off and on. Sometimes if you turn it back on too quickly it doesn't fully detach from the network. You should see the "Searching…" message when you flip it back on.

  • Frank Malloy Level 2 Level 2

    Are any AT&T users also seeing the apsd process crash?


    Yep. I've got 5 crashes logged since the 23rd. One just happened about 10 mins ago.


    What's strange is I didn't toggle Airplane Mode or restart and looking at SysMon, the process seemed to restart itself and push notifications resumed, which is good. But, in the past when it's crashed I had to restart.


    I've opened a call with Apple Support, and they even mentioned they saw my postings on this without my bringing it up. Apple is aware of this issue, which is also good. Acknowledging the problem is the first step to getting it resolved.

  • noahs Level 1 Level 1

    Yeah, I think the process is supposed to restart itself, and I've noticed that the apsd crashes don't exactly line up with when push stops working. My guess is that apsd, in addition to crashing and restarting, also sometime hangs or locks up, leaving it in a state where it's running but not working. And that's when we actually see the symptoms. Obviously there's a bug, and Apple needs to fix it.

  • DQMIA Level 1 Level 1

    Hi Noah,


    The question is how soon before the release a patch?  On friday?  next wk, 2 months from now.  As a CIO this feature is CRITICAL as I receive alerts about my servers, network infrastructure, etc...  It would be a slap in the face from Apple to us if they take their sweet time in releasing a fix and follow their normal release patterns.  This time around they NEED to make an exception.  Again, those of you reading this forum searching for an answer to the issue....right now its this:  Call Apple Support and let thm know about it.  Hopefully I'll hear back from engineering tomorrow.  Until then I've switchd to fetch every 15 minutes.... 

  • Frank Malloy Level 2 Level 2

    It's unclear. It's rare (has it even happened at all?) for them to release a fix in days or even a week or two or more. Push email has been broken before, and as I recall it's taken a couple of months to get the fix. They have to find the cause, fix it, run regressions, and do testing before they push it out to millions of people. Plus, they like to roll in more fixes (like I hope the alert volume bug) instead of pushing a patch fix for one bug.


    If Verizon and other large companies have raised this the chances are better it will get fixed faster.

  • DQMIA Level 1 Level 1

    Oh God, that really stinks to hear that.  Well then I guess its back to my 4S until they fix this (probably months from now).  This is complete and utter BS.  I mean, they only had like what, 2 years to test the iphone 5?  Completely unacceptable! 

  • laurenindc Level 1 Level 1

    It's not just Verizon iPhone 5! I have an iPhone 4S with AT&T and updated to iOS 6 last week. Everything was working fine until today. My work email (Exchange with an IBM Lotus Notes Traveler profile) stopped pushing in the morning and the whole Mail app got stuck (Gmail and iCloud weren't downloading, either). I had to delete my work account to be able to get Gmail and iCloud again. Obviously, this can't go on forever! The weird thing for me, though, is that, after the upgrade, my Exchange account worked perfectly well for a whole week!

  • shullshock Level 1 Level 1

    I have a ipone 4s with verizon and it started before the ios6 update!

  • Frank Malloy Level 2 Level 2

    If your Mail app is frozen and not working that could be a separate issue. Our issue is that checking mail manually thru the Mail app is working fine.


    If your Mail is frozen restart your phone and see if it recurs.

  • noahs Level 1 Level 1

    I called Apple and reported the issue. I told them I had already tried resetting network settings as well as restoring the phone twice, and they immediately escalated my issue to a senior advisor. I've sent them my crash logs, and they expect to get back to me in about 48 hours with an update. I'll post here if I learn something new.

  • sbenitez Level 1 Level 1

    As a temporary work around, I have been forwarding my Exchange mail to iCloud which succesfully pushes each email. I've created seperate mailboxes on iCloud for each Exchange account that I have.


    If iCloud doesn't push your email, you are most likely having a different problem than what has been alluded to in the original post.

  • Frank Malloy Level 2 Level 2

    This is a great workaround! However, for many of us that use corporate email, our companies do not permit us to forward company email to private accounts for security reasons.

  • hanishi Level 1 Level 1

    Hi, I am the developer behind an open source project that can remotely enforce security policies on devices running iOS 4 and iOS 5, after necessary configuration is made to the MS Exchange Settings.

    It employs the ActiveSync technology, especially on commands related to mobile device management.

    For any further details see the following URL:


    I have tested iOS6 upgraded device and found out that it does not initiate PING request to its connected server. PING command is what initiates the Microsoft Direct Push(it is just pretty much an http long-polling) and PUSH is not possible without the client's initiatiation of the PING command.


    I'm hoping this gets fixed.

Previous 1 3 4 5 6 7 Next