5 Replies Latest reply: Oct 3, 2012 5:46 PM by ametz08
alexbsmith1 Level 1 Level 1 (0 points)

My MacBook Pro is Mac OS X version 10.5.8, what is the next software that I need to upgrade to in order to get to the software I need for the new iTunes 10.7, which requires 10.6.8 or later? Do I need snow lepoard? Mountain lion? I'm confused on what the differences are. When I click on "software update" it says there are no updates. What software do I need and how do I get it?


MacBook Pro, Mac OS X (10.5.8)