Previous 1 2 3 Next 34 Replies Latest reply: May 1, 2014 11:10 AM by elbenoit Go to original post
  • jtbach Level 1 (0 points)

    Same here - list view skips around by years, weeks, months, all randomly - what is astonishing to me is that this bizarre scrolling problem is now nearly a month old. I'm sure it's not rocket science for Apple to fix it ... if only they cared.


    I used to like using my phone; now it's become, well, rather tedious. (That battery drain snafu and the total lack of response from Apple was a completely unnecessary example of disregard for customers.)


    Yo, Tim Cook, do something for the people that give you their money.

  • Mike Peterson3 Level 1 (0 points)

    UPDATE: When I got my new iPhone 5, it was just after the iOS update 6.0.1 was released. After activating the iPhone 5 online, and then restoring all my data and Apps to it via my iCloud backup from my iPhone 4S, and then updating the iPhone 5 to iOS 6.0.1, this problem DISAPPEARED!

    Not sure if it was the iOS 6.0.1 update or switching to an iPhone 5 that fixed the problem. Anybody else see this?

  • ttnbd Level 1 (0 points)

    It's not just the FB calendars that are throwing up this issue. I deselected them after reading your post and thought that had fixed it. But next time I went into list view it was hopping about all over the place again. I was going to deselect my other subscribed and outlook calendars one by one to see if that helped but I got fed up and just went to Month view instead. Hope Apple acknowledge this issue soon so they can start working on a fix. Pretty poor service this time Apple.

  • Mike Peterson3 Level 1 (0 points)

    I was WRONG. Calendars in list view on my iPhone 5 (iOS 6.0.1) still jump around wildly. More troubling, I recently observed the same behavior in iCal on my MacPro running OS-X 10.7.5! Since I have Google Calendars, including three at I "subscribe" to on both my iPhone 5 and my MacPro, I am VERY SUSPICIOUS that this is a Google Calendars-caused bug. Anyone else have this "jumping around" behavior on their Macs?

  • simonbarratt Level 1 (0 points)

    The problem still exists in 6.1 beta too. I don't link to google calendars. I just have two Exchange 2010 calendars, four iCloud calendars and three Internet subscribed calendars.

  • Bev Goethe Level 1 (0 points)

    I've had this problem for months and finally got on here to see if I could find a fix. After reading all of these comments I think I've fixed my problem at least. I deleted the subscribed calendars (google) and then re-added them. Now they are listed separately in their own window. The colors are all the same and they are not fighting for space. Most importantly NO MORE SKIPPING!!! Except for me, because I'm happy this worked! Hope this helps someone else.

  • memelab Level 1 (5 points)

    hmm.. right you are.. I think the birthdays calendar was interfering, too.. certainly the problem was reduced.. I'll try Bev's solution below. (sadly, I've just taken to using the feature less)

  • Björn Eriksson Level 1 (0 points)

    I tried deleting my iCloude account and my exchange account and then added them again. I'm sorry to say that this did not resolved my skipping problem.

  • yosefg Level 1 (0 points)

    Same issue here. List view just skips to years ahead and back, then forward... Also, when viewing your calendar in landscape orientation (week view), it is also a bit skippy. Not the same skippness as the list view, but still a bit buggy. Apple: Please fix the calendar app. I use my calendar all the time, but it can be frustrating when I have a smartphone in my hands that is difficult to work with. Thanks!

  • BTBW Level 1 (0 points)

    The disappearing calendar problem started on my iPhone 5 after I changed my iCloud account from to I deleted my account from my phone, chose to save the calendars, etc., then re-created my account with my login. Suddenly, all of the calendars subscribed to my icloud account started appearing and disappearing. It seems that iCloud was constantly refreshing my subscribed calendars, but they never displayed in the Calendar app. Like others in this thread, I deleted the subscribed calendars, restarted the phone, to no avail. The solution for me was Settings > Mail, Contacts, Calendars > iCloud > turn off Calendars. The phone asked me if I wanted to save or delete all calendars. This time I chose delete. I then turned Calendars back on, and everything began working fine. Perhaps duplicate, subscribed calendars were giving the system a hairball...

  • memelab Level 1 (5 points)

    this seems to have fixed it for me...

  • rhvh Level 1 (5 points)

    Thanks dude! After months irritating, your solution is awesome and worked for me

  • wenibek Level 1 (0 points)

    Did you lose all your info on your calendars when you did this?

  • BTBW Level 1 (0 points)

    No. Everything was restored from iCloud.

  • elbenoit Level 1 (5 points)

    I was encountering the calendar scrolling / skipping problem in list view as well. Been putting up with it for months.


    I have 1 iCloud calendar, the US holidays calendar from Apple (subscribed), the birthday calendar and I had 1 subscribed google calendar.


    I no longer had a need for the google calendar so I deleted it. The skipping around problem ceased immediately on my iPhone 4.


    One thing to note is that I deleted the google calendar from my Mac. Not sure if that had anything to do with it.. I tend to doubt it but there is one data-point.. Hope this helps somebody.