10 Replies Latest reply: Jul 25, 2013 6:10 PM by thymjan
thymjan Level 1 (15 points)

Since I've updated my iPod touch 4G to iOS 6 any external GPS-device doesn't work any more with navigation software / maps.


It is curious: the native apps of the GPS-devices (tomtom and dual) show correct GPS-data, but the maps-app doesn't get this data and does not show the GPS-like pulsing circle.


And it's getting even more curious: On a newer iPod touch 4G and an iPad I've also tested the GPS-devices and it works perfectly.


I already reseted the buggy iPod touch to default values (first with iTunes backup, second with all new situation), but same behaviour.


Does anyone have an idea?



iPod touch (4th generation), iOS 6, external GPS devices
  • thymjan Level 1 (15 points)

    I've restored my iPod for several times with iTunes for Windows, the iTunes which was synced with it. No change of the ugly behaviour.


    At least the Reset with iTunes for OSX solved the problem. The GPS-data now gets to other applications.

  • icecros Level 1 (0 points)

    I have the same problem, car kit application OK, no data transmitted to TomTom or Navigon. I am working with Windows not OSX, so no future...

  • thymjan Level 1 (15 points)

    Maybe you have another Windows PC with iTunes. Perhaps this works. Or ask a friend with OSX to do the reset for you. Afterwards you put your backup on your iPod again.

  • thymjan Level 1 (15 points)

    It's annoying, I've lost the gps-functionallity again (apart the basic gps app tomtom carkit and dual gps status tool), on both iPod toch 4g I can deal with. Don't know why.

    On iPad 3 the external GPS-receiver still works.

  • Chris from Ft.Worth Level 1 (5 points)

    The problem is not with the tom-tom car Kit or the dual external GPS. The problem has to do with iOS 6 privacy settings. I have an iTouch 4 and I  been having the same problem with my GPS. I'm using the tom-tom app and the tom-tom car Kit. The solution for getting the GPS working again is. First shut down the tom-tom app or what ever app you're using. Now go to settings And General and then scroll to the bottom and tap reset. Now tap Reset location and privacy. Now load your tom-tom or navigation app And it should prompt you to turn on location service again, Say yes. Now under location services you should see The tom-tom app or the navigation app you were using and slide it to on. Now Your tom-tom app should be working correctly now, But the catch is it's only going to work until another program ask to use local services. It is definitely 100% an error an iOS 6 Privacy settings. I have no idea why it does this but you can reset and it'll work every time.

  • James T Savidge Level 1 (0 points)

    I think I may have found the critical thing that was preventing the “Reset Privacy and then reboot” process from working for me.


    I went to the settings and tuned off the automatic setting of the time. “Settings -> General -> Date & Time -> Set Automatically”


    Before turning that off, resetting the location and privacy settings and rebooting frequently did not get the interaction with the external GPS working again. I would happen on occasion, but rarely after the iOS 6.0.1 update.


    Now it seems to work every time.


    My conjecture is that when the iPod Touch restarted, and it saw that it had an internet connection, it quickly tried to set the time based on my current location. In other words, it was accessing the location without asking my permission, or telling me that it was doing so. It just assumed that it had permission. In the rare cases where it didn’t do so before I started CoPilot Live or Waze, then they would work until sometime later when a lager application would “hog” the location info.


    Can anyone else confirm if this helps, or if they have this setting turned off as well?

  • bob423423 Level 1 (0 points)

    Despite all the excellent advice, my iPad2 with XGPS150 is still not working reliably with OS 6.0.1 whereas before it was always dependable, always connecting, always receiving GPS through the XGPS150 via bluetooth. The only thing that continues to work now is a reboot of the iPad2, then the GPS signal gets through for awhile.


    Does anyone know whether the next update to the OS will fix this problem??

  • Markfh Level 1 (0 points)

    James' suggestion on 13 Dec 2012  of turning off the automatic setting of the time definitely improves the ability of my iPod Touch to work with a TomTom Car Kit for iPod Touch.  Before reading his suggestion I was having to repeatedly go though a loop of rebooting the iPod Touch until it started to "see" the GPS device.  Sometimes it would see it on first reboot, but sometimes it would take multiple restarts.  When I tried James suggestion yesterday it seemed able to see the GPS device even without having to do a restart.


    Just for the record I am using an iPod Touch 4 with a TomTom Car Kit for iPod Touch and use both Cyclemeter and MotionX-GPS.  The curoius thing is that even when neither of these two apps would report a GPS signal the TomTom Car kit tool app would report  Status = Dcoked and GPS = Fix and should the various satelites and their relative signals.   Although the TomTom Car Kit for iPod Touch is only specified for use with up to iPod Touch 3 I have used it successfully for over a year with an iPod Touch 4 with some padding above to ensure firm contact with the connector and some padding behind to activate the bar switch.

  • gplracerx Level 1 (0 points)

    Go to settings:general:about:diagnostics & usage:diagnosic & usage data and look for entries starting with iapd_ .  If you see a lot of them, your problem is that the iapd daemon is crashing.  Updating to iOS 6.1 fixed that for me.  Unfortunately, now I have another problem.  I'm trying the reset privacy settings thing to see if that works.

  • thymjan Level 1 (15 points)

    Good News!


    Today I received an email from Dual which simply fixed the problem with the external bluetooth gps receiver!


    Step-by-step instruction:

    1. Turn bluetooth-device off

    2. On iOS device go to Settings->Bluetooth and find your external gps device, tap on the blue arrow, than tap on "Forget this device"

    3. Close all applications

    4. Hold power-off-button an swipe to shut down your iOS device

    5. Turn it on again

    6. Turn on your external Bluetooth GPS-receiver

    7. Go to Settings->Bluetooth find your gps-receiver an tap on it to pair

    8. Here we go! GPS-receiving should work again!


    Thanks you guys at Dual!