Previous 1 2 Next 24 Replies Latest reply: Oct 11, 2012 6:37 AM by IT@MPCS
hoisie Level 1 Level 1

I'm trying to import a spreadsheet of redemption codes into Apple Configurator. I download the spreadsheet directly from, but when I try to import it, I get the following message:


Apple Configurator: The spreadsheet provided has redemption codes for "(null)."


What can I do to import it?

iPhone 4, OS X Mountain Lion (10.8.2)
Solved by Todd Fernandez on Oct 9, 2012 3:14 PM Solved
You should upgrade to Apple Configurator 1.2 in order to import VPP spreadsheets on 10.8.2.
Reply by IT@MPCS on Oct 11, 2012 6:37 AM Helpful
I too was having the same issue with my codes being (null).  Once I updated my configurator to 1.2 (I have Mountain Lion) it worked like a charm.  It would be nice, however that these issues are stated (other than as a complaint here) so at least I do not feel I am doing something wrong.  I just assumed I was doing it wrong, since it had been a few months from the last time I did this process. I am thankful for this site to find all those little unerving issues that arise!  Good luck!

All replies

  • naholmes Level 1 Level 1

    I'm having this exact same problem with 150 codes. Could it be a mountain lion issue? Has anybody found a fix?

  • sabel-schule Level 1 Level 1

    I'm having exactly the same problem with 50 codes for "Pages", with lion, not mountain lion.

  • Kerri Ottmer Level 1 Level 1

    Im having the issue also.  Anybody fix it?

  • DarrylZ86 Level 1 Level 1

    I'm also having the same exact issue. I have 5 difference applications with various licenses for each app and every attempt I make to upload the spreadsheet produces this exact same error message. I am also running Apple Configurator off of Mountain Lion. I attempted to remove Apple Configurator and deleted the 'user/Library/Application Support/', and re-install without any success. What's strange is this worked in the past on Mountain Lion. Very curious to find the cause and solution on this one.

  • sabel-schule Level 1 Level 1

    I've got support from Apple Germany. It seems to be a problem of version 1.1.2 of Apple Configurator and Mountain Lion 10.8.2


    As mentioned above I had the same problem using 10.7.4 and 10.7.5 and Configurator 1.1.2. Apple Germany sent me a different spreadsheet, where I've put my codes in and it worked. Strange but true.


    Other story, I bought 50 redeem codes, after installing 22 iPads it stopped, telling me that there are no more redeem codes left ?


    Good luck contacting Apple directly

  • pvcc Level 1 Level 1

    What was changed in the spreadsheet? Could it be a change we could do ourselves to the spreadsheet to make them work?

  • sabel-schule Level 1 Level 1

    I tried to make the changes, Apple Germany told me, deleting one row and one line, but it didn't work. Taking the original "handcrafted" file and copying the codes and program titles in worked. I can send you this file or make it public via Dropbox.

  • Khaoz1 Level 1 Level 1

    I am having the same issue with VPP and Mountain Lion 10.8.2 when using Apple Configurator.  Could you please share that Spreadsheet. 


  • Taopin Level 1 Level 1

    Can you make that handcrafted file available please? I am having the same issue as everyone else.

  • JAalto Level 1 Level 1

    Same problem; VPP App Purchase Spreadsheet fails (with the famed "(null)" message) to import into Apple Configurator 1.1.2 (OS X 10.8.2). Called Apple and it's a known issue with no ETA on when there will be a working update of AC.


    When I tried "Supervision - OFF" and then individually (argggh!) installing the apps the first code was already used. Thanks for the hopefully unintended ripoff Apple! And multiple Bretford iPad Cart sit.... dead in the water for now.

  • Createch170 Level 1 Level 1

    Same problem.  I have three Bretford iPad Sync Carts sitting side by side with MBPs. The first one has 10.7.4 and it works great.  The two new ones have 10.8.2 and after downloading my Pages and Codes, when I try to redeem them on Apple Configurator 1.1.2, I get:


    The spreadsheet provided has redemption codes for "(null)."


    But that is not true.


    C'mon Apple... and yes, I redownloaded the spreasheet again, and again.

  • sabel-schule Level 1 Level 1

    Try this, it worked with me, I don't know whether it works with 10.8.2


    I just copied the redemption codes and the link in the spreadsheet and the app name in full (like it is in your original file)


    Good luck!


  • Allister Banks Level 1 Level 1

    Everyone having this issue, is the app the codes for already downloaded through iTunes and imported into Configurator? Thanks, Allister

  • itapps Level 1 Level 1

    Wonderful. I'm having this issue, too. Just spoke with Enterprise Support. Yeah, it's a known issue and they've "escalated" this issue. I'm supposed to dish out iPad's in 5 days with paid apps loaded. Grrrrr. I'll be watching this thread to see if anyone has a work around.

Previous 1 2 Next