Previous 1 2 Next 24 Replies Latest reply: Oct 11, 2012 6:37 AM by IT@MPCS Go to original post
  • Allister Banks Level 1 Level 1 (0 points)

    Also, a way to further debug the error you're having is to run this command from the terminal:


    defaults write DebugLevel All








    It will generate more output into the default /var/log/system.log, which you can view using the Console application

  • pvcc Level 1 Level 1 (0 points)

    Thanks Allister, tried this but no error message that could help me resolve the issue. No problem with getting the app from iTunes and importing into Configurator, just can't import the spreadsheet with any redemption codes.


    Email Apple Australia VPP support, 3 days later got a response pointing me to their basic help files, totally ignored my question and fault completly.

    Called Apple Education support, they can't help as its a VPP problem, transfered to them, they can't help as its not an issue with the VPP site but with Configurator. They have informed me the only support is via the email i've already used, which was useless.


    So huge phone circles and nothing closer - couldn't even get anyone to understand the problem, they just want to forward my call to other departments. So it appears in Australia Apple Support have no idea of this problem.........


    So no closer to a solution. We might try the configurator on an older MacOS machine and see if we can supervise our devices from that. Will let people know how we go....

  • Kerri Ottmer Level 1 Level 1 (0 points)

    We use Meraki's free MDM.  I was able to push out keys using Meraki as a work around today.  You can add the Meraki profile using configurator, and then push out the apps.  Its an extra step, but seems to work.  The only downside, is that you have to accept the app on each iPad.

  • pvcc Level 1 Level 1 (0 points)

    Hi All,


    Finally got through to Apple Enterprise Support - they confirmed the problem is known and as yet no ETA on a resolution. Its a problem with MacOS 10.8.2. They indicated we would need to use 10.8.1 or 10.7.5


    We reinstalled OS 10.8.1 on our macbook pro which kept all of our settings/apps and instantly redeeming the codes via the spreadsheet work instantly.


    Not an ideal fix but for us gets what we want done.


    Hopefully others can do the same easily.

  • itapps Level 1 Level 1 (0 points)

    I was able to migrate my profile to another Mac running 10.8

    Imported the lic's with no problem and attached an iPad with no problem, though I have not actually applied any of my paid apps to the device, but am confident that this will work.


    Before I do any of this I'd like to try and get these settings back to my 10.8.2 Mac. Can't migrate back becuase user all ready exists. Had I know I would have migrated all settings for this user, deleted from orignal Mac and migrated back.


    Going to try a few things and will post what I learn.


    I understand that I'm using to Mac's, one with 10.8.2 and one with 10.8. Maybe this will still help some other people...

  • itapps Level 1 Level 1 (0 points)

    I'm in business. Here's what I did, using 2 (not to, from previous post) Mac's.


    1. Migrated my profile from main Mac(1) running 10.8.2 to a different Mac(2) running 10.8 < >
      1. I was selective with this process as I did not want to migrate everything. Options were obvious during the process.
    2. Opened Apple Configurator on Mac 2 and pulled in the lic’s for the paid apps
    3. Migrated profile back to Mac 1 from Mac 2, creating a new profile name on Mac 1.
    4. Copied the following files from both of my profiles from Mac 1 as backup < >
      1. ~/Library/Application Support
      2. ~/Library/Preferences/
      3. ~/Library/Keychains
    5. Copied the above files into my original profile that I started with on Mac 1 (Trying to get things back to where they should be)
    6. Note: When copying files I had to be logged in as that specific user. Not sure why I could not have full access to all folders/files with the main admin account. I’m sure there’s a way to do this, but this wasn’t worth my time to try to figure out.
    7. Hooked up the 3 iPad’s that I had working to make sure they would show as Supervised. They did. *happy*
    8. Added paid apps to one of the supervised iPad’s. Worked. Again, *happy*

    Hopefully this will get fixed in the next month so I don’t have to revisit this when buying more apps, which I will be doing soon!


    Hope this helps somebody...

  • webstr Level 1 Level 1 (0 points)

    Having the same issue with 10.8.2 (12C53) and the 10.8.2 (12C60) supplemental upgrade which was just released. Very frustrating problem.

  • Edward Escobar Level 2 Level 2 (255 points)

    This worked!!!  Thank you for posting this file!


    It seems the order number is the culprit. 

  • Todd Fernandez Level 2 Level 2 (215 points)

    You should upgrade to Apple Configurator 1.2 in order to import VPP spreadsheets on 10.8.2.

  • IT@MPCS Level 1 Level 1 (5 points)

    I too was having the same issue with my codes being (null).  Once I updated my configurator to 1.2 (I have Mountain Lion) it worked like a charm.  It would be nice, however that these issues are stated (other than as a complaint here) so at least I do not feel I am doing something wrong.  I just assumed I was doing it wrong, since it had been a few months from the last time I did this process.


    I am thankful for this site to find all those little unerving issues that arise!  Good luck!

Previous 1 2 Next