Skip navigation

Apple TV photostream "unable to sign in"??

47741 Views 164 Replies Latest reply: Oct 9, 2013 10:37 AM by andersostlund RSS
1 2 3 ... 11 Previous Next
Synist Level 1 Level 1 (0 points)
Currently Being Moderated
Sep 24, 2012 4:54 PM

Just purchased and installed Apple TV today but when I try to launch Photostream, I keep getting the same error message


" Unable to sign in  The icloud Terms of Service have changed.  For more information, go to"

which would be fine if it allowed me to read AND accept the terms and conditions. I've gone to the Terms of Service page, but there is no way to acknowledge and accept.


I've check my Login and password several times

I've restarted the Apple TV

It has the latest update

I've signed in and out of iCoud on several devices without incident, and none of them mention anything of terms of sevice change


iCloud works just fine on my iphone,ipads,and macbook pro.


I've noticed this in a few other posts, but have yet to see a satifactory answer or solution.


Any help out there?

1 2 3 ... 11 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (6)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.