Previous 1 7 8 9 10 11 12 Next 167 Replies Latest reply: Jul 1, 2015 11:26 AM by Ajisharavind Go to original post
  • belisario Level 1 (0 points)



    1. New terms are requested only in iOS6 or OSX10.8. I don't have them.

    2. I cant access to Photostream using Ethernet or WiFi.


    From now the only solution is "downgrade"


    One more thing !

    If you sign out your youtube account, probably you can't log-in again, you get a:

    "This account can not be used with Apple TV".


    So you need to activate "2-step verification" in your Google account, and then generate a new application-specific password for Apple TV.

  • rtyelland Level 1 (0 points)

    My Support ticket updated yesterday - I am told that Apple are working on another software update urgently to resolve.

    It seems to be the ethernet thats the problem as I can get functionality on Wifi but swap back to ethernet and back to square one.


    I wasted enough time trying to resolve myself and await software update - just hope its not as big a C~~~ up as 5.1

  • pips1971 Level 1 (10 points)

    I sent my Apple TV back to apple 3 generation because of this update but I think it is hardware problem. We shall see.. come on Apple sort yourselves out

  • martinsweden Level 1 (0 points)

    I upgraded from 5.0.2 to 5.1.
    I got the Photo stream problem. (not the one related to updated terms & conditions)

    I filed a support request with Apple.

    Got a few pointers from Apple, nothing really helped.

    But one thing did eventually.

    I now run 5.1 (5201) and Photo stream works believe it or not!!


    Read about my story and what I did to solve it here.

  • razvansky Level 1 (0 points)

    Hi Belisaro,


    your post did the trick. I realised I have an OS X Mountain Lion update I have postponed on my iMac.


    After the iMac restarted I went to the iCloud Control Panel in preferences and I was prompted to Accept the New Terms of Service.

    After I accepted I could see an "Update" button next to Photostream in the iCloud Panel.


    It requires me to update Aperture or iPhoto which I am doing now as it makes sense anyway to be able to access the new Phostoream Features introduced in OS6.


    Hope this helps

  • Loftee Level 1 (0 points)

    2. I cant access to Photostream using Ethernet or WiFi.

    From now the only solution is "downgrade"


    ... I don't have iOS6 or OSX10.8 on any of my devices yet.  I accidentally upgraded my Apple TV into this world and can't accept iClouds new terms of service. Has this type of Catch22 situation come up at Apple before? 


    It smells like an incentive to push me into upgrading one of my iOS5.x devices. If my conspiracy theory is true it would be truely unfair to hold a feature I have made use of in a past iOS for ransom until I upgrade.

  • tomyin67 Level 1 (0 points)

    Apple is so arrogant, it forces customers to upgrade to ios6 to use photo stream on apple tv.

    Not only arrongant but murderous by wasting milllions of people's time trying to troubleshooting the problem. why apple just simply tell us photo streaming now only assosiated with ios6? let us to decide if we want to do so?

  • davidbatesuk Level 1 (0 points)

    And if, like me, your only other Apple device is a first generation iPad, what do you do then?

  • JimmyIrl Level 1 (0 points)

    I had the same Photostream issue -  Only way I could get this to work was to update my Mac Air to OSX10.8 and was then prompted to accept new T&C's for icloud. So my "free" upgrade of Apple TV, ends up costing 15.99 euro to upgrade my laptop OS. Nice one Apple!


    Oh, and installing Windows Control panel didn't work either for those trying that.

  • Loftee Level 1 (0 points)

    If your problem is the similar to mine you can visit any OSX 10.8 mac in an Apple Store and accept iClouds new terms and conditions with the Apple ID / password you use on your Apple TV. Photo Stream will then work on your Apple TV at home. It's an easy and free workaround solution.



    I could not accept the terms and conditions on my Mac with OSX 10.6.8 (Snow Leopard) or my iOS5.1.1 devices or my Apple TV Software version 5.1 in order to use Photo Stream on my Apple TV.



    Visit an Apple Store and find a Mac with OS X v10.8.2:

    1. Choose Apple () > System Preferences.
    2. Choose View > iCloud.
    3. sign in to iCloud with the Apple ID that you use on your Apple TV
    4. After a moment, the latest iCloud Terms & Conditions should load.
    5. Read the iCloud Terms & Conditions, then select the checkbox for "I have read and agree to the iCloud Terms of Service".
    6. Click Continue.

    When complete, you should be able to access Photo Stream and related services on your Apple TV.

    The workaround solution above is a modified copy/paste of the support Article:

    Apple support UK gave me this insight that I don't need to use my own computer to accept the new terms of service.  I asked this savy support rep if she would like to add a note about the solution here on the community to ease peoples pain but she suggested that I do it myself.  This is a workaround straight from Apple to me to you. I suppose it will never be official. Note, the computer I used had a guest profile active which allowed me to log out then log in again afterwards to be sure my Apple ID and password would not be compromised.

    Good luck with this solution if you want to try it out.

  • jab894 Level 1 (0 points)

    I have accepted new T&C and I am able to access Photo Stream wirelessly, however when I plug in the Ethernet cord to the Apple TV, photo stream ceases to work.  I prefer Ethernet over wifi for my Apple TV and this problem needs to be fixed by Apple.

  • pips1971 Level 1 (10 points)

    I've sent my Apple TV third generation back to be looked at they said they had repaired it sent it back to me  . it was downgraded to the previous update. before I updated I signed into photo stream and hey presto. it worked. so I decided to do the upgrade and will update my Apple TV.  too  the latest version. when I updated I try signing in too  photo stream and photo sharing. bingo still the same fault. unable to sign in. plus it won't let me do a reinstall. I think Apple are pulling a fast one on me. what shall I do.


    .. pS. Luckily I have the Apple TV 2 And it works fine

    Any ideas

  • martinsweden Level 1 (0 points)

    That's just brutal and a behaviour that's just below the biggest company in the world. I'm quite surprised actually.

    My suggestion would be to try restoring the Apple TV via cable. I had the exact same problem and it did the trick for me.

    Here's my story and solution.

    Good luck.

  • Kypp Level 1 (0 points)

    I can't believe that this hasn't been resolved yet. I have never gotten the Terms and Conditions message... the ATV Gen 3 just says that it can't open the photo stream at this time when plugged into an Ethernet cable. If I connect to my WiFi then it works fine until I plug the cable back in.


    On a related issue. I rented a movie the other night and it was able to pay for and begin buffering for playback but the movie would not authorize while plugged in to Ethernet. I unplugged the Ethernet cable and connected to my WiFi and the rented movie immediately authoriezed and started playing back.


    There is obviously an issue with the Ethernet connection with this latest software update that needs to be resolved. I never had either of these problems with the previous software releases and I'd prefer to stay connected to Ethernet rather than WiFi, especially for streaming movies but it isn't really an option right now.

  • pips7000 Level 1 (0 points)

    how do i  revert back to 5.02