Previous 1 8 9 10 11 12 Next 166 Replies Latest reply: Sep 22, 2014 2:58 AM by Maricela Fuentes Go to original post
  • BIrdbeak Level 1 Level 1 (0 points)

    I could not get the Term of Service to show up on my iMac, PC, etc for about an hour!  Finally, I took my significant iPhone 5 (or any with IOS 6), went to icloud and sign out.  Then I logged back in and FINALLY the darn Term of Service appeared, agreed to it and it finally work!  Hope this help anyone with this problem.  Again, the key is to try different devices and log in to get the Term of Service to appear. 

  • Oswald Bastable Level 1 Level 1 (0 points)

    I upgraded to firmware 5.1.1 yesterday on my 3rd generation Apple TV, and Photo Stream (and Flickr) still do not work over Ethernet.  Interestingly enough I couldn't even get the update to install using Ethernet - I had move the Apple TV elsewhere (where there is a better signal) and use Wi-Fi.  Come on Apple, how hard can it be to fix this?

  • pips7000 Level 1 Level 1 (0 points)

    So so happy mine seems to be fixed now that update 5.1.1

    At last Apple has done something right for once

    Sign in to photo stream hey presto it works with Wi-Fi and ethernet cable

  • davidbatesuk Level 1 Level 1 (0 points)

    It's not solved mine...still the same problem 

  • Faster62 Level 1 Level 1 (0 points)

    Also 5.1.1. Update failed ( approx. 10 times during the weekend ) using LAN.

    Today I tried wLAN. First try worked ! Unbelievable !!

    Now I am back on LAN and also Photostream works..A strange fix for this issue.

  • VanAndel Level 1 Level 1 (0 points)

    The Loftee solution of Oct. 17th did the trick for me.


    Visit an Apple Store and find a Mac with OS X v10.8.2:

    1. Choose Apple () > System Preferences.
    2. Choose View > iCloud.
    3. sign in to iCloud with the Apple ID that you use on your Apple TV
    4. After a moment, the latest iCloud Terms & Conditions should load.
    5. Read the iCloud Terms & Conditions, then select the checkbox for "I have read and agree to the iCloud Terms of Service".
    6. Click Continue.

    And for security reasons afterwards 7.: change your Apple ID password afterwards on one of your own computers/tablets/phones

  • sideshowbaz Level 1 Level 1 (0 points)

    haha! 9th December 11am - just turned on Apple TV and it tells me there is a new software update! This could be the solution to the ****-up we have all been suffering. But now I'm nervous........what if it's as bad as the last update......

  • PaulD70 Level 1 Level 1 (0 points)

    I just bought a new Apple TV and immediately had to update it to 5.1.1, yet I still have the "unable to sign in" problem.  Seems like this has been going on for a few months now.  Would be nice to have a solution that doesn't involve buying a brand new cable, driving to an Apple store, or upgrading the OS to 10.8.

  • ML1980 Level 1 Level 1 (0 points)

    This is a reply to all that are having this current problem. I confirm that the only way to get the photostream working on the 3rd gen Apple TV is to unplug your ethernet cables and run on wi-fi connections. For those who have managed to get the T&C's trick to work, well done and you are lucky as I spent an absolute age trying to get this to work/happen. I gave up and unplugged the ethernet cable and setup wifi. Hey Presto it worked. For those who report a slower setup in wi-fi I am curious what hardware you have including broadband speeds.


    I live in the UK and I have 30mb cable broadband going through a Virgin Media hub. I actually find my wi-fi to give me better streaming than the ethernet connection. Strange really.

  • PaulD70 Level 1 Level 1 (0 points)

    I'm connected via wifi, not Ethernet, but still have this problem.  I bought a micro USB cable to do a forced reset with iTunes as I read about someplace.  I plan to do this next time I feel the need to muck around with my computer like I used to do with a windows machine. :-(

  • PPickles Level 1 Level 1 (0 points)

    How do you sign out of your Icloud account on your apple tv? There is no option in settings or anywhere that I see.

  • PPickles Level 1 Level 1 (0 points)

    I tried this and it did not work.

  • 409industries Level 1 Level 1 (0 points)

    Got photostream to work again on my Apple TV (5.1.1). This is another ethernet vs. wifi problem. It will only allow me to login to a photo stream over the wifi.


    Hope this gets fixed with the next 5.1.X update. I don't want to have to switch to wifi to get new pics on my screen saver. I prefer to have ethernet plugged in for fast streaming from itunes on my computer.

  • Klaus Blume Level 2 Level 2 (310 points)

    I have the same problem, and I followed Apple’s Support page for signing out of iCloud and back in again, NO AGREEMENT SCREEN CAME UP, and Apple TV still can’t sign in.


    MacOSX 10.7.5, WiFi only, never had the Ethernet connection.

  • andersostlund Level 1 Level 1 (0 points)

    Also have this problem accessing my photo stream from my Appte-TV. It's unbelievably untalented of Apple to let this happen. I only bought Apple gadgets because it (used to) "just work", because of that I accepted proprietary lock-ins and limited functionality. But the "just work" paradigm is not true anymore.

    Cannot access my photo stream from Apple-TV, Safari on iPad crashes frequently, functionality of iTunes is just a joke,...


    Seems like it's time to move on.