Skip navigation

Apple TV Death after update?

155708 Views 366 Replies Latest reply: Jan 9, 2014 1:15 PM by sigbjornU RSS Branched to a new discussion.
  • ridgessp Calculating status...
    Currently Being Moderated
    Sep 28, 2012 4:12 PM (in response to James Wishart)

    I went ahead and restored my Apple TV, then updated it to the newest version, all using my MBP. It fixed the issues completely, and all I had to do was plug the Apple TV back in, reconnect it to the internet via Wifi, then sign back into iTunes and Netflix.

     

    Try that, and see if it works.

  • James Wishart Calculating status...
    Currently Being Moderated
    Sep 28, 2012 4:14 PM (in response to ridgessp)

    Thanks for the post. I tried that earlier this afternoon and it didn't work for me. Maybe I'll try again in a few days when I have some spare to to mess around with it.

  • DucMnstr Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 28, 2012 4:45 PM (in response to RandomVillain)

    As a long time apple user and apple lover (iPhone5, iPad3, MacBook Pro, Apple TV), I am absolutely disappointed in these recent apple shortcomings.  First the new maps routing me up one way roads in Boston, now the Apple TV crashing after a routine update. Apple, please get your act together. These half baked updates are getting very, very old, very, very fast. 

     

    I purchase and recommend apple products based on the stability and foresight of the products, as do many others - this is why we pay premiums for the products.  I do NOT expect to have to tinker with and downgrade from updates, especially on the newest generation of product (apple tv 3). I am thoroughly frustrated that the most recent upgrade has temporarily rendered my Apple TV useless. This is completely unacceptable and will likely affect my future purchasing decisions if not resolved soon.

     

    I can forgive the occasional issue - the maps quirks, the new iPhone5 cable, but a bad update now? W T F.

  • DucMnstr Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 28, 2012 5:09 PM (in response to RandomVillain)

    Ironically enough, the only computer I have around tonight is my sig other's toshiba laptop. Plugged the Apple TV in to restore and received an error that the Apple TV could not be restored (error 10).  No Apple TV for me tonight. I guess I'll just plug my iPhone directly into the stereo...oh wait...I can't anymore because the old iPhone 30 pin cord is defunct.  Luckily I have a jawbone jambox that connects with Bluetooth...until apple decides to not be compatible with Bluetooth and invents their own proprietary wireless connection. Thunderbolt and lightning are already taken...how about apple rain wireless?

  • scoutts Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 28, 2012 5:44 PM (in response to James Wishart)

    Just had the same issue as James....this is very frustrating...after reading the thread i was excited i could just roll back and get back my stability...geesh...

  • Ace_Ventura Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 28, 2012 6:01 PM (in response to RandomVillain)

    I have been talking to the Apple TV team and performing some diagnostics on the unit at their request so I know they are working on the issue.

     

    At this time they have asked me to test a number of reboot scenarios and an attempt to recover the logs, none of which have resolved the issue.

     

    The fact that the unit gets an IP address via DHCP with wired connection, despite the slow flashing light, indicates to me that it is software related and not a hardware failure, however, I'm concerned that a restore to previous version does not resolve the wifi.

     

    At the very least a restore to the previous version has me working via Ethernet fixed wire.

  • Jowstir62 Calculating status...
    Currently Being Moderated
    Sep 28, 2012 7:16 PM (in response to RandomVillain)

    I tried this, with both of the restore files from the posting above and nothing.  iTunes tells me the apple tv isn't compatible with this restore version.

     

    Help?!?

     

    *** Apple?

  • Vguitar Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 28, 2012 8:13 PM (in response to w_c)

    What key do you press on a PC keyboard given there is no option key to downgrade? I have this same problem. thanks

  • willzerbillz Calculating status...
    Currently Being Moderated
    Sep 28, 2012 8:43 PM (in response to RandomVillain)

    In a weak moment I pressed the OK button to update my ATV2 - now looking at a fast blinking light.  Thanks for the help - just now ordered a six dollar micro USB cable from Amazon.  During the update, the progress bar took an awful long time and paused at several points for a few minutes.  I thought I was in trouble, and it was true.  One thing that really stinks is that the display showed an iTunes logo with a white USB cable below it, but no language at all.  A phrase or two in English, French, Japanese, Arabic, Korean, and Chinese would help to clue folks in on what the heck to do next.

  • Vguitar Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 28, 2012 8:53 PM (in response to RandomVillain)

    how come i download that AT3 5.0.2 but cant locate a .ispw file to choose in the folder?

  • Ace_Ventura Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 28, 2012 9:46 PM (in response to RandomVillain)

    SOLVED for ATV 3 v5.1 Update

     

    Background

     

    Following a software update to v5.1 (from v5.0.2) the ATV restarts and is stuck on choose your language. Selecting the language results in a black screen before the unit returns to choose your language.

     

    or

     

    Following a software update (as above) the ATV restarts and is stuck with a black screen and a slow flashing light forever.

     

    My Solution

     

    Step 1:

    Remove the fixed wire Ethernet cable and power on.

     

    Step 2:

    After selecting the language the unit will look for a wireless connection with a button called "Other". Do no press "Other" and wait for 30 secs. If you do not see a busy indicator (spinner) inside the button and no wireless networks are found press menu on your remote. Repeat pressing menu until you get to "Computer" and "Settings" main screen.

     

    or

     

    The unit powers straight up to the main menu "Computer" and "Settings"

     

    Step 3: - Be careful with this step or you'll kill your wireless! If you are unsure then get someone who knows how to configure this.

     

    Logon to your wireless modem management console.

     

    Reconfigure the wireless setting to 2.4 GHz b/g/n with a speed of up to 54 Mbps and a channel of 11. Set the security to WEP and generate a pass code.

     

    Save and wait for the modem to reconfigure.

     

    Optional: Test the new wireless configuration with a device that you know works.

     

    Step 4:

    On the ATV navigate to the settings >> General >> Network >> Wifi and Wait on the "Other" screen.

     

    For me the wireless networks started appearing at this point and I could select the one I needed and enter the pass phrase.

     

    If they don't appear - power off/on again back to menu, network, wifi, other.

     

    Step 5:

    Now plug in the fixed wire Ethernet cable and the unit no longer resets!

     

    Side note:

     

    Setting the wireless back to the original setting is now working - don't know why.

     

    My settings were originally 2.4GHz b/g/n, channel Auto, Speed up to 300Mbps, Security WPA2-PSK (AES).

     

    Hope that helps you.

  • thegirl01 Calculating status...
    Currently Being Moderated
    Sep 28, 2012 9:55 PM (in response to RandomVillain)

    Thank you so much for this post. I reverted back to 5.0.2 using the method suggested and my Apple TV is finally working again. It had been driving me crazy that it wasn't working and I couldn't work out why.

     

    Thanks again

  • qtfan1 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 29, 2012 12:05 AM (in response to Ace_Ventura)

    I couldn't restore to 5.02. I got the "This device isn't eligible for the requested build." error. I restored via itunes to 5.1 and the problem persists.

  • qtfan1 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 29, 2012 12:58 AM (in response to RandomVillain)

    Also, if I put in the ethernet wire, the screen goes blank and the light keeps flashing. I should thank Apple for killing my Apple TV with the 5.1 update.

  • Zulu Sierra Calculating status...
    Currently Being Moderated
    Sep 29, 2012 2:14 AM (in response to w_c)

    Great post followed steps and this worked for me......thanks for the attention to detail.

1 2 3 4 5 ... 25 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (23)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.