1 2 3 4 5 Previous Next 66 Replies Latest reply: Jan 28, 2014 7:49 AM by bob423423 Go to original post Branched to a new discussion.
  • 30. Re: after updating to iOS 6 gps signals are no more transmitted to tomtom or navigon
    Danom Level 1 Level 1 (0 points)

    It didn't stop, I'm mean the GPS fail... and then, one moment, I got soo mad that I've spent so much money on a device that doesn't do what it's made for: being a handy smartphone, and rocketeered the **** iPhone skyhigh to make it find the **** gps satelites.

    Unfortunately, the iPhone isn't equipped with a parachute to break the speed when coming down again.

    It was clear that the impact with mother earth was much more then it could take and the iPhone became a device. a broken device. RIP

  • 31. Re: after updating to iOS 6 gps signals are no more transmitted to tomtom or navigon
    g_mac_man Level 1 Level 1 (0 points)

    I have the same issue.  By going through the workarounds listed (disable location services, wipe privacy settings), I'm able to get the gps working 'properly', (a whole two days now)but I'm afraid to add any more aps to the location services as that is what seems to cause the problem when it occurs. 

     

    This is a nasty bug that has cost me hours of time (I thought my GPS had died), and I'm very surprised it still has not been resolved.

  • 32. Re: after updating to iOS 6 gps signals are no more transmitted to tomtom or navigon
    James T Savidge Level 1 Level 1 (0 points)

    I think I may have found the critical thing that was preventing the “Reset Privacy and then reboot” process from working for me.

     

    I went to the settings and tuned off the automatic setting of the time. “Settings -> General -> Date & Time -> Set Automatically”

     

    Before turning that off, resetting the location and privacy settings and rebooting frequently did not get the interaction with the external GPS working again. I would happen on occasion, but rarely after the iOS 6.0.1 update.

     

    Now it seems to work every time.

     

    My conjecture is that when the iPod Touch restarted, and it saw that it had an internet connection, it quickly tried to set the time based on my current location. In other words, it was accessing the location without asking my permission, or telling me that it was doing so. It just assumed that it had permission. In the rare cases where it didn’t do so before I started CoPilot Live or Waze, then they would work until sometime later when a lager application would “hog” the location info.

     

    Can anyone else confirm if this helps, or if they have this setting turned off as well?

  • 33. Re: after updating to iOS 6 gps signals are no more transmitted to tomtom or navigon
    gregfromauburn Level 1 Level 1 (0 points)

    James, you are genius. I did not think to check that setting.

     

    I turned off the automatic setting of time and now my external GPS is working much, much better. I can turn it on and off and it will recover without having to go into Location Services and turn off and on. I checked this several times and it worked everytime.

     

    It's not 100% perfect - I appear to have to cause the app to go to the background and then bring it back in order for it to reaquire the signal. But that is far less painful than having to turn location services off and on and sometimes rebooting. I'll continue checking to see how it continues to work.

  • 34. Re: after updating to iOS 6 gps signals are no more transmitted to tomtom or navigon
    Swanvestas Level 1 Level 1 (0 points)

    I'm having the same issue with my iPhone 5 on iOS 6.0.2 (10A551). When the device is plugged into my Alpine head unit in my car, TomTom looses the GPS signal and then can only get it back if I disconnect from my radio. Within 30 seconds of disconnecting, the signal GPS signal returns. I was not having this problem in iOS 6.0.1.

  • 35. Re: after updating to iOS 6 gps signals are no more transmitted to tomtom or navigon
    Markfh Level 1 Level 1 (0 points)

    James' suggestion on 13 Dec 2012  of turning off the automatic setting of the time definitely improves the ability of my iPod Touch to with a TomTom Car Kit for iPod Touch.  Before reading his suggestion I was having to repeatedly go though a loop of rebooting the iPod Touch until it started to "see" the GPS device.  Sometimes it would see it on first reboot, but sometimes it would take multiple restarts.  When I tried James suggestion yesterday it seemed able to see the GPS device even without having to do a restart. 

     

    Just for the record I am using an iPod Touch 4 with a TomTom Car Kit for iPod Touch and use both Cyclemeter and MotionX-GPS.  The curoius thing is that even when neither of these two apps would report a GPS signal the TomTom Car kit tool app would report  Status = Dcoked and GPS = Fix and should the various satelites and their relative signals.   Although the TomTom Car Kit for iPod Touch is only specified for use with up to iPod Touch 3 I have used it successfully for over a year with an iPod Touch 4 with some padding above to ensure firm contact with the connector and some padding behind to activate the bar switch.

  • 36. Re: after updating to iOS 6 gps signals are no more transmitted to tomtom or navigon
    lovethehardwarehateitunes Level 1 Level 1 (0 points)

    Loaded iOS 6.1 today and it looks like this MAY be fixed now. Plugged into TomTom with no special treatment or settings played with and once the app started it connected to the GPS fine.

    Will test it over the course of the week.

  • 37. Re: after updating to iOS 6 gps signals are no more transmitted to tomtom or navigon
    KoalaDave Level 1 Level 1 (0 points)

    I have also upgraded to iOS 6.1 (thinking that it couldn't be any worse than 6.0.2!) and so far it seems to be recognising my Dual XGPS 150A device properly.  I can't say that I have done exhaustive testing but I haven't had to reset the iPod for it to use the data from the GPS receiver in Maps, Geosphere, Camera, or Compass.  So I am cautiously hopeful that the bug has been fixed.  I will also do more testing and report back.

  • 38. Re: after updating to iOS 6 gps signals are no more transmitted to tomtom or navigon
    EvertMeijer Level 1 Level 1 (0 points)

    In iOS 6.1 a new problem appears: the GPS is allways on (indicated by the little arrow left of the bluetooth symbol). That will drain the battery.... After an off-on switch, it is still on.

  • 39. Re: after updating to iOS 6 gps signals are no more transmitted to tomtom or navigon
    icecros Level 1 Level 1 (0 points)

    You have to deactivate Localisation by hand (Settings > Privacy > Location service off)

    Then you have to authorize each desired application to use Location service and unmark all unwanted application.

     

    see : http://manuals.info.apple.com/en_US/iphone_user_guide.pdf

  • 40. Re: after updating to iOS 6 gps signals are no more transmitted to tomtom or navigon
    Mister Angry Level 1 Level 1 (10 points)

    Guys, Having upgraded to 6.1 (and subsequently 6.1.1) I too am having serious GPS issues.

     

    Using iphone 4s  with TomTom car kit tool, TomTom car kit mount and UK & Ireland 1.13. Can only get a GPS signal when parked.

     

    Once moving speed does not change, I eventually (after several hundred metres) lose GPS and get the "Poor GPS" "Waiting on GPS signal" messages.

     

    All other GPS apps (Google maps, City maps to go, GPS kit) working as expected.

     

    Any help would be greatly appreciated folks.

  • 41. Re: after updating to iOS 6 gps signals are no more transmitted to tomtom or navigon
    lovethehardwarehateitunes Level 1 Level 1 (0 points)

    Have done a number of trips and can confirm it's NOT fixed, quite!

    Let's just point out that prior to iOS6, no settings needed to be messed with for TomTom to work.

    With 6.1 installed, the iPod always connects with the little arrow in the top right and the map updates to show current location. It then freezes! Stop the app and restart it updates the map again and freezes again.

    Turn the iPod off and on, same thing. Restart the iPod and it works perfectly as many times as you like until you get home and reconnect to the internet. Once anything else has used the location services you have to do the above again!

    Big improvement over first release of 6, no settings need special settings but a reboot required.

    Therefore is is merely an improvement rather than a fix!

  • 42. Re: after updating to iOS 6 gps signals are no more transmitted to tomtom or navigon
    dZolve Level 1 Level 1 (0 points)

    My set up is identical to yours, except I'm not using the car kit tool as that seems to have been discontinued qand removed from the app store!

    In my case the TomTom app works fine until I put the phone in the mount, then it just won't launch for some reason?

    It all worked perfectly before I upgraded to 6.1.1

  • 43. Re: after updating to iOS 6 gps signals are no more transmitted to tomtom or navigon
    Mister Angry Level 1 Level 1 (10 points)

    Sorry to hear that dZlove.

     

    It appears to be a more common issue than first thought.

     

    I posted over in the TomTom forums and they say they didn't encounter anything of this nature during testing.

     

    Clearly something is wrong. I've tried restores, reboots, reinstalls - all to no affect.

     

    I just hope someone ID's the issue and manages to resolve it.

  • 44. Re: after updating to iOS 6 gps signals are no more transmitted to tomtom or navigon
    LuisValencia Level 1 Level 1 (0 points)

    I have iphone 4 with ios 6.1

    First I tested with the new google maps, when on the road, the app doesnt know where the car is pointing to, accuracy is 200m.

    Then I tried navigon thinking that it was an app problem, Navigon is better, but still says gps accuraci is like 150M, sometimes it works fine, sometimes it doesnt.

     

    So I tried tomtom europe 1.13, and the problem is there, so its a bug in the IOS and not in the apps.

     

     

    Any idea how to fix it?