Skip navigation

iPhone 5 Bluetooth Issues with Car Radio

14019 Views 18 Replies Latest reply: Nov 17, 2013 9:20 PM by Leesher RSS
1 2 Previous Next
OzTrekie Calculating status...
Currently Being Moderated
Sep 25, 2012 6:24 AM

I have a Nissan X-Trail with Bluetooth radio, since I have purchased my new iPhone 5, I have been told by any person listning that the reception is terrible, apparently sounding hollow, weak, echo somtimes, and generally noisy, however I can hear them ok. I had an iPhone 4s previously which did not exhibit these effects.

 

 

Is anyone else having weid problems with the iPhone 5 Bluetooth connected to there car radio ?

 

 

I have re-set the Wi-Fi settings, and no change, normal talking without Bluetooth is ok.

 

 

This is very frustrating for a new phone, as I require it constantly due to the amount of time I spend in my Vehicle

 

If this appears to be a common problem, I hope Apple can resolve it URGENTLY.

iPhone 5, iOS 6, 32 GB
  • Lee1963 Calculating status...
    Currently Being Moderated
    Sep 25, 2012 2:31 PM (in response to OzTrekie)

    Always had this problem on my pioneer system avic910bt. the viseeo 2 is perfect inmy other car. Parrot are supposed to be the best?

  • Viper8628 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 25, 2012 5:03 PM (in response to OzTrekie)

    Since I got my iPhone 5, I am not able to connect to my 2011 Hyundai Sonata at all. Not only do I use it frequently for phone calls, but I also like to stream music. I previously had an iPhone 4 that worked seamlessly.

  • Mike in Columbus Calculating status...
    Currently Being Moderated
    Sep 26, 2012 8:03 AM (in response to OzTrekie)

    Since upgrading to IOS 6, my expensive Kenwood car stereo has very "choppy" bluetooth connection with my iPhone 4S.  Sometimes it connects, sometimes it wont.  sometimes I have to turn off bluetooth and then turn it back on for the radio to recognize it.  I don't use the phone for music streaming like so many folks do (they are having problems with this function apparantly)  I use the bluetooth for hands free calling.  I've called Kenwood (they were already aware of it) and they said they "may" have a firmware update to work with IOS 6.  I also called AppleCare and they too said they may have an updated patch (IOS 6.1?) to fix the bluetooth disconnect.  I'm hoping either one does this soon since I need my car phone iPhone to work with my Kenwood head unit. 

  • rosturkee Calculating status...
    Currently Being Moderated
    Sep 29, 2012 10:10 PM (in response to OzTrekie)

    I have the same exact problem. I was using my iphone 4 until my wife and I upgraded recently, or at least what I thought was going to be an upgrade, and the bluetooth is not working properly. We have an Audi Q7 with built-in Bluetooth. I've tried everything but it seems the iphone 5 has yet another problem. I've reset the device and the car's bluetooth connection and still no luck, very frustrating!!

  • CookietheChef Calculating status...
    Currently Being Moderated
    Sep 30, 2012 6:57 PM (in response to OzTrekie)

    First off, when I upgraded my iPhone 4s to iOS 6, my bluetooth connection to my Pioneer DEH-80PRS worked, but I lost steering wheel control and had to use my phone for all commands... definitely frustrating, but at least it worked... The bluetooth connection to my Cobra iRadar radar detector had no apparent issues.

     

    Now with my iPhone 5 with iOS 6, I can't connect ANYTHING via bluetooth!! My Pioneer unit displays "device full" (indicating that I have more than 3 devices connected to my phone via Bluetooth) even though it's not connected to any device... and now my iRadar shows a blue light indicating a connection, but according to my phone, there's no bluetooth icon up top, and in settings, it doesn't show any such device (displays my Pioneer unit, but not connected) However, when I go to my iRadar app on my phone, it shows connection and all functions are displayed correctly!?!! The only way it can get the info from my radar detector to the app on my phone.... is via Bluetooth!

     

    Go figure.

     

    I love my phone, I'm not even having any issues with iMap on my phone (works perfectly where I live) but Apple, you're letting us down with all these "minor issues".... looks to me like you've managed to literally make a mountain out of a (lot of individual) mole hill!!!

  • Aristotle_123 Calculating status...
    Currently Being Moderated
    Oct 1, 2012 6:21 AM (in response to rosturkee)

    Same here. Lexus rx350 2011 cant connect to media player via bluetooth but phone call features work via BT. Disappointed!! Not sure if this is ip5 or ios6 issue - most likely the latter.

  • Colorado Adam Calculating status...
    Currently Being Moderated
    Oct 1, 2012 4:36 PM (in response to OzTrekie)

    2009 BMW 335i same problem.  Will connect, but not well.  Won't stay connected. 

  • Sandra Foster Level 4 Level 4 (1,460 points)
    Currently Being Moderated
    Oct 1, 2012 5:03 PM (in response to Aristotle_123)

    I have the opposite problem from yours, ARistotle_123. I have no problems at all with bluetooth media playing in my 2012 Prius, but I can't answer the phone via the handsfree system. I have to answer on the phone itself, and then the conversation automatically goes to the audio system via bluetooth. Very strange.

  • luvejaran Calculating status...
    Currently Being Moderated
    Oct 4, 2012 2:49 PM (in response to OzTrekie)

    I got my Car Radio Kenwood KDC-X996. It was totally compatible with my Iphone 4s with IOS 5.1.1. Everything worked fine my Bluetooth perfect and my Car Radio can control all function from my Iphone.
    But now I updated the new IOS 6.0 and all my issues are started. Bluetooth doesn't work at all fine, I can't access all function from the Car Radio to my Iphone. The only thing I can do is pause the music is on playing.

  • clikchic Calculating status...
    Currently Being Moderated
    Oct 8, 2012 9:55 PM (in response to OzTrekie)

    My 3GS worked just fine with our JVC after market Bluetooth stereo (KD-R526) until I upgraded to IOS 6. It wouldn't even find the Bluetooth device. Now with the iPhone 5 I am having the same problem. No matter what I do I cannot get the Bluetooth to connect or even find the Bluetooth connection.

     

    Apple, please fix ASAP!!

  • deezknotts Calculating status...
    Currently Being Moderated
    Nov 18, 2012 8:18 AM (in response to luvejaran)

    I too have the KDC-x996. Bluetooth worked fine on my iPhone 4 with 5.1 iOS. Have now have an iPhone 5 with the latest iOS (6.0.1) - Bluetooth is choppy, disconnects and unusable. I have not been able to enjoy my Bluetooth features in my vehicle.  Hopefully help is on the way from either Kenwood or Apple.  I also hope Apple can get back to us with an update.

  • Zimri_J Calculating status...
    Currently Being Moderated
    Nov 18, 2012 9:30 AM (in response to OzTrekie)

    Can't connect my iPhone 5 to the Jag either... It couldn't even find it. Had the same problem with several Bluetooth-devices. My iPod Touch could find them, the iPhone 5 can't find most of the devices...

  • David FT Level 1 Level 1 (10 points)
    Currently Being Moderated
    Dec 2, 2012 8:08 PM (in response to OzTrekie)

    Same issue , just updated from an IPhone 4 , it worked great with Mitsubishi Montero Limited 2011, even with IOS6.0, yesterday I upgraded to Iphone 5 and car system not even appear in the bluethooth options.... Incredible ....

  • chris_ruga Calculating status...
    Currently Being Moderated
    Dec 11, 2012 7:47 PM (in response to OzTrekie)

    I also have an echoing problem when trying to talk via bluetooth on my pioneer avic-940bt stereo. This is worse than my blackberry that I used to have, which at least worked properly.

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.