Previous 1 2 Next 29 Replies Latest reply: Apr 10, 2006 5:46 AM by Vipir
Vipir Level 3 (745 points)
I'm really trying to be helpful here, please try to keep that in mind.
I installed 10.4.6 and AFP mounted server volumes don't act the same anymore. Applications don't function the same anymore. SMB mounted volumes seem to work correctly, but Windows 2003 or ExtremeZ-IP AFP volumes don't work right anymore.
Applications are not seeing the server volumes correctly because the server names are truncated losing the first letter for the real server name. NetInfo edits help with AFP volumes, but not SMB volumes.
sudo nano -w /private/etc/hosts edits don't seem to do squat either.
Does anyone else have these (or some) of these issues?

Thanks for your input, it's truly appreciated.

20" iMac G5, Mac OS X (10.4.6)
  • a brody Level 9 (65,743 points)
    As others have found on Macintouch, it appears that in ExtremeZ-IP situations, using case sensitive usernames and passwords works better with 10.4.6 than case insensitive usernames and passwords. This may be an issue with how ExtremeZ-IP is handling 10.4.6's networking structure. I would contact ExtremeZ-IP's author and inform them of the issues you are having with their software on the update.
  • Vipir Level 3 (745 points)
    When I take an W2003 server and create an AFP volume (not running ExtremeZ-IP) I get the same failure issue I had with ExtremeZ-IP AFP volumes. Only when NetInfo is edited will the AFP volume work. SMB's are fine.
    I typically don't use AFP anymore only for specific legacy situations. I don't believe that ExtremeZ-IP's AFP is causing the volume issues on my Mac.
    We have 15 Mac's that are running 10.4.5 and run fine. I've taken mine to 10.4.6 and applications stop having the smooth operation as the others with respect to operating in networked environments.
    There are good people who provide a wealth of knowledge for free here, & I want to say thank you.
  • a brody Level 9 (65,743 points)
    Then it may be how your router or firewall is handling AFP on your server. Or it could be a bad networking preference or cache file, or the wrong ports open on the firewall. Since it is happening with AFP, I'd see what suggestions people have on the Getting Online and Networking board:

    I have very limited experience with AFP, only know it seems to be working fine in a computer to computer Firewire over IP network I have at home.
  • Vipir Level 3 (745 points)
    Honestly I cannot see it being the Network.
    The other 14 10.4.5 Mac's function perfectly with the same network setup. We run 2 Cisco 4506's (MDF/IDF) with internal routing in the supervior cards. Gigabit from the desktops to the data center a mile away.
  • a brody Level 9 (65,743 points)
    It may be just one piece of the network that isn't communicating right. Try moving a 10.4.5 machine onto the same ethernet cable the 10.4.6 machine is on. If that works right, then check that the network preferences are identical on both machines. If they are identical, it may be an issue simply with that computer's network chip that needs resetting (i.e. resetting the NVRAM and PRAM), a bad preference, or some software using the network simultaneously like iTunes or iPhoto sharing that is interfering with the network traffic. Try to simplify the situation as much as possible. Identify potential software conflicts first, and see if you can eliminate all of them. Then if all of them don't pass the muster work your way on up to hardware.
  • Vipir Level 3 (745 points)
    All of the Macs use the same 48 port copper Gig switch in the IDF and connect to the 4506 via fiber.
    I did read something I will try and that's downloading the combo installer and trying that. I noticed it was considerably larger than the installer I used.
    I'm going to focus on the thing that's changed rather than the hardware. I'll let you know how it goes & thanks for relaxing a bit -- it's all good.

  • Kris Hunt Level 1 (5 points)
    When I updated to 10.4.6, I got a Blue Screen of Death after restarting. I had to reinstall the entire OS and then install the update (and a bunch of other apps) before everything worked properly. Not happy.
  • a brody Level 9 (65,743 points)
    Welcome to Apple Discussions!

    That is not normal. Though what you had was not a "blue screen of death." It might have been one of the issues outlined by this article even though it is said for 10.3.9 or earlier:

    If you want to upgrade again for any specific need, see my FAQ:

    And if that doesn't help, please post a new topic telling us what you tried at this link:

    P.S. Please to any other posters here, this thread was not really a poll of asking for 10.4.6 problems. It is a thread to try and solve some AFP issues that our friend Vipir had with his system. If you have suggestions, please feel free to contribute.

    Disclaimer: Reference to links I make to my website are a for your information only type reference. I do not get any profit from this page, and it is open to the public.
  • Vipir Level 3 (745 points)
    I ran the combo installer without any change in behavior.
    PhotoShop dies after saving files to AFP volumes almost everytime.
    I have another application that is not finding the SMB mounted server name/IP resolution and it used to before.
    This applicaion is client software to a W2003 server based application.
  • a brody Level 9 (65,743 points)
    I see you have changed your profile from Uranus to the South Pole. Just a tad warmer!

    Anyway, what if you save to desktop and then copy over to the Finder those files?
  • Vipir Level 3 (745 points)
    File transfers are fine to AFP volumes on the desktop (with ExtremeZ-IP), it's when saving from PhotoShop CS2, PhotoShop crashes. The file does save, but PS has a stroke.
    My other client application scans for all the servers that are mounted and checks to see if they contain the valid data it requires. Error post saying it can't find server "BCDEFG" when the real server name is ABCDEFG.
    Very strange because in this case, the NetInfo edits only help in AFP and not with SMB mounts which is what we use for this access.
    South pole sounds better doesn't it?
  • a brody Level 9 (65,743 points)
    Ah, so it would appear that Photoshop is the outlier here, not the Finder. It is one of those crazy three way conflicts, where all three participants are necessary to make it happen. I'd let Adobe know of your issues. Not easy, but doable.
  • Vipir Level 3 (745 points)
    Well I guess that's the real puzzle.
    Either the finder isn't providing the data in the same way as 10.4.5 or somehow the applications are not reading the data through the finder the same as before.
    True that applications have to be upgraded over time to function with newer OS's, but all of the software I'm running is up to date or mainstream stuff.
  • a brody Level 9 (65,743 points)
    I understand. It just is appearing that Adobe Photoshop CS 2 may be in need of an update to correspond with the Finder in situations where AFP is running like your own. Too many cooks. Until it does, you can either as you say downgrade, or just use the Finder to make your copies instead of Photoshop. And do be sure to let Adobe know of your issues.
Previous 1 2 Next