3 Replies Latest reply: Sep 26, 2012 5:08 AM by Russ H
NeXT Computers Level 1 Level 1 (0 points)

I have a slight problem with my Final Cut installation... my Project folder is weighing in at 124 gb, with two projects. One of whom is just 20 seconds long, the other 1:30 hours. The raw files weigh in at 24 gb.

It also seems to slow my computer down to almost death. Its like its eating my RAM even when im not using it.

Would there maybe be some way to make it save to my external drive instead?

 

Here are my Specs:

iMac (2008)

4 GB RAM

320 GB HDD

2.8 GHz Intel Core 2 Duo

OS X 10.8.2

 

(Maybe this machine is a bit under the requiered specifications?)

 

Thankful for help,

NeXT


Final Cut Pro X, OS X Mountain Lion (10.8.2)
  • 1. Re: My Final Cut X Projects are quite large.
    andynick Level 5 Level 5 (4,840 points)

    This is my pet checklist for questions regarding FCP X performance - you may have already addressed some of the items but it's worth checking.

     

    Make sure you're using the latest version of the application - FCP X 10.0.5 runs very well on my 2009 MacPro 2 x 2.26 GHz Quad-Core Intel Xeon with 16 GB RAM and ATI Radeon HD 5870 1024 MB. I run it with Lion 10.7.5.

     

    First, check that you have at least 20% free space on your system drive.

     

     

    For smooth playback without dropping frames, make sure 'Better Performance' is selected in the FCP X Preferences - Playback Tab.

     

     

    If you have not already done so, move your Projects and Events to a fast (Firewire 800 or faster) external HD. Make sure the drive's formatted OS Extended (journalling's not required for video). You should always keep at least 20% free space on the Hard Drives that your Media, Projects and Events are on.

     

    Check the spec of your Mac against the system requirements:

    http://www.apple.com/finalcutpro/specs/

     

    Check the spec of your graphics card. If it's listed here, it's not suitable:

    http://support.apple.com/kb/HT4664

     

    If you are getting crashes, there is some conflict on the OS. Create a new (admin) user account on your system and use FCP X from there - if it runs a lot better, there's a conflict and a clean install of the OS would be recommended.

     

    Keep projects to 20 mins or less. If you have a long project, work on 20 min sections then paste these into a final project for export.

     

    If your playback in FCP X is not good, I strongly recommend you use ProRes 422 Proxy - it edits and plays back like silk because the files are small but lightly compressed (not much packing and unpacking to do) - but remember to select 'Original or Optimised Media' (FCP X Preferences > Playback) just before you export your movie, otherwise it will be exported at low resolution.

     

     

    The downside of 'Proxy' is that it looks awful. DON'T use Proxy when you're assessing things like video quality - especially focus.

     

    If you have plenty of processor power, for the ultimate editing experience, create Optimised Media - most camera native files are highly compressed and need a great deal of processor power to play back - particularly if you add titles, filters or effects. ProRes 422 takes up much more hard drive space but is very lightly compressed. It edits and plays back superbly.

     

     

    Personally, I work with XDCAM EX and h.264 from a Canon DSLR. Both of these run fine with my system, but I do transcode multicam clips.

     

    Hide Audio Waveforms at all times when you don't need them (both in Browser and Storyline / Timeline). They take up a lot of processor power. (Use the switch icon at the bottom-right of your timeline to select a format without waveforms if you don't need them at the moment, then switch back when you do).

     

    Create folders in the Project and Events libraries and put any projects you are not working on currently, in those folders. This will help a lot. There's a great application for this, called Event Manager X - for the tiny cost it's an invaluable application.

    http://assistedediting.intelligentassistance.com/EventManagerX/

     

    Unless you cannot edit and playback without it, turn off Background Rendering in Preferences (under Playback) - this will help general performance and you can always render when you need to by selecting the clip (or clips) and pressing Ctrl+R.

     

    The biggest single improvement I saw in performance was when I upgraded the RAM from 8 GB to 16.

    Andy

  • 2. Re: My Final Cut X Projects are quite large.
    dwarfedwombat Level 1 Level 1 (50 points)

    124 gigs of rendered media (which is stored in a project's folder) sounds a bit large for the amount of footage you have described even if the footage is HD (I'm making some assumptions here about resolution and codec). I'm guessing you have a lot of render files that are no longer in use. You can manage your render files by highlighting the project in the project library and going to File in the menu bar and selecting Delete Project Render Files. After selecting this you have the options of deleting all or just unused render files. Use this at your discretion. This will help manage the size of your project library and could be of some help with performance. You mention experiencing poor performance, but don't mention if this has always been the case or is a recent development. The above post has a lot of good info that could help, but I'm guessing your performance won't get much better with your current hardware. Hope this helps.

  • 3. Re: My Final Cut X Projects are quite large.
    Russ H Level 6 Level 6 (14,255 points)

    NeXT Computers wrote:

     

    (Maybe this machine is a bit under the requiered specifications?)

     

    Thankful for help,

    NeXT

    Afraid you're right. If you have the model I think you have, your iMac's graphics card (2600 PRO?) does not meet FCP requirements .

     

    So while it may run, it's going to require a lot of TLC in managing projects. You've got lots of great tips in the preceding posts to help you do exactly that.

     

    Good luck.

     

    Russ