Previous 1 2 3 4 5 Next 65 Replies Latest reply: Jan 31, 2016 7:48 PM by Dave SF Go to original post
  • followtheeater Level 1 (5 points)

    I ran into this issue after I unplugged my apple tv while doing some furniture rearrangement. Instead of restarting my computer. I simply turned off my wifi on my mac and then turned it back on. Worked liked a charm again.

  • bojesus Level 1 (0 points)

    sudo killall coreaudiod worked for me too!

    Thanks!

  • nadir morris habib Level 1 (5 points)

    great news , start your mac and the issue is resolved..

  • cheapmacgeek Level 1 (0 points)

    Thanks couchfries, you're awesome! Been driving me crazy since buying my Apple TV a few months ago. Yeah, sure, you can reboot the Mac, but that's not a great solution. Who wants to quit everything, reboot, and wait for everything to reload that was open. Found out you can also just quit "coreaudiod" in Activity Monitor. Make sure you're viewing All Processes. A bit easier than using the Terminal command.

  • kirkjnp Level 1 (0 points)

    Thanks cheapmacgeek. Works a treat.

    I found 2 x coreaudiod in the activity monitor and quit both. Now apple tv plays audio!

  • JFW3 Level 1 (15 points)

    I was plagued by this for a while but there IS a way to prevent it.  You can't have your video player open or minimized in the doc before you turn on airplay mirroring. If it's opened in the doc or actively running at all, you need to close it out completely by selecting quit from the toolbar.  Then you need to turn off airplay.  Once BOTH airplay and all your video programs are closed out, you can go back in and turn airplay back on. You can then open your video and sound should work. To prevent this problem in the future, you just need to make sure you turn on mirroring FIRST before opening your video player.

     

    Remember too, that with a mac, most programs including quicktime, run in the background until you actively quit them. Clicking on the red circle doesn't quit the program.  You need to select quit from the toolbar menu.

     

    This "fix" isn't ideal of course, but once you get used to the fact that you have to turn on mirroring first, its really no extra work.  You don't have to mess with any audio settings or do any restarts. It's just a matter of remembering the right order.  Hope this helps people.  

  • jboydvan Level 1 (0 points)

    Another quick way that has worked for me, if you don't get sound, turn off mirroring, turn your bluetooth on, then off. Turn mirroring back on and the audio should work. This works for me every time.

  • dgoedhard Level 1 (0 points)

    Hey ...so i'm back with the same problem. Sudo killall coreaudiod worked for awhile but now all i get when i try to do that in terminal is this:

     

    Danny-Mac:~ Danny$ sudo killall coreaudiod

    sudo: /private/etc/sudoers is mode 0644, should be 0440

    sudo: no valid sudoers sources found, quitting

    Danny-Mac:~ Danny$

     

    ...and my life is **** trying to get audio through to the tv ...gone back to restarting everything ...sometimes even having to reboot the mac. Bluetooth trick doesn't work for me either. Thanks apple for providing me with this agrevation!!!

  • nadir morris habib Level 1 (5 points)

    Mate, i know it could drive you nuts..

    Can you: 1.update your apple tv? many times these problems goes way.

                  2.reset your apple tv, simply just reste it, in many other cases it helped.

            i had an issue where my macbook pro would not allow me to use terminal..why? i forgot my stupid password..i know. i know..stupid, but hapens..

  • macmagicman Level 1 (0 points)

    Power the ATV, restart your Mac and it should recognize your TV as the audio output.

  • samuelfromkenosha Level 1 (0 points)

    Does it make any difference if the movie is a youtube video vs. something downloaded and saved in your computer's library?

  • Chris.YC Level 1 (0 points)

    hey, I got the same problem today and it fixed by simple restart your Apple TV! at least it works for me and hope it will fix all your problems!

  • glünggi Level 1 (0 points)

    Make sure all channels on your wifi are available. Or simply set it to "auto". After I made sure all the channels were selected, it went from working sometimes to working all the time.

     

    I hope this helps. 

  • Wereseal Level 1 (0 points)

    Thanks to both you and Couchfries - got it working like a dream in about 30 seconds. Appreciate it!

  • rmcoven Level 1 (0 points)

    Nice, simple solution.  It works.

    couchfries wrote:

     

    I have had the same problem. For a while now, I just restarted my mac and that fixed it. But finally I found a workaround. Try running this from the terminal : sudo killall coreaudiod