4 Replies Latest reply: Oct 5, 2012 6:09 AM by MrLingan
terminaderkhan Level 1 Level 1

*Any* download from the app store is crashing my macbook pro.  As soon as installation starts, my mac does a restart. This began with an iPhoto 9.4 update.  Then I tried downloading the DMG for it and installing it directly.  Same result.


Then I tried downloading and installing Logic Pro.  Same result.



MacBook Pro, OS X Mountain Lion (10.8.2)
  • deweyduo Level 1 Level 1

    I am having the same problem.  Any download from Apple is crashing and restarting my mid-2010 iMac 27 inch.


    With you... HELP!

  • benjaminfromfindlay Level 1 Level 1

    I am having the same problem.  Updates in the App Store crashes my new MacBook Pro 15 inch when trying to do iPhoto Update 9.4.1 and Xcode version 4.5.1 Update.



  • benjaminfromfindlay Level 1 Level 1

    Update: I rebooted my MacBook Pro into Safe Mode and ran the update in the App Store.  Everything ran smoothly without crashes.


    To start up in Safe Mode:

    • Shut down the computer
    • Wait 10 seconds (according to Apple's Help program)
    • Power on the Mac
    • After the chime of the startup sound, press and hold SHIFT


    If done correctly, you will see a progress bar at the bottom of your computer when it is starting up.  After that, login and run the update in the App Store.


    That worked for me. I hope it helps you two.

  • MrLingan Level 1 Level 1

    I am having the same problem! MBP 15, 8 GB, Early 2011, ML 10.8.2 and updating to Xcode 4.5.1


    1. Started up in Safe Mode, but could not update from Appstore. No update available.

    2. Tried from the list with all my Apps. Got message that update was availiable for an other ID. I have never changed it!

    3. So, I logged in as developer and installed from there. I did OK!

    4. Restarted normaly and checked App-store, and still got info that there is Xcode update 4.5.1 to be applied.

    5. So I did, and after about 30 minutes, it did complete OK!


    I think it was the Safe Mode installation that solved the(my) problem. The last installation from App Store, probably only checked and found out that the installation allready was done! So now App Store reallity might be true! On my machine anyway!

    I will now try it on my backupsystem. (Carbon Copy Clone on a extarnal FW-800-disk).


    I think It's a misstake to mix System-updates with App-updates. Apple might come back on this one, but now they are to busy working wirh the TimeMachine - Spoligth problem! ;-))