Previous 1 2 Next 23 Replies Latest reply: Dec 14, 2013 5:05 AM by 747-8driver Go to original post
  • 747-8driver Level 1 Level 1 (0 points)

    To me it looks like the procedure  on http://portforward.com/english/routers/port_forwarding/Dlink/DSL-G604Tv2/default guide.htm should be followed.

    Not 100% sure but try the described procedure and in stead of putting the same portnumber in "Port Map" use the "correct" portnumber.

    So on the port forwarding - advanced page select the first computer (LAN IP drop down box) and make a rule for TCP/UDP with Port Start and Port End being 3284 and Port Map 3283

    Make another one with Port Start and Port End being 5901 and Port Map 5900

    Do the same for other computers connected to the router but use the next available port: Port Start and Port End being 3285 and Port Map 3283 - Port Start and Port End being 5902 and Port Map 5900

    As explained by drtidmore "The ARD client does NOT allow the changing of the ports 5900/3283".

  • st3v1e Level 1 Level 1 (65 points)

    Thanks for the info,

     

    I'll give it a go shortly and get back to you both.

     

    Cheers

  • st3v1e Level 1 Level 1 (65 points)

    Hi again,

     

    The info you provided in the link, was basically what I've been doing for a single port forwarding machine - that works fine (this is where I first got the info - great site, but not enough info for me to setup 2 machines as I need). The setup page here is not quite the screen I see, but it's close (I don't have a "Setup" tab and the input fields for the ports look slightly different, see my screenshots on previous page)

     

    It stops short of advising now to port to two machines on the same IP, with static internal IP's.

     

    Adding a "Range" from 3283 to 3284 didn't work either and I'm no longer able to check the ports with the external port checking tool on the PortForward site.

     

    I'm still in the dark as to what I'm actually trying to achieve here?

     

    Am I:

     

    • Setting the router up to accept incoming (or is it outgoing) port 3283 ?
    • Setting up the router to accept outgoing (or is it incomming) port 5900 ?
    • Setting the router up to accept incoming/ougoing port 3284/3285 and route to 3283 ?
    • Setting the router up to accept incoming/ougoing port 5901/5902 and route to 3283 ?
    • Or maybe some other configuration.

     

    Apologies, but is port 5900 incoming or outgoing, and the same question for 3283 ?

     

    Maybe I can start here first, and get an understanding of whether the screen sharing is an incoming or outgoing port? Does my remote computer see the home Mac screen, or does the home Mac share the port - this will help me understand whether it's incoming or outgoing. Then I'll reverse the 3283 port as that will be the opposte I presume?

     

    One is a reporting port, and the other a screen sharing port I believe?

     

    Thanks

     

    Thanks

  • 747-8driver Level 1 Level 1 (0 points)

    "The ARD client does NOT allow the changing of the ports 5900/3283" so the clients will always use the 5900/3283 pair.

    So what you have to do to access multiple computers with ARD is using a different port pair for each computer.

    Computer #1 5901/3284

    Computer #2 5902/3285

    Computer #3 5903/3286

    and so on.

    How to do this: use port forwarding in your router.

    That is, tell the router to forward traffic for 5901/3284 to 5900/3283 to reach Computer #1

    and traffic for 5902/3285 to 5900/3283 to reach Computer #2 and so on.

     

    I don't know the router you are using but the setup shown on the 2 pics you posted on Dec 10, 2013 3:06 PM is not correct.

    For example, you are forwarding traffic from port 3285 to port 3285

    Instead you should forward traffic from 3285 to port 3283

     

    Those entries should look like this for Computer #1:

    Protocol     Port start     Port end     Port map     Port map end

    TCP/UDP     3284          3284             3283               3283

    TCP/UDP     5901          5901             5900               5900

     

    For Computer #2:

    Protocol     Port start     Port end     Port map     Port map end

    TCP/UDP     3285          3285             3283               3283

    TCP/UDP     5902          5902             5900               5900

     

    For Computer #3:

    Protocol     Port start     Port end     Port map     Port map end

    TCP/UDP     3286          3286             3283               3283

    TCP/UDP     5903          5903             5900               5900

     

    Then you have to assign the rules to the respective computers.

    The way to achieve this is to find the page in your router looking like this one: http://portforward.com/english/routers/port_forwarding/Dlink/DSL-G604Tv2/DSL-G60 4Tv24.jpg

    There you select the LAN IP of Computer #1 and apply the forwarding rule you just created.

    Do the same for the other computers.

  • st3v1e Level 1 Level 1 (65 points)

    474-8driver,

     

    Many thanks, that's great info and I'm beginning to understand what's going on now.

    The Mapping part was what I was missing.

     

    Just a couple of quick questions if I may:

     

    I'm using no-ip.com for my Dynamic Hosting rather than a Static IP here at home, so I'll be using my Ni-iP hostname to "find" my computers when I'm away - ie: mycomputer1.noip.com & mycomputer2.noip.com . .  so:

     

    1. Using the above Dynamic hostnames, what entries do I insert into ARD to find each of them?

    2. Can I check access to both computers from inside my LAN (ie: from inside the same location as where the others are located - at home)?

    3. How do I do that?

     

    I'm guessing, my answers will be obvious: mycomputer1.noip.com:5901 (for example), but I'd like to confirm please.

     

    Thanks so much.

  • 747-8driver Level 1 Level 1 (0 points)

    In ARD you enter the no-ip address like st3v1e.no-ip.info

    No need for different no-ip addresses as they all point to the same ip address.

    The Remote Management Port/Screen Sharing Port numbers will be 3284/5901 or 3285/5902 and so on.

    For access from within your home network there's normally no reason to change anything.

    If that doesn't work you can enter the local address in stead of the no-ip address for local access.

  • st3v1e Level 1 Level 1 (65 points)

    Update:

     

    I've just driven into town where we have a local bank with free internet access. Previously I've been able to test the access from here, but today - nothing.

     

    Not sure if it's an issue with the No-iP hosting, as I have 6 computers hosted with them, and all but 1 are showing the same IP addresses ???

     

    The one which is showing the different IP is not connected to the internet, and probably not even powered up! It may be that the IP shown was the last IP reported when it was connected.

     

    But one of the machines showing my "home" IP, is about 400 miles away, so somethings not right there for sure.

     

    Also, when I tried ot connect at the bank, I tried the following formats:

     

    mycomputer1,noip.com - no connection via ARD (using scanner/network address to find the machine at home)

    mycomputer1.noip.com:3284

    mycomputer1.noip.com:3283

    mycomputer1.noip.com:5901

    mycomputer1.noip.com:5900

     

    The last 4 tries resulted in the following pop-up message:

     

    Error-message_ARD.png

    I get the same message if I enter ":xxxx" (that's a full colon before the numbers) at the end of any dynamic hostname address I enter, or if I enter it numerically - looks like ARD doen't like that format.

     

    To add further info on my setup, here's how I'm now setting the forwarding up in the router:

     

    ARD_Quad Mapping.png

     

     

    . . . . And applying the rule like so:

     

    Screen shot 2013-12-14 at 11.34.14 AM.png

     

     

    OK that's when it stops for now.

    Thanks again for the help so far, any further help would be most appreciated.

     

    ______________________________________

     

    HI I've just seen your latest update, thanks for the confirmation of the no-ip.info entries I need.

    I've sent a support ticket to No-iP.com to see why all but one IP is the same. I had this issue about a year ago and they reset the account, and everything was OK from there. So I'll see how it goes, as I believe I've set then router up as required with your help.

     

    I'd appreciate confirmation of that from the above screenshots.

    Thanks

     

    Message was edited by: st3v1e

  • st3v1e Level 1 Level 1 (65 points)

    More testing:

     

    Using the following entries on my router:

     

    Computer #1:

    Protocol     Port start     Port end     Port map     Port map end

    TCP/UDP     3284          3284             3283               3283

    TCP/UDP     5901          5901             5900               5900

     

    For Computer #2:

    Protocol     Port start     Port end     Port map     Port map end

    TCP/UDP     3285          3285             3283               3283

    TCP/UDP     5902          5902             5900               5900

     

    I'm now showing (I checked this previously but it definitely wasn't working):

     

    Computer #1 - Ports 3284 / 5901 - open

    Computer #2 - Ports 3285 / 5902 - open

     

    So the questions is: If I "now" try to access my No-iP.com Dynamic Hostname from an external internet connection (WAN) using ARD, "should" I see each of my home machines - given that No-iP is still seeing only one IP address for my home router?

     

    Thanx

  • 747-8driver Level 1 Level 1 (0 points)

    If you have a regular home internet subscription you will have only 1 IP address.

     

    st3v1e wrote:

     

    mycomputer1.noip.com:3284

    mycomputer1.noip.com:3283

    mycomputer1.noip.com:5901

    mycomputer1.noip.com:5900

    ??

    In Remote Desktop you should use File - Add by Address

    In the window that pops up you enter your no-ip address as address (without port numbers!), your username and password and under Advanced options the correct Remote Management Port/Screen Sharing Port numbers.

    Like 3284/5901 or 3285/5902.

     

    Computer #1 - Ports 3284 / 5901 - open

    Computer #2 - Ports 3285 / 5902 - open

     

    What do you mean by "open"?

Previous 1 2 Next