Previous 1 2 Next 29 Replies Latest reply: Oct 17, 2012 3:32 AM by Dynamikemusic Go to original post
  • Dynamikemusic Level 1 (0 points)

    @t.kuerrev (and others)

    That's true! I made a clean install through recovery (cmnd+r when booting up). When OS X has finished installing I did NO software update. So it stays at 10.7.4 instead of .5. After that I installed my sound device, Logic and all plug-ins. Everything worked again with no authorization failures. I use my Mac only for producing music so for me it's no problem to choose a fresh install. It's just a few hours work. I also made some notes with all the settings I have to change. But if you have lots of other things running (and tweaked) it takes more time ofcourse.

    (http://www.logicprohelp.com/forum/viewtopic.php?f=1&t=87742)

    It's absolutely unbelievable why Apple releases an update which isn't carefully tested with Logic!

  • Dynamikemusic Level 1 (0 points)

    Forgot to say > I bought my Mac with Lion version 10.7.4. installed so don't know how a fresh install works if someone bought his Mac with an older version (for example Snow Leopard).

  • t.kuerrev Level 1 (70 points)

    Thanks for your hints, Dynamike!  In the Appstore, Lion is no more available. So I had to phone with Apple Store Germany, and they arranged that I got a version of LION. The only problem is, I don't know, which version the installer is. When it was finished, I had 10.7.5 on the harddrive. But I'm not sure, wether the system did an update itself without me watching it doing so.

     

    @ vicharmonyprodz: When I saw all those failed validations in my list of the AU-Manager, I decided to check the boxes of those, that I need urgently and frequently. So they run as "invalid", but I can open and use them. Everytime I start Logic I get that message that I run invalid plugins and that this is dangerous, making Logic crash and I might even loose data. I just ignore this message and I go on.

    Only my very old VirtualGuitarII refuses to work, it makes Logic stop playing, no sound at all. So for this, I will try to take the workaround via VIENNA Ensemble, starting the plugin there and sending the MIDI and Note information from the Logic track. I will let you know, if I was successfull.

     

    That's it for today. Have a good time!

  • Nomad_76 Level 1 (10 points)

    I upgraded to OS Mountain Lion and the problem went away! I got all of my pluggins back, and so far the operating system runs good.

     

    So in short, just do the upgrade to Mountain Lion, and it will fix your problem.

  • Nomad_76 Level 1 (10 points)

    I got it for some pluggins, about 90% of them loaded correctly. The ones from antares didnt load, my sylenth did not load, and a few others. I was really concerned about my sylenth1.

     

    But as I stated. I was desperate and tried the Mountain Lion upgrade. I had zero problems with the upgrade (so far), and all of my pluggins work now.

     

    -----

    As for your other questions, They worked fine under 10.7.4 but then I had to do a clean install. The Os I used was 10.7.5. and 10.7.5 is definitely the problem since is fixed with 10.8....

  • Dynamikemusic Level 1 (0 points)

    That's cool! But not all plug-ins will be Mountain compatible yet .. I think?

  • Jazzmaniac Level 2 (465 points)

    An apple dev admitted today on the CoreAudio mailing list that 10.7.5 contains a bug affecting AU validation. He promised a quick fix, but currently the only workaround is going to a different OS release.

     

    Cheers,

     

    Jazz

  • davidkaeser Level 1 (0 points)

    Thank you Jazz !

     

    I hope an update will come quickly...

  • EGCdigital Level 1 (0 points)

    I hope an update will come ASAP

  • Pancenter Level 6 (9,450 points)

    Jazzmaniac wrote:

     

    An apple dev admitted today on the CoreAudio mailing list that 10.7.5 contains a bug affecting AU validation. He promised a quick fix, but currently the only workaround is going to a different OS release.

     

    Cheers,

     

    Jazz

     

    Pretty obvious that Logic isn't being tested with OSX (upgrades?)

     

    This is not an insignificant error, it would bring any professional studio to an immediate halt.

  • Israel Curtis Level 1 (10 points)

    Apple just posted a "10.7.5 Supplemental Update". No mention of the validation problem - I'm going to test it anyway...

     

    http://support.apple.com/kb/DL1599?viewlocale=en_US&locale=en_US

    About OS X Lion 10.7.5 Supplemental Update

    The OS X v10.7.5 Supplemental Update is recommended for all users running OS X Lion v10.7.5 and includes the following fixes:

    • Resolves an issue that may cause Time Machine backups to take a very long time to complete
    • Addresses an issue that prevents certain applications signed with a Developer ID from launching

    The Supplemental Update is recommended if you installed the Mac OS X Lion v10.7.5 Update (build 11G56).

    It is not needed if you install the Mac OS X Lion v10.7.5 Update (build 11G63).

  • davidkaeser Level 1 (0 points)

    Thanks Israel ! This supplemental update corrects the bug !

  • Israel Curtis Level 1 (10 points)

    I can confirm - opening Audio Units Manager and clicking "Reset and Rescan" on the plugins which failed validation to this exact error now validate properly! I've had success with Arturia, Gforce, Rob Papen, Antares, and more....

     

    [got really lucky and noticed the update on macrumors literally moments before I was about to wipe my drive and clean install 10.7.4, after 5 days of installing plugins and tearing my hair out...]

  • t.kuerrev Level 1 (70 points)

    I can also confirm - on a german system 10.5.7. When I installed the supplement (via the "software update" menu), validation went the usual way.

    Thanks to Apple - although I had appreciated if someone from APPLE would have posted the availability of the supplemental update in threads like this. Or am I too demanding?? Thanks to Israel for posting it here! You are the star for today

  • Dynamikemusic Level 1 (0 points)

    How long can you go without an update? I want to keep 10.7.4 because updating and updating brings also compatible issues with (older) plug-ins.

     

    On the other hand, new plug-ins will have higher requirements.

    But that's something for the near future I think.

Previous 1 2 Next