5 Replies Latest reply: Jan 7, 2013 7:14 AM by neil.steiner Branched to a new discussion.
neil.steiner Level 1 Level 1 (0 points)

I wanted to sync my iPod touch with my Mac last night, when iTunes tried to sell me on the iOS 6 update.  I told it to go ahead with the update, and left it alone to do its thing.  When I checked again, it told me the update had failed with error 6, and that I might need to restore my iPod.  The only info I've found about error 6 pertains to Windows security software, and that clearly does not apply to my case.

 

The iPod is now stuck in recovery mode, and none of the my googling has changed that.  I have tried the various patterns of power and home keys, and have also tried downloads that were supposed to force the iPod out of recovery mode.  How exactly does an update brick a device?  Now I don't mind restoring the iPod, but I need to get my data back.  Loosing the data is not acceptable.  This is not a jailbreak attempt.  I just want my data back, and I don't mind going low-level to get it (i.e. terminal, dd, scripts, ...).  Pointers in the right direction would be greatly appreciated.

  • Flawless Knockoff Level 1 Level 1 (0 points)

    I have the same problem. And when I try to restore my iPod to factory settings via iTunes, it reinstalls the original software on the iPod and it still stays stuck in Recovery mode.

     

    Did the iOS6 update brick my device?

  • neil.steiner Level 1 Level 1 (0 points)

    I was able to extract my data and copy it to a disk image with the help of http://code.google.com/p/iphone-dataprotection/wiki/README.  This process is really only appropriate for developers, I regret to say, but for developers the process is reasonably robust.  I still had to read between the lines in one or two places, and make good use of the shell, but I am delighted to have retrieved my data from my iPod.

     

    A lower priority question for me is whether to try to collect my notes and contacts from the assorted .sqlitedb files.  It looks like iFunBox may come in handy if I try to push things back onto the iPod once I restore it.

     

    For anyone who cares to know, my iPod Touch decided to listen on port 2000 instead of port 2222, my /dev/rdisk0sXsY devices had different numbers than expected by dump_data_partition.sh, and I had to find my keychain-2.db file in /mnt2/Keychains on the data filesystem.  But it worked, and that's awesome.

  • rvbillpaid Level 1 Level 1 (0 points)

    I had the same problem.

     

    Watch this video and follow instructions. It will fix the problem.

     

    http://www.youtube.com/watch?v=chDbm4RBmL8&feature=related

     

     

  • neil.steiner Level 1 Level 1 (0 points)

    After extracting my data, I tried and tried to restore the iPod, but was unable to from my 2007 Mac Mini.  I finally tried from a PowerBook Pro running Lion, and was able to restore to a working iOS 6.

     

    I had a few difficulties when trying to push recovered data back to the iPod.  iFunBox allowed me to restore everything belonging in mobile/Media, which was great.  But even in Raw File System mode, it won't let me access mobile/Library, I think because my iPod isn't jailbroken.

     

    So I used the iphone-dataprotection approach and copied certain files back into place with ssh, and was careful to change ownership of the files back from root to mobile.  At this point, I think all of my data is back in place, but the Contacts app still shows an empty list.  I'm going to try sync-ing with my machine at home to see if that clears up the problem.  I also had to reset all of my settings, since I have no idea where that data is stored, nor how to update it.

  • neil.steiner Level 1 Level 1 (0 points)

    Correction:  After making sure that the ownership was set to "mobile" for everything in mobile/Library, the Contacts app now shows everything correctly again.  The only part I was not able to properly recover was all of my preference settings, and I have now updated those manually.

     

    In short, I used iFunBox as a convenient way to restore everything that it gave me access to in mobile/Media, and I used ssh to restore everything in mobile/Library, taking care to change the ownership from root to mobile.

     

    Using ssh is a mess because it first requires the process described in http://code.google.com/p/iphone-dataprotection/wiki/README.  If iFunBox were to expand their access to include mobile/Library, that would provide an easy way for most people to recover from the kind of situation I experienced.